Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
0 registered members (), 26 guests, and 10 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Posts: 1,253
Joined: February 2007
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 20
id242 16
JAISP 7
Naubel 2
mimoir 2
Bert 2
Slaz 1
Latest Photos
Some pictures for fun
test for attachment sizes
A gallery with animated GIFs
Lazy fox, drops, and a light house.
Welcome to poet
Previous Thread
Next Thread
Print Thread
#249069 - 05/09/12 02:04 AM i ordered a T_STRING, and all i got is this T_VARIABLE  
Joined: Jan 2007
Posts: 27
drkknght00 Offline
newbie
drkknght00  Offline
newbie

Joined: Jan 2007
Posts: 27
my boards, the lovable but cranky v7.2 over at rkmbs.com, have recently begun spitting out the following error after trying to post:

Parse error: syntax error, unexpected T_VARIABLE, expecting T_STRING in /nfs/c09/h01/mnt/131728/domains/rkmbs.com/html/scripts/showflat.inc.php on line 955

the post actually does get added, you just have to deal with the error message. any ideas what i done did...?

Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
#249070 - 05/09/12 02:05 AM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Jan 2007
Posts: 27
drkknght00 Offline
newbie
drkknght00  Offline
newbie

Joined: Jan 2007
Posts: 27
actually, check that -- it apparently shows up whilst trying to go to any topic; not limited to adding new ones

#249071 - 05/09/12 02:10 AM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Jun 2006
Posts: 1,475
gliderdad Offline
veteran
gliderdad  Offline
veteran

Joined: Jun 2006
Posts: 1,475
NY
What do you have on line 955 in showflat.inc.php?

#249072 - 05/09/12 02:15 AM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Jan 2007
Posts: 27
drkknght00 Offline
newbie
drkknght00  Offline
newbie

Joined: Jan 2007
Posts: 27
looks like...

$popups .= "<script type=\"text/javascript\">registerPopup(\"profile_popup_$Number\"); </script>";

#249073 - 05/09/12 02:21 AM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Jun 2006
Posts: 1,475
gliderdad Offline
veteran
gliderdad  Offline
veteran

Joined: Jun 2006
Posts: 1,475
NY
Give me a few to rest but it looks like you may have an extra ;. Remove the one after $Number\"); and see if it works

#249074 - 05/09/12 02:23 AM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Jan 2007
Posts: 27
drkknght00 Offline
newbie
drkknght00  Offline
newbie

Joined: Jan 2007
Posts: 27
tried, but no dice frown


#249075 - 05/09/12 02:38 AM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Jan 2007
Posts: 27
drkknght00 Offline
newbie
drkknght00  Offline
newbie

Joined: Jan 2007
Posts: 27
(and this new quick reply is awesome, btw)

#249076 - 05/09/12 02:48 AM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Jun 2006
Posts: 1,475
gliderdad Offline
veteran
gliderdad  Offline
veteran

Joined: Jun 2006
Posts: 1,475
NY
I meant remove the ; after </script>

#249077 - 05/09/12 02:58 AM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Jun 2006
Posts: 1,475
gliderdad Offline
veteran
gliderdad  Offline
veteran

Joined: Jun 2006
Posts: 1,475
NY
Actually, that is stock code. Have you edited this file at all? You may be missing a curly bracket or colon somewhere around that line

#249078 - 05/09/12 03:30 AM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Jan 2007
Posts: 27
drkknght00 Offline
newbie
drkknght00  Offline
newbie

Joined: Jan 2007
Posts: 27
it's possible I edited the file awhile back, but at least not since last august - I don't think I've touched any file in a few years. this issue just seems to have crept up in the past 24 hours

#249080 - 05/09/12 02:00 PM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Jan 2007
Posts: 27
drkknght00 Offline
newbie
drkknght00  Offline
newbie

Joined: Jan 2007
Posts: 27
unfortunately, my sleep and lack of knowledge did not fix the issue smile

could there have been something i did that would cause this to all of a sudden revolt? i used to hack a lot in the files back in the day, but like i said, i haven't touched anything in maybe 3-4 years, outside of moving servers - and even that was almost a year ago, back in august 2011

#249094 - 05/10/12 12:33 AM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Jan 2007
Posts: 27
drkknght00 Offline
newbie
drkknght00  Offline
newbie

Joined: Jan 2007
Posts: 27
woo! i'm an uber hack! smile

so, basically, i couldn't figure out what the issue was, but the entire block causing trouble here was "If it is an anonymous post, don't give a link to their profile"

and since i dont allow anonymous posts, and i don't care (that much) about profiles (until there's an upgrade)... i just commented out lines 921 through 956.

so now, all the threads work again for viewing and replying. the only issue is all the user names are text, and not links. ...but i can live with that for now! hopefully the upgrade (later this... year?) will just swap out all the bad for the good, anyway.

regardless, thanks for your assistance, gliderdad!

#249096 - 05/10/12 04:40 AM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Dec 2003
Posts: 2,032
AllenAyres Offline
Pooh-Bah
AllenAyres  Offline
Pooh-Bah

Joined: Dec 2003
Posts: 2,032
Texas
Hey Rob! Good to see you around and still breaking your forums laugh


- Allen
- ThreadsDev | PraiseCafe
#249109 - 05/10/12 10:14 PM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Jan 2007
Posts: 27
drkknght00 Offline
newbie
drkknght00  Offline
newbie

Joined: Jan 2007
Posts: 27
hah! :-p

#249115 - 05/10/12 10:27 PM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: AllenAyres]  
Joined: Jun 2006
Posts: 16,402
Gizmo Offline
UBB.threads Developer
Gizmo  Offline
UBB.threads Developer

Joined: Jun 2006
Posts: 16,402
Portland, OR; USA
Originally Posted by AllenAyres
Hey Rob! Good to see you around and still breaking your forums laugh
Isn't that what we all do best?


Forums: A Gardeners Forum
UBB.Threads: UBBWiki, UBBSkins, UBB.Sitemaps
Longtime Supporter & Beta Tester & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
#249135 - 05/11/12 04:24 PM Re: i ordered a T_STRING, and all i got is this T_VARIABLE [Re: drkknght00]  
Joined: Dec 2003
Posts: 2,032
AllenAyres Offline
Pooh-Bah
AllenAyres  Offline
Pooh-Bah

Joined: Dec 2003
Posts: 2,032
Texas
Yes smile


- Allen
- ThreadsDev | PraiseCafe

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Parse error
by VaGunTrader on 08/23/16 01:52 AM
FORBIDDEN 403 error code
by VaGunTrader on 08/23/16 12:55 AM
Uploading Photos & Mobile Capabilities???
by mimoir on 08/08/16 04:29 PM
OP can't edit his original post
by Baldeagle on 08/06/16 05:08 PM
Thread defaults to first post
by Bert on 08/04/16 07:02 PM
Forum Statistics
Forums36
Topics34,776
Posts188,658
Members11,917
Most Online978
Jun 25th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.0
(Preview build 20160824)