Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
1 registered members (Gizmo), 51 guests, and 110 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
JAISP
JAISP
Pennsylvania
Posts: 1,310
Joined: February 2007
Show All Member Profiles 
Top Posters(30 Days)
Morgan 39
Gizmo 38
isaac 35
Jake 6
NitroX 5
rfd123 4
ECNet 4
Bert 4
Latest Photos
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Coffee & Cocoa related
QHD Walls (960x800)
Previous Thread
Next Thread
Print Thread
#260011 - 04/03/17 04:47 PM Login issue  
Joined: Jun 2006
Posts: 476
Morgan Offline
addict
Morgan  Offline
addict

Joined: Jun 2006
Posts: 476
Sweden

Quote
When I open the home page, I am not logged in, and if I click on the log in link, it just refreshes the home page. If I go to the forums page, I am not logged in. I click on the log in link, and it just refreshes the forums page. If I click on your name,to send you a message, then it goes to a log in page, where I can log in. It seems like the pop up for logging in from the home page, or the forums page is not working. Everything worked fine until the crash the other day. I'm only logging in from home, and it seems to be a windows problem, as Android works fine.

Or...maybe it's just me!


See above a message from our member
Any thoughts ?


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php?
Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
#260012 - 04/03/17 08:44 PM Re: Login issue [Re: Morgan]  
Joined: Jun 2006
Posts: 16,690
Gizmo Online tapedshut
UBB.threads Developer
Gizmo  Online Tapedshut
UBB.threads Developer

Joined: Jun 2006
Posts: 16,690
Portland, OR; USA
On the Control Panel Landing Page (Dashboard), what is the date that displays for the release you're using (Snapshot Date on the right side of the page); there was an issue with the Stop Forum Spam feature in the initial release that was fixed in a refresh (the build date displays what the date the build you're running is).


Forums: A Gardeners Forum
UBB.Threads: UBBWiki, UBBSkins, UBB.Sitemaps
Longtime Supporter & Beta Tester & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
#260013 - 04/04/17 01:57 AM Re: Login issue [Re: Morgan]  
Joined: Jun 2006
Posts: 476
Morgan Offline
addict
Morgan  Offline
addict

Joined: Jun 2006
Posts: 476
Sweden
Release 20170214, Feb 14

Last edited by Morgan; 04/04/17 02:06 AM.

Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php?
#260014 - 04/04/17 02:08 AM Re: Login issue [Re: Morgan]  
Joined: Jun 2006
Posts: 16,690
Gizmo Online tapedshut
UBB.threads Developer
Gizmo  Online Tapedshut
UBB.threads Developer

Joined: Jun 2006
Posts: 16,690
Portland, OR; USA
The v7.6.0 archive was refreshed on 2017-02-23
UBB.Wiki v7.6.0 Changelog
Release Notice


Forums: A Gardeners Forum
UBB.Threads: UBBWiki, UBBSkins, UBB.Sitemaps
Longtime Supporter & Beta Tester & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
#260015 - 04/04/17 04:56 AM Re: Login issue [Re: Morgan]  
Joined: Jun 2006
Posts: 476
Morgan Offline
addict
Morgan  Offline
addict

Joined: Jun 2006
Posts: 476
Sweden
Hi Gizmo,

I know that I uploaded several files after that date due to recomendations by Isaac and possibly you.
Shall I make a complete upload of all files or are there only a few I need to upload?
What do you Think?


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php?
#260016 - 04/04/17 03:21 PM Re: Login issue [Re: Morgan]  
Joined: Jun 2006
Posts: 16,690
Gizmo Online tapedshut
UBB.threads Developer
Gizmo  Online Tapedshut
UBB.threads Developer

Joined: Jun 2006
Posts: 16,690
Portland, OR; USA
There where quite a few files changed; the only way I'd say not to upload them all is if you used a tool like BeyondCompare to check the contents.


Forums: A Gardeners Forum
UBB.Threads: UBBWiki, UBBSkins, UBB.Sitemaps
Longtime Supporter & Beta Tester & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
#260017 - 04/04/17 04:10 PM Re: Login issue [Re: Morgan]  
Joined: Jun 2006
Posts: 476
Morgan Offline
addict
Morgan  Offline
addict

Joined: Jun 2006
Posts: 476
Sweden
Gizmo I found the patch and uploaded those files. Will now wait for feedback from the member.

Thanks


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php?
#260018 - 04/05/17 04:17 AM Re: Login issue [Re: Morgan]  
Joined: Jun 2006
Posts: 476
Morgan Offline
addict
Morgan  Offline
addict

Joined: Jun 2006
Posts: 476
Sweden
Quote
No, I still have to click on someone's name to get to the log in page. It's annoying, but not terminal, so I won't worry about it. Thanks for the help.
Marlin


As you see Gizmo it didn't help to upload the patch


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php?
#260020 - 04/05/17 03:01 PM Re: Login issue [Re: Morgan]  
Joined: Jun 2006
Posts: 16,690
Gizmo Online tapedshut
UBB.threads Developer
Gizmo  Online Tapedshut
UBB.threads Developer

Joined: Jun 2006
Posts: 16,690
Portland, OR; USA
Make sure that you're not turning users away with a silent fail message, this should generally be set to "Auto With Message" so that the user can supply you with any associated error, if you have it set to "silent fail" it'll always just appear to not work.
CP -> Primary Settings -> Stop Forum Spam (tab) -> Spam Protection Level: Auto with Message

If you're running the patch all I can recommend that you do is open /scripts/login.inc.php and ensure that the Stop Forum Spam block (Lines 52-80) shows:
PHP Code
 if(($config["SFS_ENABLE"] == 1) && ($config["SFS_LEVEL"] > 2)) {
		if(function_exists("file_get_contents") && (ini_get("allow_url_fopen") == 1)) {
			$xml_string = @file_get_contents("https://www.stopforumspam.com/api?ip=". $user_ip);

			if($xml_string != false) {
				if($xml_string != "Error") {
					$xml = new SimpleXMLElement($xml_string);

					if($xml->appears == "yes") {
// Only submit to the database if there is a key supplied
						if($config["SFS_KEY"] != "") {
							PostToHost("username=". $Loginname ."&ip_addr=". $user_ip ."&email=". $Email ."&api_key=". $config["SFS_KEY"]);
						}

// Only inform the user of an error if Level 4 (Silent Fail)
						if($config["SFS_LEVEL"] == 3) {
							$html->not_right($ubbt_lang["SFS_DETECTED_LOGIN"]);
						} else {
							return array("location" => "cfrm");
						}
					}
				} else {
					return array("location" => "cfrm");
				}
			}
		} else {
			$html->not_right($ubbt_lang["SFS_ERROR_REMOTE"]);
		}
	} 


A set of coding was removed from the kludge above in the patch/refresh.


Forums: A Gardeners Forum
UBB.Threads: UBBWiki, UBBSkins, UBB.Sitemaps
Longtime Supporter & Beta Tester & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
#260022 - 04/05/17 03:30 PM Re: Login issue [Re: Morgan]  
Joined: Jun 2006
Posts: 476
Morgan Offline
addict
Morgan  Offline
addict

Joined: Jun 2006
Posts: 476
Sweden
Gizmo

I changed from silent fail to Auto and then I opened the login.inc.php and here it is. is it ok by you?

PHP Code
 if(($config["SFS_ENABLE"] == 1) && ($config["SFS_LEVEL"] > 2)) {
		if(function_exists("file_get_contents") && (ini_get("allow_url_fopen") == 1)) {
			$xml_string = @file_get_contents("https://www.stopforumspam.com/api?ip=". $user_ip);

			if($xml_string != false) {
				if($xml_string != "Error") {
					$xml = new SimpleXMLElement($xml_string);

					if($xml->appears == "yes") {
// Only submit to the database if there is a key supplied
						if($config["SFS_KEY"] != "") {
							PostToHost("username=". $Loginname ."&ip_addr=". $user_ip ."&email=". $Email ."&api_key=". $config["SFS_KEY"]);
						}

// Only inform the user of an error if Level 4 (Silent Fail)
						if($config["SFS_LEVEL"] == 3) {
							$html->not_right($ubbt_lang["SFS_DETECTED_LOGIN"]);
						} else {
							return array("location" => "cfrm");
						}
					}
				} else {
					return array("location" => "cfrm");
				}
			}
		} else {
			$html->not_right($ubbt_lang["SFS_ERROR_REMOTE"]);
		}
	} 


Oh it looks strange presented here..


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php?
#260023 - 04/05/17 11:23 PM Re: Login issue [Re: Morgan]  
Joined: Jun 2006
Posts: 16,690
Gizmo Online tapedshut
UBB.threads Developer
Gizmo  Online Tapedshut
UBB.threads Developer

Joined: Jun 2006
Posts: 16,690
Portland, OR; USA
Yeah, that's the right code; have the user go to that page now that you've turned off silent fail.


Forums: A Gardeners Forum
UBB.Threads: UBBWiki, UBBSkins, UBB.Sitemaps
Longtime Supporter & Beta Tester & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Webhost upgrade
by MichaelM. 05/19/17 06:04 PM
Gallery Links Missing & 6 Bug Reports From Users
by PianoWorld. 05/19/17 10:34 AM
Saving password
by Bert. 05/18/17 09:11 PM
Lines Missing After 7.6.0 Upgrade
by PianoWorld. 05/13/17 11:43 AM
left column to wide..
by Morgan. 05/12/17 05:56 PM
Forum Statistics
Forums36
Topics34,952
Posts190,103
Members11,992
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20170512)