Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
1 registered members (JAISP), 83 guests, and 216 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Yarp™
Yarp™
Breda, NL
Posts: 1,530
Joined: August 2006
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 27
isaac 21
Ruben 20
Morgan 6
Alento 4
M4TT 2
driv 2
Latest Photos
Test
Testing to drag photos
Comfortable Cats
Test
BSA photos
Previous Thread
Next Thread
Print Thread
Error Running ubb_upgrade.cgi #143118
03/16/01 07:36 PM
03/16/01 07:36 PM
A
Anonymous OP
Unregistered

Hi, I was following the steps to upgrade from the registered version 5.x to 6 and when I got to the step of exec the ubb_upgrade.cgi file I get an error from the apache error log:

[Fri Mar 16 13:02:13 2001] [error] (2)No such file or directory: exec of /var/www/cgi-bin/ubb_upgrade.cgi failed
[Fri Mar 16 13:02:13 2001] [error] [client 206.54.5.24] Premature end of script headers: /var/www/cgi-bin/ubb_upgrade.cgi

the perl path is correct, and the attribs are set to 755.

Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: Error Running ubb_upgrade.cgi #143119
03/16/01 08:01 PM
03/16/01 08:01 PM
A
Anonymous OP
Unregistered

Is the perl path correct?

Re: Error Running ubb_upgrade.cgi #143120
03/16/01 08:57 PM
03/16/01 08:57 PM
A
Anonymous OP
Unregistered

It says at the bottom of my message that the perl path is correct.

Re: Error Running ubb_upgrade.cgi #143121
03/16/01 09:26 PM
03/16/01 09:26 PM
A
Anonymous OP
Unregistered

No such file or directory can only mean one of a very small number of things:
Bad PERL path
umm...

If it didn't exist, you'd get a different error..

I've NEVER seen that error be ANYTHING other than a perl path..

Graeme

Re: Error Running ubb_upgrade.cgi #143122
03/16/01 11:17 PM
03/16/01 11:17 PM
A
Anonymous OP
Unregistered

I dont know what to say, all my other scripts have the same perl path, its correct, but for some reason its not working for the ubb_upgrade.cgi ?

here is my output for hello.cgi

Hello world from PERL 5.006
.cgi scripts are mapped to Perl.

Re: Error Running ubb_upgrade.cgi #143123
03/16/01 11:42 PM
03/16/01 11:42 PM
A
Anonymous OP
Unregistered

Ensure that you have uploaded all UBB6 files except images in ascii as a binary or Auto mode upload would also cause the Premature end of script headers error.

Re: Error Running ubb_upgrade.cgi #143124
03/17/01 03:57 AM
03/17/01 03:57 AM
R
Rick  Offline
Former Developer
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
You ARE installing UBB6 into the same directory that your UBB5 cgi files are in, aren't you?

Re: Error Running ubb_upgrade.cgi #143125
03/18/01 12:19 AM
03/18/01 12:19 AM
A
Anonymous OP
Unregistered

I had the same problem. Every time I tried to run ubb6_test.cgi, hello.pl, hello.cgi, or even ubb_ubgrade.cgi I'd get "command not found". The only way I was able to get this to work is by and '-w' to the perl line.

#!/usr/bin/perl -w

I ended up having to add this to all the cgi files to get ubb to work.

Re: Error Running ubb_upgrade.cgi #143126
03/19/01 06:05 PM
03/19/01 06:05 PM
A
Anonymous OP
Unregistered

Ok I am a idiot, I unziped the archive without the -a option, sorry for wasting your time guys.


Shout Box
Today's Birthdays
No Birthdays
Recent Topics
"UBB 10 years" image/button question
by Morgan. 10/22/18 09:35 AM
image test
by JPG. 10/21/18 10:06 AM
Upgrade from a really really old version
by Alento. 10/18/18 06:16 PM
Subscription Feature
by M4TT. 10/16/18 09:34 PM
PHP 7.2 compatibility
by Pak. 10/16/18 06:00 PM
Forum Statistics
Forums36
Topics35,153
Posts191,544
Members12,110
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.2