Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
1 registered members (M4TT), 80 guests, and 234 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
SteveS
SteveS
Massachusetts
Posts: 532
Joined: March 2007
Show All Member Profiles 
Top Posters(30 Days)
isaac 21
Ruben 10
Gizmo 8
Geoff 3
FREAK 2
Slaz 2
DennyP 1
Latest Photos
Testing to drag photos
Comfortable Cats
Test
BSA photos
Chinese Buddhist temple.
Previous Thread
Next Thread
Print Thread
[FIXED for 7.2] error from database when setting prefs? #182639
04/13/07 03:34 PM
04/13/07 03:34 PM
A
Andrew Bienhaus  Offline OP
member
Joined: Apr 2007
Posts: 147
Binbrook, Ontario, Canada
User on the new 7.1 threads got this:

Quote:
Andrew,

When trying to change my preferences (for example, to set the # posts per page to 99) I get the following error:

UBB Error
We encountered a problem. The reason reported was

Database error only visible to forum administrators

Please use your back button to return to the previous page.
THE ERROR IS:

Database error only visible to forum administrators


Thoughts, or things to get you more info from?


...usin' da classic UBB, since the beginning of time.
wink
Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: error from database when setting prefs? [Re: Andrew Bienhaus] #182640
04/13/07 03:40 PM
04/13/07 03:40 PM
A
Andrew Bienhaus  Offline OP
member
Joined: Apr 2007
Posts: 147
Binbrook, Ontario, Canada
Correction: multiple users having the same problem.

just fyi. smile


...usin' da classic UBB, since the beginning of time.
wink
Re: error from database when setting prefs? [Re: Andrew Bienhaus] #182650
04/13/07 04:01 PM
04/13/07 04:01 PM
Mark S  Offline
Joined: Jul 2006
Posts: 4,722
Liverpool : England : UK
Have you checked the error log via the control panel
for the sql error ?

As the output should be there.

You could also try the permissions test which
is one of the links on the left in the Control Panel.


BOOM !! Version v7.6.1.1
People who inspire me Isaac ME Gizmo
Re: error from database when setting prefs? [Re: Mark S] #182653
04/13/07 04:11 PM
04/13/07 04:11 PM
A
Andrew Bienhaus  Offline OP
member
Joined: Apr 2007
Posts: 147
Binbrook, Ontario, Canada
Permission tests all pass.

Don't see anywhere that I can check the error log in the CP...?
Ok, got it, have to enable first, and then manually check the dir, ok, will get back to you. smile

Last edited by Andrew Bienhaus; 04/13/07 04:12 PM.

...usin' da classic UBB, since the beginning of time.
wink
Re: error from database when setting prefs? [Re: Andrew Bienhaus] #182654
04/13/07 04:22 PM
04/13/07 04:22 PM
A
Andrew Bienhaus  Offline OP
member
Joined: Apr 2007
Posts: 147
Binbrook, Ontario, Canada
here we go...
Quote:
[ERROR][Fri, Apr 13 2007 16:15:36 -0400] [/forums/ubbthreads.php] [Rob Cauduro] Script: C:\Inetpub\ca.dsm.org\forums\scripts\changedisplay.inc.php - Line: 141
UPDATE ubbt_USER_PROFILE
SET
USER_START_VIEW = 'cfrm',
USER_FAVORITES_TAB = 'forums',
USER_FAVORITES_SORT = 'reply',
USER_TOPIC_VIEW_TYPE = 'flat',
USER_SHOW_AVATARS = 1,
USER_NOTIFY_ON_PM = 'yes',
USER_POSTS_PER_TOPIC = 40,
USER_TOPICS_PER_PAGE = 40,
USER_ACCEPT_PM = 'yes',
USER_TIME_FORMAT = 'Y m d | h:i a',
USER_TIME_OFFSET = 0,
USER_VISIBLE_ONLINE_STATUS = 'yes',
USER_SHOW_SIGNATURES = 'yes',
USER_STYLE = 0,
USER_UNAPPROVED_POST_NOTIFY = 0 ,
USER_HIDE_LEFT_COLUMN = 0 ,
USER_HIDE_RIGHT_COLUMN = 0 ,
USER_EMAIL_WATCHLISTS = 0 ,
USER_LANGUAGE = 'english' ,
USER_REPORT_POST_NOTIFY = '' ,
USER_RELATIVE_TIME = 1
WHERE USER_ID = 821
- Incorrect integer value: '' for column 'USER_REPORT_POST_NOTIFY' at row 1
[ERROR][Fri, Apr 13 2007 16:16:56 -0400] [/forums/ubbthreads.php] [Rob Cauduro] Script: C:\Inetpub\ca.dsm.org\forums\scripts\changedisplay.inc.php - Line: 141
UPDATE ubbt_USER_PROFILE
SET
USER_START_VIEW = 'cfrm',
USER_FAVORITES_TAB = 'forums',
USER_FAVORITES_SORT = 'reply',
USER_TOPIC_VIEW_TYPE = 'flat',
USER_SHOW_AVATARS = 1,
USER_NOTIFY_ON_PM = 'yes',
USER_POSTS_PER_TOPIC = 10,
USER_TOPICS_PER_PAGE = 10,
USER_ACCEPT_PM = 'yes',
USER_TIME_FORMAT = 'Y m d | h:i a',
USER_TIME_OFFSET = 0,
USER_VISIBLE_ONLINE_STATUS = 'no',
USER_SHOW_SIGNATURES = 'yes',
USER_STYLE = 0,
USER_UNAPPROVED_POST_NOTIFY = 0 ,
USER_HIDE_LEFT_COLUMN = 0 ,
USER_HIDE_RIGHT_COLUMN = 0 ,
USER_EMAIL_WATCHLISTS = 0 ,
USER_LANGUAGE = 'english' ,
USER_REPORT_POST_NOTIFY = '' ,
USER_RELATIVE_TIME = 1
WHERE USER_ID = 821
- Incorrect integer value: '' for column 'USER_REPORT_POST_NOTIFY' at row 1
[ERROR][Fri, Apr 13 2007 16:17:03 -0400] [/forums/ubbthreads.php] [Rob Cauduro] Script: C:\Inetpub\ca.dsm.org\forums\scripts\changedisplay.inc.php - Line: 141
UPDATE ubbt_USER_PROFILE
SET
USER_START_VIEW = 'cfrm',
USER_FAVORITES_TAB = 'forums',
USER_FAVORITES_SORT = 'reply',
USER_TOPIC_VIEW_TYPE = 'flat',
USER_SHOW_AVATARS = 1,
USER_NOTIFY_ON_PM = 'yes',
USER_POSTS_PER_TOPIC = 10,
USER_TOPICS_PER_PAGE = 10,
USER_ACCEPT_PM = 'yes',
USER_TIME_FORMAT = 'Y m d | h:i a',
USER_TIME_OFFSET = 0,
USER_VISIBLE_ONLINE_STATUS = 'yes',
USER_SHOW_SIGNATURES = 'yes',
USER_STYLE = 0,
USER_UNAPPROVED_POST_NOTIFY = 0 ,
USER_HIDE_LEFT_COLUMN = 0 ,
USER_HIDE_RIGHT_COLUMN = 0 ,
USER_EMAIL_WATCHLISTS = 0 ,
USER_LANGUAGE = 'english' ,
USER_REPORT_POST_NOTIFY = '' ,
USER_RELATIVE_TIME = 1
WHERE USER_ID = 821
- Incorrect integer value: '' for column 'USER_REPORT_POST_NOTIFY' at row 1
[ERROR][Fri, Apr 13 2007 16:17:16 -0400] [/forums/ubbthreads.php] [Rob Cauduro] Script: C:\Inetpub\ca.dsm.org\forums\scripts\changedisplay.inc.php - Line: 141
UPDATE ubbt_USER_PROFILE
SET
USER_START_VIEW = 'cfrm',
USER_FAVORITES_TAB = 'forums',
USER_FAVORITES_SORT = 'reply',
USER_TOPIC_VIEW_TYPE = 'flat',
USER_SHOW_AVATARS = 1,
USER_NOTIFY_ON_PM = 'yes',
USER_POSTS_PER_TOPIC = 10,
USER_TOPICS_PER_PAGE = 10,
USER_ACCEPT_PM = 'yes',
USER_TIME_FORMAT = 'Y m d | h:i a',
USER_TIME_OFFSET = 0,
USER_VISIBLE_ONLINE_STATUS = 'yes',
USER_SHOW_SIGNATURES = 'yes',
USER_STYLE = 0,
USER_UNAPPROVED_POST_NOTIFY = 0 ,
USER_HIDE_LEFT_COLUMN = 0 ,
USER_HIDE_RIGHT_COLUMN = 0 ,
USER_EMAIL_WATCHLISTS = 0 ,
USER_LANGUAGE = 'english' ,
USER_REPORT_POST_NOTIFY = '' ,
USER_RELATIVE_TIME = 1
WHERE USER_ID = 821
- Incorrect integer value: '' for column 'USER_REPORT_POST_NOTIFY' at row 1
[ERROR][Fri, Apr 13 2007 16:20:37 -0400] [/forums/ubbthreads.php] [Rob Cauduro] Script: C:\Inetpub\ca.dsm.org\forums\scripts\modifypost.inc.php - Line: 455
update ubbt_POSTS
set POST_SUBJECT = 'Re: New Forum Program....' ,
POST_BODY = ' <img src=\"http://www.fox-obel.com/images/cheese.jpg\" alt=\"\" /> <br /><br />There ya go Strelecki <img src=\"/forums/images/graemlins/default/smile.gif\" alt=\"\\:\\)\" title=\"smile\" height=\"15\" width=\"15\" />' ,
POST_DEFAULT_BODY = ' [Linked Image] \r\n\r\nThere ya go Strelecki :)',
POST_ICON = 'book.gif' ,
POST_LAST_EDITED_TIME= '' ,
POST_LAST_EDIT_REASON = '' ,
POST_LAST_EDITED_BY = 'Rob Cauduro' ,
POST_ADD_SIGNATURE = 1 ,
POST_HAS_FILE = 0

where POST_ID = 228217
- Incorrect integer value: '' for column 'POST_LAST_EDITED_TIME' at row 1
[ERROR][Fri, Apr 13 2007 16:20:43 -0400] [/forums/ubbthreads.php] [Rob Cauduro] Script: C:\Inetpub\ca.dsm.org\forums\scripts\modifypost.inc.php - Line: 455
update ubbt_POSTS
set POST_SUBJECT = 'Re: New Forum Program....' ,
POST_BODY = ' <img src=\"http://www.fox-obel.com/images/cheese.jpg\" alt=\"\" /> <br /><br />There ya go Strelecki <img src=\"/forums/images/graemlins/default/smile.gif\" alt=\"\\:\\)\" title=\"smile\" height=\"15\" width=\"15\" />' ,
POST_DEFAULT_BODY = ' [Linked Image] \r\n\r\nThere ya go Strelecki :)',
POST_ICON = 'book.gif' ,
POST_LAST_EDITED_TIME= '' ,
POST_LAST_EDIT_REASON = '' ,
POST_LAST_EDITED_BY = 'Rob Cauduro' ,
POST_ADD_SIGNATURE = 1 ,
POST_HAS_FILE = 0

where POST_ID = 228217
- Incorrect integer value: '' for column 'POST_LAST_EDITED_TIME' at row 1


...usin' da classic UBB, since the beginning of time.
wink
Re: error from database when setting prefs? [Re: Andrew Bienhaus] #182655
04/13/07 04:23 PM
04/13/07 04:23 PM
A
Andrew Bienhaus  Offline OP
member
Joined: Apr 2007
Posts: 147
Binbrook, Ontario, Canada
<LOL>
Excuse the cheese... they were whining, and someone offered up some cheese to go with it.


...usin' da classic UBB, since the beginning of time.
wink
Re: error from database when setting prefs? [Re: Andrew Bienhaus] #182656
04/13/07 04:43 PM
04/13/07 04:43 PM
A
Andrew Bienhaus  Offline OP
member
Joined: Apr 2007
Posts: 147
Binbrook, Ontario, Canada
and, it almost looks like it's also having an issue updating the last post time??


...usin' da classic UBB, since the beginning of time.
wink
Re: error from database when setting prefs? [Re: Andrew Bienhaus] #182657
04/13/07 04:44 PM
04/13/07 04:44 PM
Mark S  Offline
Joined: Jul 2006
Posts: 4,722
Liverpool : England : UK
pmsl at the cheese..

2 things well 3.

1. Watch for a fella called Rick to come on line. (He built Threads)
2. Start a support ticket with your login info and so on.
3. I cant help as ive havent seen that error before.


BOOM !! Version v7.6.1.1
People who inspire me Isaac ME Gizmo
Re: error from database when setting prefs? [Re: Mark S] #182658
04/13/07 04:57 PM
04/13/07 04:57 PM
A
Andrew Bienhaus  Offline OP
member
Joined: Apr 2007
Posts: 147
Binbrook, Ontario, Canada
Will do.
Have done.
No problem.

wink


...usin' da classic UBB, since the beginning of time.
wink
Re: error from database when setting prefs? [Re: Andrew Bienhaus] #182667
04/13/07 07:33 PM
04/13/07 07:33 PM
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,956
Portland, OR; USA
Sounds like the MySQL Strict issue I think...

see the bottom part of this thread here


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: error from database when setting prefs? [Re: Gizmo] #182673
04/13/07 09:06 PM
04/13/07 09:06 PM
A
Andrew Bienhaus  Offline OP
member
Joined: Apr 2007
Posts: 147
Binbrook, Ontario, Canada
Yes, my first thought as well, but as you can see by that other thread, I've already entered that command once to relax things, or else the import never would have run.

It's not like I have to enter it and save it, or anything like that, is it?


...usin' da classic UBB, since the beginning of time.
wink
Re: error from database when setting prefs? [Re: Andrew Bienhaus] #182676
04/13/07 09:16 PM
04/13/07 09:16 PM
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,956
Portland, OR; USA
Lol didn't read the thread to see if it where you, simply used the search and posted the link wink...

Well, if it isn'tthat, I'm not sure, will likely have to wait for Ricky wink


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: error from database when setting prefs? [Re: Gizmo] #182677
04/13/07 10:30 PM
04/13/07 10:30 PM
R
Rick  Offline
Former Developer
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
Definitely looks like it's still the strict mode issue. One thing about this, when run it only holds the change until MySQL is restarted or reloaded. If it has been restarted, then you'll want to run that command again.

I've set my devel box to run in strict mode so I can make sure all of these are caught for the 7.1.1 update.

Re: error from database when setting prefs? [Re: Rick] #182695
04/14/07 07:05 AM
04/14/07 07:05 AM
A
Andrew Bienhaus  Offline OP
member
Joined: Apr 2007
Posts: 147
Binbrook, Ontario, Canada
ok, so is there a way to save this setting?

Or, are you saying that the UBB should be dealing with this, and in 7.1.1 you will have resolved it, and I won't have to do it any more?

thanks...


...usin' da classic UBB, since the beginning of time.
wink
Re: error from database when setting prefs? [Re: Andrew Bienhaus] #182701
04/14/07 11:34 AM
04/14/07 11:34 AM
R
Rick  Offline
Former Developer
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
I believe you can add something to your mysqld startup script that stores the default settings. However, this is something that UBB should be dealing with as more and more sites upgrade to MySQL 5 and strict mode is the default.

Re: error from database when setting prefs? [Re: Rick] #182704
04/14/07 01:19 PM
04/14/07 01:19 PM
A
Andrew Bienhaus  Offline OP
member
Joined: Apr 2007
Posts: 147
Binbrook, Ontario, Canada
Ok, will keep putting it in after reboots, until 7.1.1 hits the street.

Thanks...


...usin' da classic UBB, since the beginning of time.
wink

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
UBB.threads 7.6.2 - Released
by isaac. 09/17/18 08:08 AM
7.6.2 Changelog Discussion
by isaac. 09/17/18 06:35 AM
Upgrade Documentation
by DennyP. 09/15/18 03:55 PM
PHP 7.2
by Geoff. 09/12/18 10:22 PM
Email Cleanup-Is it possible?
by Ruben. 09/06/18 11:25 AM
Forum Statistics
Forums36
Topics35,139
Posts191,439
Members12,106
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.2