Previous Thread
Next Thread
Print Thread
Hop To
Joined: Nov 2006
Posts: 9
cass Offline OP
stranger
OP Offline
stranger
Joined: Nov 2006
Posts: 9
Gizmo has been working on my forums. I asked him to take a look at a problem with .pdf attachments that give an Adobe error when accessed, while the same .pdf file, transferred to server via ftp is fine.

This started with 7.3.1 and continues with the upgrade to 7.4.1.

I'm linking to two threads that Gizmo tested which show the problem.

Thread 1

Thread 2


Joined: Jun 2006
Posts: 15,966
Likes: 38
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,966
Likes: 38
Originally Posted by Gizmo
I upload the file, when I try to open it through the link the forum provides it errors (clicky).

I ftp download the file, and open it, opens fine (thus it uploaded fine).

I use the direct link (clicky) and it works fine.

I'm not entirely sure of the issue, but since the link works when accessed directly, it leads me to think it has to be something with the redirector to the file in the UBB; BUT it just redirects to the file on the server...

Leads me to think, you may have to file a bug report at UBBCentral...


Originally Posted by Gizmo (EMail)
The ubb stores their names in the database, and the files as a number with whatever extension the file is... I posted a test on the same forum you linked me to as well as basically saying you need to post a bug report; feel free to quote what I said and/or link to the posting on your bug report.

Basically, the redirector reads the URL you link to it, and it looks up the associated file in the database, then sends the file to the user with a header of what the name should be and the browser does the rest; I'm thinking that something in the whole request is causing the issue (as the file exists properly on the server since linking to it directly on its actual location works)


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Dec 2003
Posts: 6,207
Likes: 31
Online Yawn
Joined: Dec 2003
Posts: 6,207
Likes: 31
After reading this post I tested this on my ver7.4.1.
Using two different computers and ie7 and firefox3.
When I upload a pdf file about 200k it uploads in less that two seconds. When I try to open or save the file in the post I don't get a error but it takes at least 5 to 6 minutes to complete.
If I try a image file it performs very fast.
I also tried a word.doc file same issue
I am not talking about the time the application takes to display the file but how long the file takes to download to the browser.
Typing the url directly in my browser the file opens almost in an instant less than a second.
So there must be some type of issue that it takes so long.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Jun 2006
Posts: 15,966
Likes: 38
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,966
Likes: 38
have you tried opening the document? The request gets sent just fine, but the document downloaded is currupt when downloading through the UBB... When accessing via actual server URL (and not the UBB) it works fine.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Dec 2003
Posts: 6,207
Likes: 31
Online Yawn
Joined: Dec 2003
Posts: 6,207
Likes: 31
Yes the file opens just fine. In fact I tried a 1mb pdf.
My issue is when downloading the status shows nothing is downloading % shows 0 but it takes at least 6 minutes to download a file even if the file is 100kb or 1 mb takes the same amount of time.
If I was not testing this I would have canceled the operation as a user because it looks like it is not working at all and it takes way to long.

There is something wrong with this process for sure.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Jun 2006
Posts: 9,242
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,242
I think we need to change the way pdf documents are handled in downloads. I'll need to do a couple tests with this.


Link Copied to Clipboard
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
What triggers page view numbers
by Morgan - 09/21/2020 10:31 AM
Forum Permissions Question
by FREAK - 09/20/2020 2:13 PM
Moving UBBthreads Between Servers
by DennyP - 09/19/2020 7:55 PM
Member Log In/Password Issues
by FREAK - 09/19/2020 12:13 PM
[FIXED for 7.7.5] Broken CP Link
by JAISP - 09/17/2020 3:22 PM
Who's Online Now
4 members (Mors, Daryl Fawcett, Ruben, Gizmo), 52 guests, and 55 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.5
(Snapshot build 20200921)