Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
6 registered members (Ruben, Gizmo, JAISP, isaac, Outdoorking, jbergmann), 50 guests, and 391 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Posts: 756
Joined: June 2006
Show All Member Profiles 
Top Posters(30 Days)
isaac 53
Gizmo 41
Geoff 32
Morgan 30
ECNet 17
Ruben 12
Mark S 11
JAISP 10
Bert 8
Latest Photos
Chinese Buddhist temple.
My buddha beads.
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Previous Thread
Next Thread
Print Thread
Install Goes ok, but Clicking on "Admin" results in error #23068
07/17/02 04:45 PM
07/17/02 04:45 PM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


I have been able to register my first user, but once I have logged in, and click the "Admin" link at the top left left of the screen, I get the following error:

Warning: Failed opening './ubbt.inc.php' for inclusion (include_path='') in /home/www/massassimilation/ubbthreads/main.inc.php on line 8

Fatal error: Cannot instantiate non-existent class: user in /home/www/massassimilation/ubbthreads/admin/login.php on line 27

I am at the following URL when this occurs:
/ubbthreads/admin/login.php?Cat=

Any thoughts?

Re: Install Goes ok, but Clicking on "Admin" results in error #23069
07/17/02 06:24 PM
07/17/02 06:24 PM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


FTP to your server and check your config.inc.php file for the proper paths in all the standard locations - in this case the Installation directory may be off.

Regards,

Brett Harris
Infopop Corporation

Re: Install Goes ok, but Clicking on "Admin" results in error #23070
07/18/02 08:25 AM
07/18/02 08:25 AM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


Brett, thanks for the tip, but I looked, and everything is where it is supposed to be as far as I can tell. Let me know if you see anything that is "off."


// Path and Url variables

// Url to the main UBB.threads php install
$config['phpurl'] = "http://www.massassimilation.net/ubbthreads";

// Absolute Url containing the images
$config['images'] = "/ubbthreads/images";

// Path to your images directory, needed for calculating image sizes
$config['imagepath'] = "./images";

// Url to your stylesheets directory
$config['styledir'] = "/ubbthreads/stylesheets";

// Path to your UBB.threads php install
$config['path'] = "./";

// Path to your stylesheets directory
$config['stylepath'] = "./stylesheets";

// Domain that ubbthreads is running under.
$config['referer'] = "http://www.massassimilation.net";

Re: Install Goes ok, but Clicking on "Admin" results in error #23071
07/18/02 10:55 AM
07/18/02 10:55 AM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


These 3 will need to be changed to reflect the full path from the root directory (ie. "/home/ubbthreads"):

// Path to your images directory, needed for calculating image sizes
$config['imagepath'] = "./images";

// Path to your UBB.threads php install
$config['path'] = "./";

// Path to your stylesheets directory
$config['stylepath'] = "./stylesheets";

-------------------
Rick Baker
UBBThreads developer

Re: Install Goes ok, but Clicking on "Admin" results in error #23072
07/18/02 01:43 PM
07/18/02 01:43 PM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


Rick,

I'm trying not to be a half-witt, but I think I am failing.

I replaced my relative paths with the path in the directory structure of the server to the files. That path on my server is /home/www/massassimilation/ubbthreads/ . that didn't quite work either.

I guess I am missing something really obvious here.

In my trials this time, I decided to stick a "/" at the end of the path, and got this error message on the page previous to the Admin page [that I am not getting to].

Warning: readfile("/ubbthreads//includes/header-insert.php") - No such file or directory in /home/www/massassimilation/ubbthreads/ubbt.inc.php on line 144

This is really interesting (while clearly also not being the solution), because this time, it references "/home/www/massassimilation" which I have not specified in config.inc.php. As you can see, I am just grasping for straws here.

I would just shut up and buy the product right away except that I need to make sure it works with my hosting situation.

Re: Install Goes ok, but Clicking on "Admin" results in error #23073
07/18/02 03:15 PM
07/18/02 03:15 PM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


consider removing the . from the front of the paths.

Regards,

Brett Harris
Infopop Corporation

Re: Install Goes ok, but Clicking on "Admin" results in error #23074
07/18/02 03:51 PM
07/18/02 03:51 PM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


Brett,

Tried that. Was one of many tests.

When I try (/ubbthreads , /ubbthreads/stylesheets, and /ubbthreads/images ) I get the following error message:

Warning: readfile("/ubbthreads/includes/header-insert.php") - No such file or directory in /home/www/massassimilation/ubbthreads/ubbt.inc.php on line 144.

Re: Install Goes ok, but Clicking on "Admin" results in error #23075
07/18/02 05:25 PM
07/18/02 05:25 PM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


And of course, those files and directories are present.

Re: Install Goes ok, but Clicking on "Admin" results in error #23076
07/18/02 05:36 PM
07/18/02 05:36 PM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


Have you chmodded the directories to 777?

Regards,

Brett Harris
Infopop Corporation

Re: Install Goes ok, but Clicking on "Admin" results in error #23077
07/19/02 10:43 AM
07/19/02 10:43 AM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


Brett,

Yes, I followed the install instructions. I have subsequently tested the environment with all the directories set at 777. No luck.

Re: Install Goes ok, but Clicking on "Admin" results in error #23078
07/19/02 04:13 PM
07/19/02 04:13 PM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


I give up. I just installed it on a server that has what I perceive to be a more "forward" organization.

The install "script" picked up the paths just fine by itself.

Thanks for the assistance. I hope I never have to install this product on an server offered by that host.

Re: Install Goes ok, but Clicking on "Admin" results in error #23079
07/27/02 02:29 AM
07/27/02 02:29 AM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


I'm having the same proble also
"Warning: Failed opening './ubbt.inc.php' for inclusion (include_path='') in /home/www/massassimilation/ubbthreads/main.inc.php on line 8
"
My config file looks like this
// Url to the main UBBThreads php install
$config['phpurl'] = "http://192.168.123.22/ubbthreads";

// Relative Url containing the images
$config['images'] = "./images";

// Path to your images directory, needed for calculating image sizes
$config['imagepath'] = "./images";

// Url to your stylesheets directory
$config['styledir'] = "./stylesheets";

// Path to your UBBThreads php install
$config['path'] = "./";

// Path to your stylesheets directory
$config['stylepath'] = "./stylesheets";

// Domain that ubbthreads is running under.
$config['referer'] = "http://192.168.123.22";

I have the "sessions" folder above the root directory. with everyone full access.

What am I doing wrong?

Re: Install Goes ok, but Clicking on "Admin" results in error #23080
07/26/02 03:10 PM
07/26/02 03:10 PM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


Why oh why oh why don't Infopop tell people to use the "realpath" function to determine their correct path settings????????

How many times do I have to suggest this? <img border="0" title="" alt="[Confused]" src="images/icons/confused.gif" /> Or do you guys enjoy seeing folk have the same problems with path settings time after time after time ...........?

Running the following:
<?
$path = realpath ("./");
print $path;
?>
gets the system to tell you what the path is to the folder from which the script is run.

Dave Anderson
http://www.pctechguide.com

Re: Install Goes ok, but Clicking on "Admin" results in error #23081
07/29/02 09:25 AM
07/29/02 09:25 AM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


Dave,

Thanks for that - for the most part that's not that hard to do - however sometimes the folders are virtual so the remaining paths can be a trick.

Turk - you may want to start a new thread on this subject unless you have already done so - that will assure that we know that it's only you on that thread.

Regards,

Brett Harris
Infopop Corporation

Re: Install Goes ok, but Clicking on "Admin" results in error #23082
07/29/02 09:52 AM
07/29/02 09:52 AM

A
Anonymous OP
Unregistered
Anonymous OP
Unregistered
A


Thanks Brett

Just trying to help!

Paths were the one thing that I had problems with when I first installed UBBT. Furthermore, for those of us on a hosted server, it can be a very difficult question to get answered. I guess the number of queries you guys get on the subject is testimony to that.

The PHP "realpath" function was my salvation - I figured it might be to many others too!

Dave Anderson
http://www.pctechguide.com


Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Upgrading from 7.6.0 to 7.6.1
by Baldeagle. 01/20/18 01:07 PM
Odd behavior with marking forums as read
by Baldeagle. 01/20/18 12:51 PM
Subscription Pending Auto Update to Active
by Geoff. 01/18/18 09:04 AM
7.6.1.1 Custom Tag Editor (YouTube)
by Mark S. 01/15/18 02:58 PM
Enable Spider Friendly Urls Issues
by Geoff. 01/15/18 11:32 AM
Forum Statistics
Forums36
Topics35,049
Posts190,782
Members12,051
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1.1