Previous Thread
Next Thread
Print Thread
Hop To
Joined: Apr 2008
Posts: 33
R
Rascal Offline OP
newbie
OP Offline
newbie
R
Joined: Apr 2008
Posts: 33
A couple of days ago we moved to a new server and upgraded from 7.5.3 to 7.5.5, and since then are experiencing a couple of problems.

1) When viewing a forum, a thread that has any new replies shows the yellow folder and red number as expected. But when clicking on the subject of such a thread, the user is taken to the top of the thread rather than to the first unread reply as he should be.

2) The new post indicators are disappearing when they shouldn't. For instance, user enters a forum where a number of threads properly have the yellow folder and red number indicating new replies. He clicks on the subject of one thread, reads it, then returns to the same forum via breadcrumb link or the "Hop to" menu, and the other unread threads no longer have the new post indicators.

What do we need to do to get these features working properly again?


Running UBB.threads 7.5.5 as of May 23 2010
Joined: Dec 2003
Posts: 6,278
Likes: 45
Online Yawn
Joined: Dec 2003
Posts: 6,278
Likes: 45
If I understand item 2 it has been a bone of contention for the last few versions.

Meaning you visit a forum that has new posts for two topics.
You view one only but go back to the forum summary.
Then the summary page does not display you have unread topics in a forum.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Apr 2008
Posts: 33
R
Rascal Offline OP
newbie
OP Offline
newbie
R
Joined: Apr 2008
Posts: 33
If by "forum summary" you mean the main "Forum List" page, then no, that's not what I'm talking about. This is:

You visit the General Chat forum, and you see there are new posts in Topic A and Topic B. You view Topic A and then go directly to the General Chat forum, and Topic B no longer shows it has unread posts.


Running UBB.threads 7.5.5 as of May 23 2010
Joined: Jun 2006
Posts: 9,242
R
Former Developer
Offline
Former Developer
R
Joined: Jun 2006
Posts: 9,242
It's probably the time setting on the new server. What you want to do is compare the server time on the new server and what the old server was set to and then adjust the server time offset accordingly.

Joined: Apr 2008
Posts: 33
R
Rascal Offline OP
newbie
OP Offline
newbie
R
Joined: Apr 2008
Posts: 33
Really? We were with GoDaddy (Scottsdale, AZ) and had some time stamp issues last fall because AZ doesn't observe daylight saving time, and it's certainly possible we didn't get the new offset right when we switched. I'll investigate that tonight. But how would the wrong time setting on the server cause the problems we're seeing?


Running UBB.threads 7.5.5 as of May 23 2010
Joined: Dec 2003
Posts: 6,278
Likes: 45
Online Yawn
Joined: Dec 2003
Posts: 6,278
Likes: 45
It makes a cookie issue on the timestamp.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Jul 2007
Posts: 91
journeyman
Offline
journeyman
Joined: Jul 2007
Posts: 91
Is it all members or just some members that are having the problem? I recently did a Server switch and some members computers were reading the old cookies. Have members go to My Stuff, bottom of popup is cookies, have them expire the cookies. That might clean up the problem.

Joined: Apr 2008
Posts: 33
R
Rascal Offline OP
newbie
OP Offline
newbie
R
Joined: Apr 2008
Posts: 33
I don't know if it's all members. Doesn't seem to be a cookie issue, though (or at least not solely that) because deleting them via browser interface had no effect on the problems.

Rick, I believe the Default Time Offset in the CP was wrong so I changed it. I actually tried a couple of different offsets, because frankly I've got myself so confused I'm not sure what the setting should be, but apparently I haven't found the magic number because the problems remain.

Old server was in Scottsdale, AZ.
New server is in Houston, TX. What should the Default Time Offset be to fix the problems?


Running UBB.threads 7.5.5 as of May 23 2010
Joined: Jun 2006
Posts: 9,242
R
Former Developer
Offline
Former Developer
R
Joined: Jun 2006
Posts: 9,242
Do you recall what the offset was previously? The offset should be one hour less than what it was. If the issue still persists probably best to open up a support ticket with FTP and admin login info so we can take a look.

Joined: Apr 2008
Posts: 33
R
Rascal Offline OP
newbie
OP Offline
newbie
R
Joined: Apr 2008
Posts: 33
On the old server we had the offset at 0.

-1 was one of the settings I tried that didn't appear to solve the problem. I didn't wait for posts to be made after the change to -1, though, just checked by looking at posts made earlier that I hadn't yet read. Occurs to me now that perhaps that wasn't a good test; do I need to wait for posts made under the new offset? If so I'll try it again before opening a support ticket.


Running UBB.threads 7.5.5 as of May 23 2010
Joined: Jun 2006
Posts: 9,242
R
Former Developer
Offline
Former Developer
R
Joined: Jun 2006
Posts: 9,242
Yeah, you'll want to wait for new posts to be made so the timestamps in the various tables are updated accordingly.

Joined: Apr 2008
Posts: 33
R
Rascal Offline OP
newbie
OP Offline
newbie
R
Joined: Apr 2008
Posts: 33
Thanks, Rick. I just changed it to -1 again, will give it some time now.


Running UBB.threads 7.5.5 as of May 23 2010

Link Copied to Clipboard
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
v7.7.5 Active Topics Display Name Incorrect
by Jake - 11/17/2020 4:46 PM
custom islands in forums tool
by Ruben - 11/17/2020 3:21 PM
Captcha bug maybe?
by Morgan - 11/16/2020 8:34 AM
Facebook thumbnail issue
by DBryce - 11/08/2020 7:43 PM
No hop to menu in the category pages
by Morgan - 11/05/2020 4:19 PM
Who's Online Now
2 members (Ernie, Ruben), 55 guests, and 53 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
gallery test
gallery test
by Mors, September 23
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Powered by UBB.threads™ PHP Forum Software 7.7.5