Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
0 registered members (), 57 guests, and 386 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Mark S
Mark S
Liverpool : England : UK
Posts: 4,704
Joined: July 2006
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 18
M4TT 12
FREAK 11
Ruben 8
mmkk 4
isaac 4
Latest Photos
Chinese Buddhist temple.
My buddha beads.
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Previous Thread
Next Thread
Print Thread
Some characters turned into gibberish #252647
04/17/13 02:52 PM
04/17/13 02:52 PM
Joined: Nov 2008
Posts: 27
S
sw55 Offline OP
newbie
sw55  Offline OP
newbie
S
Joined: Nov 2008
Posts: 27
Hi,

I renewed my license and installed version 7. I then imported my data from UBB.threads 6.5.5 using the importer from the member download area. I found it very straight forward.

Except for this problem: all of the 'non-English' characters (and some other characters like trademark symbols, some quotation marks etc.), turned into 'gibberish'. For example, my Korean forum title is like this: 歡迎使用 Ÿä»¶ï¼

When I do a mysqldump of my 6.5.5 forum and view the .sql in notepad++ everything looks good. I remember having a similar problem when I went from MySQL 4 to 5 and had to export and import the forum, but I'm not certain what the fix for that problem ended up being. I think I set something to 'latin' in the exported sql file.

Anyone know what's going on and how it can be fixed?

Thanks,
Andrew

Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: Some characters turned into gibberish [Re: sw55] #252648
04/17/13 03:39 PM
04/17/13 03:39 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
I am by no means a expert on this issue but it probably has to do with the character set used before the upgrade and after.
This impacts the way the data strings are stored in the dbase.
The older versions used character set ISO-8859-?.
The newer versions used character set utf8 .
This was a option seen only when installing the newer versions not upgrading.
When upgrading you needed to do some edits to the script.

Do a search for both terms ISO-8859 and utf8
Another search term would be non-latin characters. This s probably what you recall.

Last edited by Ruben; 04/17/13 03:43 PM.

Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Some characters turned into gibberish [Re: sw55] #252649
04/17/13 03:53 PM
04/17/13 03:53 PM
Joined: Jun 2006
Posts: 16,788
Portland, OR; USA
Gizmo Offline
UBB.threads Developer
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,788
Portland, OR; USA
As Ruben said, you'll need to update the charset in the language files (I think it's in Generic) to whatever you where using before; Korean characters aren't a part of the Latin Character Set so it'll end up gibberish.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Some characters turned into gibberish [Re: sw55] #252650
04/17/13 04:14 PM
04/17/13 04:14 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
A quick look shows me it is in the language files.
Languages/English/Generic.php
Key CHARSET
I have iso-8859-1 for version 7.5.6
If you have a backup from your older version you probably will find it is like utf-8

Of course if you have a different language pack installed you will need to edit the field in that folder


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Some characters turned into gibberish [Re: sw55] #252651
04/17/13 04:31 PM
04/17/13 04:31 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
Curious thought why did you stop at 7.1 for a upgrade?
Or was this just the first upgrade step?


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Some characters turned into gibberish [Re: Ruben] #252652
04/17/13 04:47 PM
04/17/13 04:47 PM
Joined: Nov 2008
Posts: 27
S
sw55 Offline OP
newbie
sw55  Offline OP
newbie
S
Joined: Nov 2008
Posts: 27
Hi,

Quote:
A quick look shows me it is in the language files.
Languages/English/Generic.php
Key CHARSET
I have iso-8859-1 for version 7.5.6
If you have a backup from your older version you probably will find it is like utf-8


Thanks very much your quick replies - that absolutely worked! My old files were set to utf-8, and setting the new one to utf-8 solved it.

Regarding 7.1. Actually I have 7.5.7.

What I said was "I installed version 7 [period][new sentence] I then imported my data..." smile

Re: Some characters turned into gibberish [Re: sw55] #252653
04/17/13 04:48 PM
04/17/13 04:48 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
Otay. Good deal.
I guess I guessed correctly! lol


Blue Man Group


There is no such thing as stupid questions. Just stupid answers

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Users Unable to Upload Avatar [Not a Bug]
by M4TT. 12/13/17 08:51 AM
Shout Box Sound Effect
by M4TT. 11/29/17 08:28 PM
Ad island
by TGCsanderson. 11/25/17 06:41 PM
Taking to long to connect to DB
by AstroCat. 11/24/17 12:34 PM
Forum Statistics
Forums36
Topics35,015
Posts190,544
Members12,045
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171106)