Previous Thread
Next Thread
Print Thread
Hop To
Joined: Nov 2008
Posts: 28
S
sw55 Offline OP
newbie
OP Offline
newbie
S
Joined: Nov 2008
Posts: 28
I installed Version 7.5.7 and imported my data from UBB.threads 6.5.5 using the script downloaded from this site.

Everything is great, except that for some reason no forum members were assigned to the "Users" group. i.e. in the Member Management section, the Users checkbox is always unchecked. So nobody can see my forums (except for users that belong to other groups like admins etc.). I notice that the "Member Status" radio button is set to User. If I register a new user then they do get the User box checked.

One odd thing I see which may be related is that in Group Management, the # moderators shows 20000.

Can I use the Database tools section to fix this? (i.e. add all members as Users?

Thanks, Andrew

Joined: Jun 2006
Posts: 16,014
Likes: 58
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,014
Likes: 58
If you look, all users are moderators and no moderators are users; it's a bug with the importer.

Go to Member Management, under advanced choose moderators, choose submit, under action at the bottom choose change groups, choose all members in search, submit page, add to users.

I dont think that method will allow you to remove them as mods though.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Nov 2008
Posts: 28
S
sw55 Offline OP
newbie
OP Offline
newbie
S
Joined: Nov 2008
Posts: 28
Excellent, thanks Gizmo!

I notice that in the group management area, it still shows 20000 moderators (as you said), however that doesn't seem to affect anything - i.e. they don't have moderator permissions.

Do you know if there will be any issues from that? So far in my testing it looks fine.

Joined: Dec 2003
Posts: 6,278
Likes: 45
Offline
Joined: Dec 2003
Posts: 6,278
Likes: 45
I had the same issue once.
I believe it was from classic to version 7.2
As I recall Rick fixed it for me by doing some database diving.
Then I went in and reassigned the real moderators.
They were added to the moderator group but were not assigned a forum.
You could clean it up manually
But that would mean editing 20,000 members!


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Dec 2003
Posts: 6,278
Likes: 45
Offline
Joined: Dec 2003
Posts: 6,278
Likes: 45
I found a old topic with a fix:
www.ubbcentral.com/forums/ubbthreads.php/ubb/showflat/Number/223217/

It would still require you to manually add the real moderators back in.
Since this is a test board give it a try.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Nov 2008
Posts: 28
S
sw55 Offline OP
newbie
OP Offline
newbie
S
Joined: Nov 2008
Posts: 28
Perfect, everything's sorted. I used that query in the Database Tools area:

UPDATE `database_name`.`ubbt_USER_GROUPS` SET `GROUP_ID` = '4' WHERE `ubbt_USER_GROUPS`.`GROUP_ID` =3

Initially I got an error, and I realized that was because I had already added all the members to the Users group. So I just created a temp group, moved members to that, and substituted the appropriate group ID numbers in the SQL statement, etc.

I didn't even need to re-assign my moderators, because they were already in the 'global moderators' group, so I just moved them from there.

Andrew

Last edited by sw55; 05/01/2013 2:39 PM. Reason: Added more info
Joined: Jun 2006
Posts: 16,014
Likes: 58
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,014
Likes: 58
I fixed it on my site by running the following query in PHPMyAdmin (you could run it in the UBB's SQL section as well):
Code
DELETE FROM `ubbt_USER_GROUPS` WHERE `GROUP_ID`=3;

This will delete all users from the moderators group; it could fail if your database prefix is anything other than "ubbt_", so be sure to update it accordingly.

I'd advise running the group step i mentioned in the prior post, which will have changed all users to the users group.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Apr 2007
Posts: 3,940
SD Offline
Former Developer
Offline
Former Developer
Joined: Apr 2007
Posts: 3,940
given that the importer was written PRE 7.3 ( when we added global moderators ), the proper way to import is to:

1. import to 7.1 ( 7.2 works too ) .. basically anything PRE 7.3
2. then upgrade to 7.5.7

that will prevent the incorrect group importing, if you go direct to 7.5.7 on import

2c


Link Copied to Clipboard
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
v7.7.5 Active Topics Display Name Incorrect
by Jake - 11/17/2020 4:46 PM
custom islands in forums tool
by Ruben - 11/17/2020 3:21 PM
Captcha bug maybe?
by Morgan - 11/16/2020 8:34 AM
Facebook thumbnail issue
by DBryce - 11/08/2020 7:43 PM
No hop to menu in the category pages
by Morgan - 11/05/2020 4:19 PM
Who's Online Now
0 members (), 68 guests, and 76 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
gallery test
gallery test
by Mors, September 23
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Powered by UBB.threads™ PHP Forum Software 7.7.5