Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
2 registered members (Gizmo, mmkk), 69 guests, and 416 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Mark S
Mark S
Liverpool : England : UK
Posts: 4,704
Joined: July 2006
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 16
FREAK 11
M4TT 11
Ruben 6
mmkk 5
isaac 4
Latest Photos
Chinese Buddhist temple.
My buddha beads.
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Previous Thread
Next Thread
Print Thread
Not sure you'd call this a bug, but.... #257076
07/30/15 09:09 PM
07/30/15 09:09 PM
Joined: Oct 2007
Posts: 215
Baldeagle Offline OP
enthusiast
Baldeagle  Offline OP
enthusiast
Joined: Oct 2007
Posts: 215
I was going through my Google Search Console correcting problems that Google had uncovered when I came across this. Google is reporting that I have pages with multiple <title></title> entries. They all seem to be in the Forum.
HTML
powertrain swap? | Tons 'o Fun | The Stovebolt Forums
/ubbthreads/ubbthreads.php?ubb=showflat&Number=1100518
/ubbthreads/ubbthreads.php?ubb=showflat&Number=1102060
2
cummins 350 help | Big Bolts | The Stovebolt Forums
/ubbthreads/ubbthreads.php?ubb=showflat&Number=448899&page=all
/ubbthreads/ubbthreads.php?ubb=showflat&Number=449169&page=2
/ubbthreads/ubbthreads.php?ubb=showflat&Number=449186&page=1
/ubbthreads/ubbthreads.php?ubb=showflat&Number=449197
/ubbthreads/ubbthreads.php?ubb=showflat&Number=449828&page=2
5
1958 GMC Parking lights | General Truck Talk | The Stovebolt Forums
/ubbthreads/ubbthreads.php?ubb=showflat&Number=1101107
/ubbthreads/ubbthreads.php?ubb=showflat&Number=630311
/ubbthreads/ubbthreads.php?ubb=showflat&Number=630335
3
'68 250 engine swap | The Engine Shop | The Stovebolt Forums
/ubbthreads/ubbthreads.php?ubb=showflat&Number=1079785
/ubbthreads/ubbthreads.php?ubb=showflat&Number=1080786
(This is just a sample. There's quite a few more.)

Looks like a loop type problem to me, but what do I know?


The Stovebolt Geek
http://www.stovebolt.com/ubbthreads/ubbthreads.php

UBBThreads 7.6.0
Web Server Apache/2.4.25
PHP Version 5.6.30
MySQL Version 5.5.55-log
Database Size 1.95 GB
Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: Not sure you'd call this a bug, but.... [Re: Baldeagle] #257077
07/31/15 01:51 AM
07/31/15 01:51 AM
Joined: Jun 2006
Posts: 16,786
Portland, OR; USA
Gizmo Online tapedshut
UBB.threads Developer
Gizmo  Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 16,786
Portland, OR; USA
If you're having indexing issues you should first enable search engine friendly URLs with the fake html extension in the Control Panel (CP -> Master Settings -> Primary SEttings -> General Tab -> Advanced Options -> "Enable Spider-Friendly URLs" and "Enable HTML Extention")

Without Spider Friendly URLs Google sees all urls as "/ubbthreads/ubbthreads.php" with qualifiers; at times it will drop the qualifiers on some URLs, resulting in some crawling errors.

Now would probably also be a good time to install this modification so that you're already setup for the v7.6.0 URL scheme; I even have support built for the v7.6.0 in the UBB.Sitemaps modification.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Not sure you'd call this a bug, but.... [Re: Baldeagle] #257078
07/31/15 02:25 AM
07/31/15 02:25 AM
Joined: Apr 2004
Posts: 1,004
California
isaac Offline
UBB.threads Developer
isaac  Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,004
California
Some additional information that you can read through, on top of what Gizmo mentioned above:

Have a quick read through this page -
https://support.google.com/webmasters/answer/6080548?rd=1

Then visit here -
https://www.google.com/webmasters/tools/crawl-url-parameters?hl=en&siteUrl=https://www.YOURWEBSITE.com/

Add these items to your list -
.html
Cat
PHPSESSID
sb
view
words
Limit

Set their qualifiers on GWT to "Let Googlebot decide"

These settings have been helpful for me since coming from 5.x, 6.x and 7.x versions before the SF-URLs were available.

BUT ULTIMATELY, if you want the spiders to get through your pages with less issues, turn on "Spider Friendly URLs" as Gizmo pointed out.

Re: Not sure you'd call this a bug, but.... [Re: Gizmo] #257083
07/31/15 12:28 PM
07/31/15 12:28 PM
Joined: Oct 2007
Posts: 215
Baldeagle Offline OP
enthusiast
Baldeagle  Offline OP
enthusiast
Joined: Oct 2007
Posts: 215
Originally Posted by Gizmo
If you're having indexing issues you should first enable search engine friendly URLs with the fake html extension in the Control Panel (CP -> Master Settings -> Primary SEttings -> General Tab -> Advanced Options -> "Enable Spider-Friendly URLs" and "Enable HTML Extention")

Without Spider Friendly URLs Google sees all urls as "/ubbthreads/ubbthreads.php" with qualifiers; at times it will drop the qualifiers on some URLs, resulting in some crawling errors.

Now would probably also be a good time to install this modification so that you're already setup for the v7.6.0 URL scheme; I even have support built for the v7.6.0 in the UBB.Sitemaps modification.

Gizmo, thanks, man. I didn't even know UBBThreads had Spider Friendly URLs available. I implemented it immediately. I'll take a look at the mod too.


The Stovebolt Geek
http://www.stovebolt.com/ubbthreads/ubbthreads.php

UBBThreads 7.6.0
Web Server Apache/2.4.25
PHP Version 5.6.30
MySQL Version 5.5.55-log
Database Size 1.95 GB
Re: Not sure you'd call this a bug, but.... [Re: isaac] #257084
07/31/15 12:44 PM
07/31/15 12:44 PM
Joined: Oct 2007
Posts: 215
Baldeagle Offline OP
enthusiast
Baldeagle  Offline OP
enthusiast
Joined: Oct 2007
Posts: 215
Originally Posted by id242
Some additional information that you can read through, on top of what Gizmo mentioned above:

Have a quick read through this page -
https://support.google.com/webmasters/answer/6080548?rd=1

Then visit here -
https://www.google.com/webmasters/tools/crawl-url-parameters?hl=en&siteUrl=https://www.YOURWEBSITE.com/

Add these items to your list -
.html
Cat
PHPSESSID
sb
view
words
Limit

Set their qualifiers on GWT to "Let Googlebot decide"

These settings have been helpful for me since coming from 5.x, 6.x and 7.x versions before the SF-URLs were available.

BUT ULTIMATELY, if you want the spiders to get through your pages with less issues, turn on "Spider Friendly URLs" as Gizmo pointed out.

Thanks id242. When you add these parameters you have to select from two options: they do or do not affect or change the content. The answer is no to each of them, correct?


The Stovebolt Geek
http://www.stovebolt.com/ubbthreads/ubbthreads.php

UBBThreads 7.6.0
Web Server Apache/2.4.25
PHP Version 5.6.30
MySQL Version 5.5.55-log
Database Size 1.95 GB
Re: Not sure you'd call this a bug, but.... [Re: Baldeagle] #257085
07/31/15 12:50 PM
07/31/15 12:50 PM
Joined: Apr 2004
Posts: 1,004
California
isaac Offline
UBB.threads Developer
isaac  Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,004
California
Choose "do not affect"

Those qualifiers mostly just change how the stuff on the screen is displayed, but the information is the generally same as far as what a search engine will munch on, or what it even has access to.

If you're moving to Spider-Friendly URLs, those items will mostly be unseen by spiders. But its good to have them since your site has been around for quite a long time and I'm sure many people have posted your links all over without the Spider-Friendly URLs style.

Last edited by id242; 07/31/15 12:54 PM.
Re: Not sure you'd call this a bug, but.... [Re: Baldeagle] #257086
07/31/15 12:59 PM
07/31/15 12:59 PM
Joined: Oct 2007
Posts: 215
Baldeagle Offline OP
enthusiast
Baldeagle  Offline OP
enthusiast
Joined: Oct 2007
Posts: 215
OK, I tried the mod, but it blew up my board. I did this:
PHP Code
	 // There should be no '&amp;' or '&amp;amp;' in the url, strip those JIC
		$url = str_replace('&amp;', '&', $url);
		// Testing the new dash rather than underscore capability
		/* $title = ubbchars($title);
		$title = str_replace(' ', '_', trim($title));
		$title = str_replace( '%', '_', $title );
		$title = substr($title, 0, 30); */
						
		//SEO-friendly URL String Converter
		//ex) this is an example -> this-is-an-example
		$title = str_replace(array("&amp;","&nbsp;"), " ", $title); //replace space and ampersand markup
		$title = str_replace(array("&quot;","'"), "", $title); //replace quote markup
		$title = mb_convert_case($title, MB_CASE_LOWER, "UTF-8"); //convert to lowercase
		$title = preg_replace("#[^A-Za-z0-9]+#", "-", $title); //replace everything non-alphameric with dashes
		$title = preg_replace("#(-){2,}#", "$1", $title); //replace multiple dashes with one
		$title = trim($title, "-"); //trim dashes from beginning and end of string if any
		$title = substr($title, 0, 70); 
and got an undefined function error. What did I do wrong?


The Stovebolt Geek
http://www.stovebolt.com/ubbthreads/ubbthreads.php

UBBThreads 7.6.0
Web Server Apache/2.4.25
PHP Version 5.6.30
MySQL Version 5.5.55-log
Database Size 1.95 GB
Re: Not sure you'd call this a bug, but.... [Re: Baldeagle] #257087
07/31/15 01:03 PM
07/31/15 01:03 PM
Joined: Apr 2004
Posts: 1,004
California
isaac Offline
UBB.threads Developer
isaac  Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,004
California
Try it once again, being sure to copy the whole bit of code.

refresh TWICE laugh

Re: Not sure you'd call this a bug, but.... [Re: isaac] #257089
07/31/15 04:08 PM
07/31/15 04:08 PM
Joined: Oct 2007
Posts: 215
Baldeagle Offline OP
enthusiast
Baldeagle  Offline OP
enthusiast
Joined: Oct 2007
Posts: 215
I thought i did copy the entire code. What did I miss?


The Stovebolt Geek
http://www.stovebolt.com/ubbthreads/ubbthreads.php

UBBThreads 7.6.0
Web Server Apache/2.4.25
PHP Version 5.6.30
MySQL Version 5.5.55-log
Database Size 1.95 GB
Re: Not sure you'd call this a bug, but.... [Re: Baldeagle] #257208
08/28/15 07:11 AM
08/28/15 07:11 AM
Joined: Jan 2004
Posts: 2,650
driv Offline

driv  Offline


Joined: Jan 2004
Posts: 2,650
I'm having the same issue. I have friendly URLs enabled and have all the parameters added to webmaster tools.
Clearly, the issue is the number following the word 'topics'.

Do you think there is anything that can be done about this?

Attached Files dup-tiles-1.jpg

Using version :: 7.6.0
Re: Not sure you'd call this a bug, but.... [Re: driv] #257213
08/28/15 01:15 PM
08/28/15 01:15 PM
Joined: Dec 2003
Posts: 5,825
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,825
Lutz,FL
I can only assume that you implemented the code changes as well as friendly urls and now Google is re-indexing your site. So that can take quite some time.
In the meantime you will have a lot of duplication till it settles down.
It could take a very very long time.(Weeks,Months)
Unless possibly you resubmit a sitemap(Giz hack)

Probably something Giz and Id242 should have mentioned.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Not sure you'd call this a bug, but.... [Re: Ruben] #257214
08/28/15 01:29 PM
08/28/15 01:29 PM
Joined: Apr 2004
Posts: 1,004
California
isaac Offline
UBB.threads Developer
isaac  Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,004
California
Originally Posted by Ruben
I can only assume that you implemented the code changes as well as friendly urls and now Google is re-indexing your site. So that can take quite some time.
In the meantime you will have a lot of duplication till it settles down.
It could take a very very long time.(Weeks,Months)
Unless possibly you resubmit a sitemap(Giz hack)

Probably something Giz and Id242 should have mentioned.


Was there something Giz or myself should have mentioned that did not get mentioned?

Driv's screenshot does not look like he has the "Better URL Sanitization for SEO" installed. He looks to be running stock code.
If Driv does choose to manually install this fix/solution, a complete write-up can be found @ http://www.ubbcentral.com/forums/ubbthreads.php/topics/255500

Re: Not sure you'd call this a bug, but.... [Re: Baldeagle] #257215
08/28/15 01:33 PM
08/28/15 01:33 PM
Joined: Dec 2003
Posts: 5,825
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,825
Lutz,FL
No I am just saying even if he implemented all the fixes that he may need to wait while to be reindexed.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Not sure you'd call this a bug, but.... [Re: Baldeagle] #257216
08/28/15 01:34 PM
08/28/15 01:34 PM
Joined: Apr 2004
Posts: 1,004
California
isaac Offline
UBB.threads Developer
isaac  Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,004
California
The problem I see, is that Google is not only indexing the topic URL, but also the bookmark/link URL to the individual posts within those topics.

Re: Not sure you'd call this a bug, but.... [Re: isaac] #257217
08/28/15 03:57 PM
08/28/15 03:57 PM
Joined: Jan 2004
Posts: 2,650
driv Offline

driv  Offline


Joined: Jan 2004
Posts: 2,650
Thank you for your responses gents. smile

Originally Posted by id242
Driv's screenshot does not look like he has the "Better URL Sanitization for SEO" installed. He looks to be running stock code.

Quite correct. However I shall use that mod (thanks), clearly it is needed as indicated by the x-ray / x_ray issue.

Another issue seems to be the use of Re: in the titles, but then I don't suppose that can be added to the Webmaster Tools parameter list.


Originally Posted by id242
The problem I see, is that Google is not only indexing the topic URL, but also the bookmark/link URL to the individual posts within those topics.
Is anyone else getting this problem? Surely it can't just be me, can it?




Using version :: 7.6.0
Re: Not sure you'd call this a bug, but.... [Re: Baldeagle] #257232
09/04/15 12:01 PM
09/04/15 12:01 PM
Joined: Jul 2006
Posts: 4,704
Liverpool : England : UK
Mark S Offline
Mark S  Offline

Joined: Jul 2006
Posts: 4,704
Liverpool : England : UK
Not sure where your screen shot is from DRIV but this is my HTML improvements, omg. . .
If you can direct me to where you got the duplicate info i can check mine.

I did spot a crawler issue with Mobile devices. Click Me

Attached Files webtools-1.jpg
Last edited by Mark S; 09/04/15 12:03 PM.

Version v7.5.8
People who inspire me Gizmo ID242 SD
Its been a long road. . . .to be waiting
Re: Not sure you'd call this a bug, but.... [Re: Baldeagle] #257233
09/04/15 12:06 PM
09/04/15 12:06 PM
Joined: Jul 2006
Posts: 4,704
Liverpool : England : UK
Mark S Offline
Mark S  Offline

Joined: Jul 2006
Posts: 4,704
Liverpool : England : UK
Inside the Duplicate title tags. ..

I don't have Better URL Sanitization for SEO included yet, but the others I do, spider friendly and extender.

Attached Files webtools-1.jpg
Last edited by Mark S; 09/04/15 12:10 PM.

Version v7.5.8
People who inspire me Gizmo ID242 SD
Its been a long road. . . .to be waiting
Re: Not sure you'd call this a bug, but.... [Re: Baldeagle] #257248
09/06/15 06:05 AM
09/06/15 06:05 AM
Joined: Jul 2006
Posts: 4,704
Liverpool : England : UK
Mark S Offline
Mark S  Offline

Joined: Jul 2006
Posts: 4,704
Liverpool : England : UK
To Put it in context i have

933,228 Posts
69,585 Topics

So if its "Topics" Webmaster tools is reporting back that's more than 50% duplicates.
If its posts its only a small fraction, im not really sure which it is.

At the time of sharing the screen shots im using 7.5.8 and not using the Better URL Sanitization for SEO.
I have just implemented the Better URL Sanitization for SEO.
So lets see where we go.

IGNORE THIS IMAGE its for another topic, but i cant upload there.

Attached Files webtools-2.jpg
Last edited by Mark S; 09/06/15 06:09 AM.

Version v7.5.8
People who inspire me Gizmo ID242 SD
Its been a long road. . . .to be waiting

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Users Unable to Upload Avatar
by M4TT. 12/13/17 08:51 AM
Shout Box Sound Effect
by M4TT. 11/29/17 08:28 PM
Ad island
by TGCsanderson. 11/25/17 06:41 PM
Taking to long to connect to DB
by AstroCat. 11/24/17 12:34 PM
Forum Statistics
Forums36
Topics35,015
Posts190,535
Members12,045
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171106)