Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
1 registered members (driv), 61 guests, and 229 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Zarzal
Zarzal
Berlin, Germany
Posts: 1,148
Joined: June 2006
Show All Member Profiles 
Top Posters(30 Days)
isaac 21
Ruben 10
Gizmo 8
Geoff 3
FREAK 2
Slaz 2
DennyP 1
Latest Photos
Testing to drag photos
Comfortable Cats
Test
BSA photos
Chinese Buddhist temple.
Previous Thread
Next Thread
Print Thread
Attachments Not Uploading 7.6.1 #260817
01/08/18 04:47 PM
01/08/18 04:47 PM
G
Geoff  Offline OP
Journeyman
Joined: Aug 2006
Posts: 92
Florida
For some reason after upgrading to 7.6.1, users can not attach files. The file name gets created but no files are upladed to the directory. It worked before the upgrade.


Attached Files 93DFCF9E-9804-4F28-A43A-E5E8926703E4.pngFDBF6F54-5477-40CF-8570-5D8793F67498.png22C6AEE8-9C49-4271-B8B1-1945CFB43EC9.png835E84EF-89A0-423B-8D4E-400377C4527A.png6F4BDA33-EEFB-44CE-A4A9-7A0A9DD16D06.png
Last edited by Geoff; 01/08/18 04:49 PM. Reason: Changed one photo

I am a Superstar! Testing signature here
Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: Attachments Not Uploading 7.6.1 [Re: Geoff] #260822
01/08/18 06:04 PM
01/08/18 06:04 PM
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,956
Portland, OR; USA
What are the permissions on your /tmp folder?

How are the permissions on the rest of your UBB.threads folders?
CP -> Tools & Information -> Permission Checks

Can Guests see uploaded images? Can members veiw attached images?

Last edited by Gizmo; 01/08/18 06:09 PM.

I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Attachments Not Uploading 7.6.1 [Re: Gizmo] #260824
01/08/18 10:00 PM
01/08/18 10:00 PM
G
Geoff  Offline OP
Journeyman
Joined: Aug 2006
Posts: 92
Florida
/tmp folder says OK
Permission check shows all OK

Prior to 1/3, attwchments can be viewed by both members and guests.
Example when worked: Link to Working Attachment Example.
Example Now: Attachment Manager Not Working

Up until 1/3 when I updated to 7.6.1, attachment feature worked fine. Had issue with randomly not rendering attachments but resolved itself after I fixed the Avatar being mapped to the pre SSH URL.


I am a Superstar! Testing signature here
Re: Attachments Not Uploading 7.6.1 [Re: Geoff] #260825
01/08/18 10:34 PM
01/08/18 10:34 PM
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,956
Portland, OR; USA
Geoff, could you go in to the image settings and ensure that you have an image processor selected (IM or GD) and submit the page, then try again? Isaac and I have been trying to figure out why images aren't ending up in your tmp folder.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Attachments Not Uploading 7.6.1 [Re: Gizmo] #260828
01/09/18 11:50 AM
01/09/18 11:50 AM
G
Geoff  Offline OP
Journeyman
Joined: Aug 2006
Posts: 92
Florida
I will but currently locked out of the control panel. I just posted another thread for this issue of being locked out.

IM was selected. I will resubmit. The IM and paths are the same they were in 7.6.0 which were the default suggested and worked. I have contacted TierraNet hosting provider to confirm paths and version of IM installed.


I am a Superstar! Testing signature here
Re: Attachments Not Uploading 7.6.1 [Re: Geoff] #260877
01/11/18 03:50 PM
01/11/18 03:50 PM
G
Geoff  Offline OP
Journeyman
Joined: Aug 2006
Posts: 92
Florida
Looks like for some reason the paths for ImageMagick from 7.6.0 failed to continue to work after the 7.6.1 install. Maybe host changed same time or just worked without having correct paths (Was GD2 fall over if IM failed?).

I changed to GD2 and attachments working again. Still waiting on TierraNet hosting on correct paths. ImageMagick is installed.

I happened to see in Captch a GD2 image but the IM image failed to load. I opened the image in another window and error said something about path to IM was wrong.

Attached Files C2449E3E-6AED-4C72-8783-8D2F807D6C9A.png
Last edited by Geoff; 01/11/18 03:57 PM. Reason: Added about the captcha images

I am a Superstar! Testing signature here
Re: Attachments Not Uploading 7.6.1 [Re: Geoff] #260888
01/12/18 09:57 AM
01/12/18 09:57 AM
G
Geoff  Offline OP
Journeyman
Joined: Aug 2006
Posts: 92
Florida
According to the CP PHP Info ImageMagick is installed. How do I determine if the paths have been identified?

My Host is telling me I have to do this and I have no clue. If the paths were working before, why not know?

I found this on web:
Quote
$wgImageMagickConvertCommand = '/usr/bin/convert'; # for linux


Just don’t know what to do with it or if I have to do it as the paths worked before. What about the mogrify path?

Quote
$wgImageMagickMogrifyCommand = '/usr/bin/mogrify'; # for linux

Attached Files FD150CFC-F6DE-49A6-AFF1-F767C45EBA7D.png

I am a Superstar! Testing signature here
Re: Attachments Not Uploading 7.6.1 [Re: Geoff] #260891
01/12/18 03:05 PM
01/12/18 03:05 PM
Ruben  Offline
Joined: Dec 2003
Posts: 5,920
Lutz,FL
First you never stated what your paths are set to for ImageMagick .
If you google How do I test ImageMagick there are a few php scripts you can run.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Attachments Not Uploading 7.6.1 [Re: Geoff] #260892
01/12/18 07:59 PM
01/12/18 07:59 PM
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,956
Portland, OR; USA
The imagic module in PHP isn't the same as the system level binary that you have to specify the link to in the UBB.threads control panel. If the paths are populated, the "test" is where it populates the example graphic; if it works it works, if it doesn't then there is a problem with the system level binary you're linking to.

Attached Files imgd.png

I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
UBB.threads 7.6.2 - Released
by isaac. 09/17/18 08:08 AM
7.6.2 Changelog Discussion
by isaac. 09/17/18 06:35 AM
Upgrade Documentation
by DennyP. 09/15/18 03:55 PM
PHP 7.2
by Geoff. 09/12/18 10:22 PM
Email Cleanup-Is it possible?
by Ruben. 09/06/18 11:25 AM
Forum Statistics
Forums36
Topics35,139
Posts191,439
Members12,106
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.2