Previous Thread
Next Thread
Print Thread
Hop To
Joined: Jun 2008
Posts: 87
M
mmem700 Online Content OP
Journeyman
OP Online Content
Journeyman
M
Joined: Jun 2008
Posts: 87
Installing Threads on CentOS 7 with PHP 5.6.38 and am getting this error when trying to run the /install/upgrade.php script

Fatal error: Call to undefined function mysqli_pconnect() in /web/vhosts/orbisvitae.com/htdocs/ubbthreads/libs/mysqli.inc.php on line 31

How do I proceed?

Thanks in advance.


Today they call you "crazy".
Tomorrow they call you "ahead of your time".
Joined: Jun 2006
Posts: 16,186
Likes: 102
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,186
Likes: 102
You should install the UBB.threads System Requirements Test Script and see if it detects any problems with your configuration; the error is reporting that the mysqli_pconnect function does not exist on your server, can you disable persistent connections in your config file and see if the error goes away?

the "PERSISTENT_DB_CONNECTION" line in /includes/config.inc.php should be set to '' (blank) for this test. Additionally, you can also install the mysqli_pconnect function to your server.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Jun 2008
Posts: 87
M
mmem700 Online Content OP
Journeyman
OP Online Content
Journeyman
M
Joined: Jun 2008
Posts: 87
OK thanks. I'll give this a try and get back.


Today they call you "crazy".
Tomorrow they call you "ahead of your time".
Joined: Jun 2008
Posts: 87
M
mmem700 Online Content OP
Journeyman
OP Online Content
Journeyman
M
Joined: Jun 2008
Posts: 87
OK, updating the "PERSISTENT_DB_CONNECTION" setting to zero worked and allowed the update script to run.

I'm now having an issue that prevents me from preceding past the "Languages" step. There is no "next"/"continue" button on the window. I've included a link to a screen shot.

Any help would be appreciated.
Thanks.

Attached Images
screenshot01.png

Today they call you "crazy".
Tomorrow they call you "ahead of your time".
Joined: Jun 2006
Posts: 16,186
Likes: 102
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,186
Likes: 102
That is NOT the UBB.threads v7.7 install CSS; you've got a cached page and CSS in your browser (it looks fine when I access the page); can you hold alt and press F5 to clear your cache of that page?

Is your site on a CDN?


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Jun 2008
Posts: 87
M
mmem700 Online Content OP
Journeyman
OP Online Content
Journeyman
M
Joined: Jun 2008
Posts: 87
Thanks for responding.
We have our own server. Not using a CDN.

Searching further there appears to be a Javascript error on the page. Here are 2 more screenshots...

I'm still stuck just after the Language files have been installed.

Attached Images
screenshot02.png screenshot03.png

Today they call you "crazy".
Tomorrow they call you "ahead of your time".
Joined: Jun 2008
Posts: 87
M
mmem700 Online Content OP
Journeyman
OP Online Content
Journeyman
M
Joined: Jun 2008
Posts: 87
I cleared the cache and reloaded the page and now the CSS style is much better.

I am still stuck with the JS error shown in the above post and unable to proceed beyond this step.

Attached Images
screenshot04.png

Today they call you "crazy".
Tomorrow they call you "ahead of your time".
Joined: Jun 2008
Posts: 87
M
mmem700 Online Content OP
Journeyman
OP Online Content
Journeyman
M
Joined: Jun 2008
Posts: 87
I noticed that the ubb_jslib.js file shows version 7.6.1 at the top. You can see it here live:

http://orbisvitae.com/ubbthreads/ubb_js/ubb_jslib.js

This is the file that was included in the 7.7.0 zip file.

I'm installing v 7.7.0.

Is this possibly the issue?

Last edited by mmem700; 01/29/2019 10:20 PM.

Today they call you "crazy".
Tomorrow they call you "ahead of your time".
Joined: Jun 2006
Posts: 16,186
Likes: 102
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,186
Likes: 102
Files that aren't updated for a release do not have the header versions changed... You should be fine once you have a white layout vs the "sand" from early v7.5

When I access:
http://orbisvitae.com/ubbthreads/install/

I see the Expected Color Scheme


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Jun 2008
Posts: 87
M
mmem700 Online Content OP
Journeyman
OP Online Content
Journeyman
M
Joined: Jun 2008
Posts: 87
OK. I understand.
I appreciate the help.

Unfortunately we still have the error and are unable to proceed.
Any ideas what I should do next?

We just updated 2 licenses and our UBB forums are currently down because of this.

Attached Images
screenshot02.png screenshot03.png

Today they call you "crazy".
Tomorrow they call you "ahead of your time".
Joined: Jun 2006
Posts: 16,186
Likes: 102
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,186
Likes: 102
It has nothing to do with ubb_jslib, if you access your: http://orbisvitae.com/ubbthreads/ubb_js/ubb_jslib.js
AND the one from my test forums https://www.virtualnightclub.net/forum/ubb_js/ubb_jslib.js

And compare, you'll see they're the same file (both are the 7.7.0 lib), there is an update for this file in 7.7.1 as the display on some elements were adjusted.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Jun 2008
Posts: 87
M
mmem700 Online Content OP
Journeyman
OP Online Content
Journeyman
M
Joined: Jun 2008
Posts: 87
Thank you. I'll check.


Today they call you "crazy".
Tomorrow they call you "ahead of your time".
Joined: Jun 2008
Posts: 87
M
mmem700 Online Content OP
Journeyman
OP Online Content
Journeyman
M
Joined: Jun 2008
Posts: 87
I just used the diff-checker online and compared your ubb_js/ubb_jslib.js file with my file and they are identical:

https://www.diffchecker.com/diff

Screenshot:

Attached Images
screenshot05.png

Today they call you "crazy".
Tomorrow they call you "ahead of your time".
Joined: Jul 2006
Posts: 114
Likes: 2
P
Member
Offline
Member
P
Joined: Jul 2006
Posts: 114
Likes: 2
Originally Posted by Gizmo
You should install the UBB.threads System Requirements Test Script and see if it detects any problems with your configuration; the error is reporting that the mysqli_pconnect function does not exist on your server, can you disable persistent connections in your config file and see if the error goes away?

the "PERSISTENT_DB_CONNECTION" line in /includes/config.inc.php should be set to '' (blank) for this test. Additionally, you can also install the mysqli_pconnect function to your server.
This is a bug because there is no mysqli_pconnect in the MySQLi extension. To fix this issue, replace line 31 in /ubb/libs/mysqli.inc.php:
Code
				$this->dbh = mysqli_pconnect("p:" . $config['DATABASE_SERVER'], $config['DATABASE_USER'], $config['DATABASE_PASSWORD'], $config['DATABASE_NAME']) or die("Problem occured in connection");
with:
Code
				$this->dbh = mysqli_connect("p:" . $config['DATABASE_SERVER'], $config['DATABASE_USER'], $config['DATABASE_PASSWORD'], $config['DATABASE_NAME']) or die("Problem occured in connection");

The "p:" will already open the persistent connection

Joined: Jun 2006
Posts: 956
Old Hand
Offline
Old Hand
Joined: Jun 2006
Posts: 956
I can confirm the V7.x installer error while updating the language files. I stuck every time at this point. The installer do a update to the files but dont display the continue button. You have to use the browser-back button and skip the next part wit 'do my own modification'. The rest runs fine. After this you have to check you language files by hand (I use beyond compare).


my board: http://www.dragonclan-forum.de
my hobby: http://www.biker-reise.de
Ich kann bei Fragen zu UBBthreads in Deutsch weiterhelfen oder es zumindest versuchen
Joined: Jun 2008
Posts: 87
M
mmem700 Online Content OP
Journeyman
OP Online Content
Journeyman
M
Joined: Jun 2008
Posts: 87
I'm having the same experience as Zarzal.

Like him, I had to use the "I will do my own language file mod" option to get the installer past the "Language" step.

At least I got it finished and hope that all goes well from here.

Thanks for the confirmation Zarzal.

Since I'm using a more recent version of PHP, I will make the update suggested by Phillip above.

Thanks for the help and input!


Today they call you "crazy".
Tomorrow they call you "ahead of your time".
Joined: Apr 2004
Posts: 1,918
Likes: 140
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,918
Likes: 140
Originally Posted by Zarzal
I can confirm the V7.x installer error while updating the language files. I stuck every time at this point. The installer do a update to the files but dont display the continue button. You have to use the browser-back button and skip the next part wit 'do my own modification'. The rest runs fine. After this you have to check you language files by hand (I use beyond compare).
Originally Posted by mmem700
I'm having the same experience as Zarzal.

Like him, I had to use the "I will do my own language file mod" option to get the installer past the "Language" step.

Zarzal is using his third-party/custom German language.

Are you using only the stock English language for your install, or do you have multiple languages / asking the upgrader to also automatically upgrade those additional languages for you?


Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
Joined: Jun 2008
Posts: 87
M
mmem700 Online Content OP
Journeyman
OP Online Content
Journeyman
M
Joined: Jun 2008
Posts: 87
Since I had to skip the automated language file update during the install, how would I now update the language files?

Last edited by mmem700; 01/30/2019 11:13 AM.

Today they call you "crazy".
Tomorrow they call you "ahead of your time".
Joined: Apr 2004
Posts: 1,918
Likes: 140
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,918
Likes: 140
Originally Posted by Philipp
This is a bug because there is no mysqli_pconnect in the MySQLi extension. To fix this issue, replace line 31 in /ubb/libs/mysqli.inc.php:
Code
				$this->dbh = mysqli_pconnect("p:" . $config['DATABASE_SERVER'], $config['DATABASE_USER'], $config['DATABASE_PASSWORD'], $config['DATABASE_NAME']) or die("Problem occured in connection");
with:
Code
				$this->dbh = mysqli_connect("p:" . $config['DATABASE_SERVER'], $config['DATABASE_USER'], $config['DATABASE_PASSWORD'], $config['DATABASE_NAME']) or die("Problem occured in connection");

The "p:" will already open the persistent connection

Thank you for this. It will be corrected for a future release.


Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
Joined: Apr 2004
Posts: 1,918
Likes: 140
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,918
Likes: 140
Originally Posted by mmem700
Since I had to skip the automated language file update during the install, how would I now update the language files?

Manually. Compare side-by-side if using a language other than English.
Or copy the files over from the installer package's language directory to your forum's language directory.

Again, are you using only English? or do you have additional language installed?

The upgrader can only automatically update English files.

Last edited by isaac; 01/30/2019 11:21 AM.

Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
Joined: Jun 2008
Posts: 87
M
mmem700 Online Content OP
Journeyman
OP Online Content
Journeyman
M
Joined: Jun 2008
Posts: 87
Just using English.

I'll go ahead and copy the language files from the install files to the live system as suggested.

Thanks for the help.


Today they call you "crazy".
Tomorrow they call you "ahead of your time".
Joined: Jun 2006
Posts: 956
Old Hand
Offline
Old Hand
Joined: Jun 2006
Posts: 956
Originally Posted by isaac
The upgrader can only automatically update English files.
Thats wrong. The updater change my german files too. If a string is missing he insert the original english string. Thats fine. After the installsation I have to translate it. Last test was the update from 7.6.2 to 7.7.0 with several modifications to the language files.No string was missing after the update and comparing with the original english files.

Zarzal


my board: http://www.dragonclan-forum.de
my hobby: http://www.biker-reise.de
Ich kann bei Fragen zu UBBthreads in Deutsch weiterhelfen oder es zumindest versuchen
Joined: Apr 2004
Posts: 1,918
Likes: 140
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,918
Likes: 140
I guess I should have phrased that better. :/

The upgrader can only automatically update files with English.


Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
Joined: Jun 2006
Posts: 956
Old Hand
Offline
Old Hand
Joined: Jun 2006
Posts: 956
isaac, thats ok smile


my board: http://www.dragonclan-forum.de
my hobby: http://www.biker-reise.de
Ich kann bei Fragen zu UBBthreads in Deutsch weiterhelfen oder es zumindest versuchen

Link Copied to Clipboard
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
"forum introduction body" - Where is this stored.
by mmem700 - 09/24/2022 10:58 AM
Google Search Console mobile usability issue
by cegadm - 09/11/2022 4:36 PM
10 images attached - only one displayed
by Baldeagle - 09/06/2022 6:01 PM
Help! Broken UBB
by JPFolks - 06/27/2022 3:43 PM
Who's Online Now
1 members (mmem700), 46 guests, and 80 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.5