UBBCentral
Posted By: Bilalianman Upgraded to 7.2.2 Problem - 03/21/2016 2:46 AM
I just tried to bring back my website using 7.2.2 and everything worked fine till I got to the end. I loaded the final ubbthreads.php and expected to log in and WHAM! I got the fatal UBB Error We encountered a problem. The reason reported was Database error only visible to forum administrators. Please click back to return to the previous page. Dang man! Man I thought was a real programmer there for a minute... burst my bubble like a champ! O ye duty experts... What can I do to get this back on track?
Posted By: JAISP Re: Upgraded to 7.2.2 Problem - 03/21/2016 10:52 AM
Check your ./includes/config.ini.php file to make sure your database settings are correct.
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/21/2016 12:21 PM
Thanks for your reply. All config.ini.php data appears to be accurate; the path(s), user, password, etc... What happened is, my ISP deleted all my files and all I had left was a backup of 7.2.2. UbbThreads and my local files of the site. Now, I'm trying to rebuild the site using those data. My method was to upload the original 7.2.2. files and add the install directory to that bunch of files to reinstall... My guess is, that is the WRONG method. If I start fresh with a completely new install of say, 7.5.5 which is my last upgrade download, can I somehow make it link with the old backup of my board data and (local) forum files?
Posted By: Gizmo Re: Upgraded to 7.2.2 Problem - 03/21/2016 8:22 PM
Quite simply, likely the issue is due to the version PHP running on your server (PHP v5.1.2+ requires UBB.threads v7.5.8, PHP v7 is not compatible with any build of UBB.threads); please check your system requirements against the UBBWiki entry Server Requirements and Suggestions or use the UBB.threads v7.6.0+ System Requirement Test tool.
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/22/2016 1:37 AM
Thanks for the assist so far. Now, I've downloaded the 7.5.9 version, my php version is 5.6, should I install a "clean" new installation, then address bringing my old files into that? Or, should I try to load all my old files and do an "upgrade" over the old installation?
Posted By: Gizmo Re: Upgraded to 7.2.2 Problem - 03/22/2016 4:27 AM
Sorry for the delay, we where putting our Cub Scout career arrows together for their crossover ceremony on Monday.

If I was doing the upgrade, I'd put the new files on the server, then overwrite the files on the server with your old includes directory, the styles/wrapper.inc.php file, and the /cache_builders/custom directory; then run the upgrade script on the old database (be sure that the same working connection data is in your includes/config.inc.php file).
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/22/2016 3:41 PM
Those Cub Scout events are FAR more important than this stuff... for sure. I've got a four, seven and eight year old... BOYS! Thanks for your reply. I'll be working on that tonight!
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/23/2016 12:30 AM
I performed the initial work, and got to the Upgrade/Install Utility screen, I entered my username and password. So, now I'm getting an SQL error: Database error only visible to administrators Access denied for user 'thecoden_jbilal'@'localhost" (using password" YES)

I didn't expect that. It looks like the old login, and yet, I've checked the config.ini.php... that one matches the SQL login and password on my server. Hmmmmm... old data is somewhere else in the program.
Posted By: JAISP Re: Upgraded to 7.2.2 Problem - 03/23/2016 12:37 AM
Your configuration information is only in that file for your MySQL Database connection. Perhaps your host has changed your information or password by mistake when they had done what they had with your database.

Posted By: Gizmo Re: Upgraded to 7.2.2 Problem - 03/23/2016 12:58 AM
Well, this bit means your username and/or password was refused from the MySQL server:
Quote:
Access denied for user '[username_removed]'@'localhost" (using password" YES)
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/23/2016 1:14 AM
Ok, I'll check the login data for the server... Thank you.
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/23/2016 2:22 AM
I changed the information to synch with my MySql, and now I'm getting this error.

Table 'thecode1_ubbt.ubbt_VERSION' doesn't exist
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/23/2016 2:33 AM
I have another question... I have an old backup of the original MySql database. Is there a way to restore that? Or does the program rebuild that database from the files on the server?
Posted By: Gizmo Re: Upgraded to 7.2.2 Problem - 03/23/2016 3:13 AM
Quote:
Table 'thecode1_ubbt.ubbt_VERSION' doesn't exist


Your DB is "thecode1_ubbt" and the table is "ubbt_VERSION", it's saying that the requested table doesn't exist in the database; make sure that the old database was fully restored.

Originally Posted by Bilalianman
I have another question... I have an old backup of the original MySql database. Is there a way to restore that? Or does the program rebuild that database from the files on the server?
Yes, that's what my initial instructions on upgrading where supposed to do, you where supposed to restore the old database and the indicated files, then run the upgrade script on the old database.
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/23/2016 12:39 PM
I restored the old database in phpMyAdmin and I'm getting no errors. When the upgrade screen asks for Username and Password the one I remember doesn't work. Is there a way to reset?
Posted By: Ruben Re: Upgraded to 7.2.2 Problem - 03/23/2016 6:49 PM
Slowdown cowboy.
Starting over, first load the database backup.
Then upload the same UBB version backup scripts for that database.
Verify that the config.inc.php has the correct info and paths.

First verify that it works and you can login as a admin.
If needed reset your password.

Then follow a upgrade method.
.
Posted By: Gizmo Re: Upgraded to 7.2.2 Problem - 03/23/2016 7:26 PM
I gave him a set of instructions to follow, and it sounds like he's upgraded now, but it seems that he doesn't recall his password to his forum account... Sp he'll need to replace his password with an MD5 hash of another password.

What he'd need to do to regain access to his account is open PHPMyAdmin, open up the "ubbt_USERS" table in his database, look for his user account, and replace the password with "609a5fb349c92aee01d41fae16d082cf" and then he'll need to login with the password "cowboy"; then he'll want to change his password.
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/23/2016 11:26 PM
That pw reset got me into the Upgrade/Install Utility, so I've been checking files, and when I look at the files on my server it looks like all the files are there, however, the Utility says they're not there! It says "Make sure these files are uploaded". Might this have something to do with permissions? I changed all the necessary permission based on the install instructions. Thanks for the assist...
Posted By: Gizmo Re: Upgraded to 7.2.2 Problem - 03/24/2016 12:06 AM
Are you running the upgrade script or the install script? Are the files chmodded 666 with folders 777?
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/24/2016 12:15 AM
This is the upgrade script. I've only changed the files shown in the installation guide. UBB Installation Guide
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/24/2016 12:28 AM
Originally Posted by Bilalianman
This is the upgrade script. I've only changed the files shown in the installation guide. UBB Installation Guide


I meant to say, I only changed the Folders (777) and files (666) as shown in the aforementioned guide.
Posted By: Gizmo Re: Upgraded to 7.2.2 Problem - 03/24/2016 12:52 AM
The UBBWiki has a more up to date Upgrade Guide, at some point I need to request that UBBSystems update their links; likely with the upcoming new version.

Which files is it indicating needs to be present (I believe it should display a list).
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/24/2016 1:27 AM
It looks like the entire list! Very long list! 2212 items... Something is wrong...
Posted By: Gizmo Re: Upgraded to 7.2.2 Problem - 03/24/2016 5:17 AM
So then, not just the files you uploaded from backups (the includes/ folder, the styles/wrapper.inc.php file, and the /cache_builders/custom folder)? Then something isn't working correctly (since the other files should be stock to the version of the installer).

Does the error still display when you click the "i am updating my files myself" option?
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/24/2016 11:43 AM
Quote:
Does the error still display when you click the "i am updating my files myself" option?

I don't recall seeing that option. I got to the long list and nothing else happens.
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/24/2016 11:47 AM
Should I start from the beginning again? I first uploaded the new version, then, I uploaded the includes, cache builder, styles, etc... this was done without the corrected DB, I tried to run the upgrade, it didn't work. THEN i corrected the DB and went straight to the upgrade again. Maybe I need to start from the beginning with the new DB in place?
Posted By: Gizmo Re: Upgraded to 7.2.2 Problem - 03/24/2016 6:07 PM
Originally Posted by Bilalianman
Should I start from the beginning again? I first uploaded the new version, then, I uploaded the includes, cache builder, styles, etc... this was done without the corrected DB, I tried to run the upgrade, it didn't work. THEN i corrected the DB and went straight to the upgrade again. Maybe I need to start from the beginning with the new DB in place?


How I would upgrade an OLD UBB.t install on a modern system (as UBB.threads versions prior to 7.3 shouldn't work with a modern version of PHP, and UBB.threads versions 7.5.8 and newer won't work on older PHP builds [7.5.8 added compatibility with PHP 5.4 and PHP 5.5 & Compatibility with MySQL 5.6]):
  • Upload Old DB
  • Upload NEW UBB Files
  • Overwrite the folders cache_builders/custom/ (NOT /cache_builders) and /includes/, and the styles/wrappers.inc.php file.
  • Edit the includes/config.inc.php file (that should now be your old configuration) and update your connection information.
  • Run the UPGRADE script, install/upgrade.php and login as an administrative user.
  • Select "I will update files myself"


After that it SHOULD just upgrade the data in the database; you might have to select the "check again" button twice (as on some systems I have seen it not take the button press the first time).

If it doesn't work after following the instructions directly, you may need advanced support to get the system upgraded.
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/24/2016 6:59 PM
Sounds good, I'll let you know. Thanks.
Posted By: Bilalianman Re: Upgraded to 7.2.2 Problem - 03/26/2016 2:04 AM
I really appreciate you guys at UBB, the developers, the actual died in the wool programmers, and lets not forget the die hard wanna-be-programmers... like me, who actually know very little, but little by little we fool ourselves into believing we can do all of what we can only do a little of... much respect guys.
© 2019 UBB.threads PHP Forum Software Community