UBBCentral

Lost access to database following server restore

Posted By: Crasher

Lost access to database following server restore - 01/11/2017 8:37 PM

Hello all, its been a while since i was last here - a belated happy new year to you all.

Last weekend, the server my site is hosted on went belly-up, taking out all of the sites it was hosting. After many days of failed rebuilds and restores from backup, i now have access to my hosted account - allbeit on a different server name now.
However when you land on the website all you get is the following messages...
UBB Message
We encountered a problem. The reason reported was
Database error only visible to forum administrators

Please click [ Back ] to return to the previous page.

Its been a while since i last needed to tinker with my site (i like things when they are stable) - i seem to recall that there is a potential path to put in to get access to the admin page? Or if i've wrongly remembered, what files do i need to get at to re-jig?

Many thanks

Barry
Posted By: Gizmo

Re: Lost access to database following server restore - 01/11/2017 9:51 PM

If you're on a different server now the paths to your hosting and the database access information are all likely different; follow the instructions in the UBBWiki Migration Guide to get yourself back up and running. In this case, since your host moved everything for you, start at the Config step.
Posted By: Crasher

Re: Lost access to database following server restore - 01/12/2017 12:06 PM

Originally Posted by Gizmo
If you're on a different server now the paths to your hosting and the database access information are all likely different; follow the instructions in the UBBWiki Migration Guide to get yourself back up and running. In this case, since your host moved everything for you, start at the Config step.

Cheers Gizmo
Good to see some familiar faces still lurking here smile
Posted By: Gizmo

Re: Lost access to database following server restore - 01/13/2017 3:33 AM

:snicker: no problem, just writing documentation and coding; ask Isaac, I go overboard with it.
Posted By: Crasher

Re: Lost access to database following server restore - 01/13/2017 10:39 AM

Okay i now have access (to a degree).
None of the formatting is present (ie looks like the landing page has escaped from the early 80's!) so i probably need to clear all the caches down (cached paths to the css perhaps?) However...

Next issue is that i get a forbidden error when i click on the login link - so obviously the restore has trashed the finely crafted (and specific) UBB file permissions.

Anyone have a handly list of what needs to be set to what? I have sever access so can go through and manually set them accordingly.

Cheers
Posted By: Gizmo

Re: Lost access to database following server restore - 01/13/2017 5:08 PM

Have you updated the paths and urls? possible that something stale is just idling around; if you're going to purge caches via FTP you'll delete everything from templates/compile and /cache then run the content rebuilder in the Control Panel.

The UBB.threads System Requirements Test will report quite a bit of information about your hosting environment, including your full paths.

A rule of thumb about the permissions is 666 for files, 777 for directories; however, some environments are overzealous and will not let scripts execute from a directory that's chmodded 777 (in which case you'd chmod the directory that UBB.threads is in to 755).
Posted By: Crasher

Re: Lost access to database following server restore - 01/13/2017 5:38 PM

Thanks for the info (again)

After crawling through everything, the main culprit was the directory permissions on the top level ubbthreads7 directory - that was 750.
Quick change to 755 and i can log in.
Now to trawl through and sort out the minor issues smile

P.S. Site checker Test was most helpful - cheers
© 2019 UBB.threads PHP Forum Software Community