UBBCentral

Update to 7.6, Admin daschboard not reachable

Posted By: Landyphil

Update to 7.6, Admin daschboard not reachable - 02/27/2017 4:26 PM

Hello,

the update worked fine, there was only one file missing ".../ubb_portal/languages/german/admin/dashboard.php".
My workaround was to load the dashboard.php file from the english languagefiles.

With that workaround finisching the update worked fine.

So after proceeding these steps i want to open my borad again in the admin panel but if I click on the buton "Control Panel " the opened URL "http://www.viermalvier.de/admin/dashboard.php" gives me a blanc page, even the source code is empty.

Changing the permitions of the File "http://www.viermalvier.de/admin/dashboard.php" up to 0777 does change nothing.

Anny Help 4 me?

THX
Phil
Posted By: ehm1

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 4:48 PM

Phil, let me pigtail on your thread and state that I had exactly the same issue.
The language on my forum is Portuguese, I had to upload /dashboard.php from English, since it did not had on original download, and now I can't to go control panel.
Blank page.
Also change permissions and still not loading a page.
Any help?
Posted By: Landyphil

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 4:55 PM

Hi ehm,
so I am not alone, that feels better ;-).
Meanwhile i opened my board by editing the config.inc file so this point is fixed by myself.
The real issue that the control panel is not displayed is stil active, I gues we wil get asap some answers by the UBB Team.
CU
Phil
Posted By: ehm1

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 5:00 PM

I open my going to http://myforum.com/forum/admin/dbinfo.php
from that, I was able to navigate to general settings and open the forum.
it seams to be working well. but the control panel still not loading, like your.
So I'm assuming it's a bug
My current PHP is 5.6. I try with 5.4 same results.
EHM
Posted By: Gizmo

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 5:44 PM

/admin/login.php was changed to /admin/dashboard.php, /admin/dashboard.php should exist in your install archive, just upload it to the /admin folder from the LATEST zip posted to the member area (I'd say to look at the line in the dashboard since it lists the archive date to the right).
Posted By: Landyphil

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 6:04 PM

EHM1,
Thanks for the hint, yes this works to. another page witch is not displayed is "admin/phpinfo.php"
Cu
Philip
Posted By: Landyphil

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 6:07 PM

Originally Posted by Gizmo
/admin/login.php was changed to /admin/dashboard.php, /admin/dashboard.php should exist in your install archive, just upload it to the /admin folder from the LATEST zip posted to the member area (I'd say to look at the line in the dashboard since it lists the archive date to the right).

Hi Gizmo,

The file is uploaded and his date is 15th Feb. 2017 16:06 PM, I´ll check it out with the file on the UBB Server
Posted By: Gizmo

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 6:10 PM

Well, if you can't reach www.example.com/forum/admin/ or www.example.com/forum/admin/dashboard.php then it's probably not uploaded.
Posted By: Landyphil

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 6:13 PM

Hi Gizmo,

I just downloaded the package again and used these files to overwrite the complete folder "admin". no changes ... dashboard.php is not displayed
Posted By: Gizmo

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 6:17 PM

Just read that you chmodded http://www.viermalvier.de/admin/dashboard.php 777, change it to 644 and change the permission of the folder it's in (the /admin folder) to be chmodded 755 and see if it works; some servers do NOT want to execute PHP scripts if the folder they are in is world writable.
Posted By: Landyphil

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 6:23 PM

Originally Posted by Gizmo
Just read that you chmodded http://www.viermalvier.de/admin/dashboard.php 777, change it to 644 and change the permission of the folder it's in (the /admin folder) to be chmodded 755 and see if it works; some servers do NOT want to execute PHP scripts if the folder they are in is world writable.


Hi Gizmo,

after changing the permitions to try solutions I reset the permitions. So the folder "admin" ist 755 and the files are 644

[Linked Image]
Posted By: Gizmo

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 6:25 PM

Originally Posted by Landyphil
after changing the permitions to try solutions I reset the permitions. So the folder "admin" ist 755 and the files are 644

Just the files in the admin folder (as there is not an editor to edit the admin files), files outside of this folder can retain 666.

Is an error being logged in your server error logs? Have you modified the English language files that came with v7.6.0? Have you re-translated all of the language strings to your native language (I ask as language files from another version could cause problems as well).
Posted By: Landyphil

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 6:28 PM

Originally Posted by Gizmo
Originally Posted by Landyphil
after changing the permitions to try solutions I reset the permitions. So the folder "admin" ist 755 and the files are 644

Just the files in the admin folder (as there is not an editor to edit the admin files), files outside of this folder can retain 666.

Is an error being logged in your server error logs? Have you modified the English language files that came with v7.6.0? Have you re-translated all of the language strings to your native language (I ask as language files from another version could cause problems as well).


OK i meaned the files in the admin folder, the other ones i did not change
Posted By: Gizmo

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 6:40 PM

Originally Posted by Gizmo
Is an error being logged in your server error logs? Have you modified the English language files that came with v7.6.0? Have you re-translated all of the language strings to your native language (I ask as language files from another version could cause problems as well).

Posted By: Landyphil

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 6:50 PM

Originally Posted by Gizmo
Originally Posted by Gizmo
Is an error being logged in your server error logs? Have you modified the English language files that came with v7.6.0? Have you re-translated all of the language strings to your native language (I ask as language files from another version could cause problems as well).



Hi Gizmo

I did not check the server errorfiles, that is what I will do.next.
The English language files are not modificated.
I have 2 languages instaled english and german, so I did the folowing test:
* deleted all the folder/files in the folder .../language/german and replaced them by the original folders/files out of the .../language/english

This was not the solution so I restored my Folder .../language/german to the state as it was after processing the update.
So far thanks for support

Phil
Posted By: ehm1

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 7:02 PM

Originally Posted by Gizmo
/admin/login.php was changed to /admin/dashboard.php, /admin/dashboard.php should exist in your install archive, just upload it to the /admin folder from the LATEST zip posted to the member area (I'd say to look at the line in the dashboard since it lists the archive date to the right).

Gizmo,
the /admin/dashboard.php is there on the 7.6 package yes. but it's not getting transferred to the languages other then English. I did that manually, but still not working.
As I stated, I'm and other here are getting a blank page.
No error created, (not even on the server log).

There is another dashboard.php under /languages/english/admin/dashboard.php.
They are both different. I try to upload each one to the /languages/english folder, but same results.

So any other way we can debug it?
Posted By: isaac

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 7:26 PM

For reference:
Purely looking at core "actual files", not their "file contents"
(this list also does not include the new addon feature libraries)

THESE FILES WERE REMOVED
admin\login.php
languages\english\admin\editskin.php
languages\english\admin\login.php
libs\email.html
templates\default\admin\login.tmpl
templates\default\viewpoll.tpl


THESE FILES WERE ADDED
admin\dashboard.php
admin\suhosin.php
languages\english\admin\dashboard.php
languages\english\admin\suhosin.php
scripts\editnotify.inc.php
scripts\shoutchat.inc.php
templates\default\admin\dashboard.tmpl
templates\default\admin\suhosin.tmpl
templates\default\shoutchat.tpl


THESE FILES WERE CHANGED...
this list is too long, and irrelevant to this conversation.


At this time, English is the only language pack currently available for the 7.6 series. The 7.5 series had a lot of support over its nearly 10 year run. During that time, a lot of people contributed to creating different language packs for it. The 7.6 series was released less than a month ago. While most of the 7.5 series language strings will work in 7.6, there were many new items added. These items simply were not available in 7.5. Much of those items include descriptions, new features/options. Inlined items removed from the scripts and templates, to be put in the language files where they belong.

The problem right now, is that the two developers of this software only speak a single language. which is English. Could you imagine the mess and language-butchering, if we ran the strings through an automated service, such as Google Translate?

If you want to help translate from English, in to your own language, we would be grateful for that, as would many others who could use your contributed translations.
Posted By: Landyphil

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 7:45 PM

Originally Posted by id242

The problem right now, is that the two developers of this software only speak a single language. which is English. Could you imagine the mess and language-butchering, if we ran the strings through an automated service, such as Google Translate?

If you want to help translate from English, in to your own language, we would be grateful for that, as would many others who could use your contributed translations.


HI,

wel actualy this is not our problem, I will do the translation of the laguage files myself file by file.
Our problem keeps existing even iff I change the complete content in my folder languages/german with those out of the folder languages/english. For me it seamed to be an other problem. Did you tried to run a Update on a forum with more as one language instaled? this should be a testcase for the future...
You do not need a translation of the files for this case just make a copy of the folder english and rename it in "whatever".

At this moment i am not able anymore to fix the isue out of my +10 Years experience with UBB ...
Posted By: ehm1

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 7:52 PM

I understand the language issue. Back in the years I also helped with my own translation for Portuguese and I'm not asking the developers to do otherwise. This is why the community exist. smile smile to help each other.
But the issue is something else then just language.
I did the same test Landyphill did: removed all files from my /languages/portuguese/*.* copy over based on /languages/english/*.* same results.
so I copy back the portuguese now, and still the same.

Could be something else, that only happens with forums that have other language then English? (but not related with the /languages/*.* folders) ?
Posted By: isaac

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 7:58 PM

Hmm. what you guys are doing "should just work."

Give me a few hours today to get caught up on a few things here, and I will work on reproducing the problem, using the steps you guys mentioned.

Your issues are not normal. And i am unaware of anything in the scripts that was changed which would produce a problem.

Again, thanks for the detailed "how to reproduce" steps.
Posted By: Landyphil

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 8:07 PM

I GOT IT.

When i uploaded the english language files in my folder "language/german/" I took them from the downloaded zip file from your Server.
But while processing the update the script changed something with these files.

So the solution is:
1) make a backup of the folder "language/your_language"
2) delete al the content on your webserver in the folder "language/your_language"
3) download al the content of the folder "language/english"
4) Upload these folders / files to your webserver in the folder "language/your_language

Now everything should work ... at least in english.

This is a major Bug because all non englisch UBB boards will run into this problem.



.... is now retranslating the files ;-)

Posted By: ehm1

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 11:43 PM

Landyphil,
this is a very good research. Congratulations.
Now, why don't we wait a bit for isaac @ id242, see if he can come up with a more practical solution, one that do not involve in translating the whole set of files again?
I can survive easy with /languages/portugues/admin folder all in English, but redo all /language/portugues/* again to Portuguese will be quite a pain.

id242, can you shine in? smile

tks.
Posted By: ehm1

Re: Update to 7.6, Admin daschboard not reachable - 02/27/2017 11:59 PM

Adding on my post:
if I delete and them upload only /language/english/admin to /languages/portugues/admin per Landyphil observation, it is working.
The screen seams to be very 'unattractive' if compared with the one before version 7.6, (Like a wrong CSS), but it's working now. All back to English.

[Linked Image]
Posted By: isaac

Re: Update to 7.6, Admin daschboard not reachable - 02/28/2017 12:09 AM

Originally Posted by ehm1
The screen seams to be very 'unattractive' if compared with the one before version 7.6, (Like a wrong CSS), but it's working now. All back to English.



UBB.threads 7.5.x "Home"
[Linked Image]


UBB.threads 7.6.x Dashboard
[Linked Image]

edit: ignore the dates on my screenshots. thats a sandboxed build date. not an actual release date.
Posted By: Gizmo

Re: Update to 7.6, Admin daschboard not reachable - 02/28/2017 12:11 AM

I hate the old CP color scheme, lol...
Posted By: JAISP

Re: Update to 7.6, Admin daschboard not reachable - 02/28/2017 12:12 AM

I didn't like the old dark colors of the past.
Posted By: Gizmo

Re: Update to 7.6, Admin daschboard not reachable - 02/28/2017 12:13 AM

The new one is so easy on the eyes, and has suhosin/max vars warnings in case your host's settings aren't configured properly, and tons of stuff cleaned up.
Posted By: JAISP

Re: Update to 7.6, Admin daschboard not reachable - 02/28/2017 1:13 AM

I think the new one with the much needed information and color scheme is so much better. It's all the information you need right there.
Posted By: ehm1

Re: Update to 7.6, Admin daschboard not reachable - 02/28/2017 1:18 AM

I still finding the 'blank screen' in other pages:

admin/languageeditor.php

if I load that page, after placing a term to search on /forum/admin/availablelangs.php (display settings --> languages --> Search Edit)
the page render blank.
Posted By: Ruben

Re: Update to 7.6, Admin daschboard not reachable - 02/28/2017 8:27 PM

Originally Posted by ehm1
I still finding the 'blank screen' in other pages:

admin/languageeditor.php

if I load that page, after placing a term to search on /forum/admin/availablelangs.php (display settings --> languages --> Search Edit)
the page render blank.



Same here if you search all files.
Posted By: driv

Re: Update to 7.6, Admin daschboard not reachable - 02/28/2017 10:34 PM

I had this.

But then I did the fix for the 'Mark all read' bug.

There was clearly a template issue which was resolved by uploading those three files.
Posted By: ehm1

Re: Update to 7.6, Admin daschboard not reachable - 03/01/2017 12:35 AM

Originally Posted by driv
I had this.

But then I did the fix for the 'Mark all read' bug.

There was clearly a template issue which was resolved by uploading those three files.


Driv,
I check my and saw the 'mark all read' bug.
Then follow your link and got it fix,
but the Search language still with problems.

I did not have time to click on every link on the forum admin, but

Subscriptions -->View Subscriptions render a full page (The page lost the left column with all menus)
So, maybe there is more blank screens...
Let's wait for support
Posted By: isaac

Re: Update to 7.6, Admin daschboard not reachable - 03/01/2017 2:22 AM

Originally Posted by ehm1
Subscriptions -->View Subscriptions render a full page (The page lost the left column with all menus)
So, maybe there is more blank screens...
Let's wait for support


Thanks for this!

I just noticed this bug three nights ago (2/25). and patched it.

You're still able to use the page. nothing is broken within it. But the header and side menu are not displayed while in that report. There will be a new release which will fix this and a few other items which were caught and reported in the last two weeks.

As always, thank you for making a comment on this smile Each bug report helps everyone
© 2019 UBB.threads PHP Forum Software Community