UBBCentral
Posted By: AllenAyres Re: Version 7.5.7 Discussion - 12/13/2012 3:19 AM
Not sure where to put this, sooo...

When I submit my profile page (updating password), I get a blank screen and the password doesn't get updated.

IE9 and Firefox 17
Posted By: UBBSystems Re: Version 7.5.7 Discussion - 12/13/2012 3:33 AM
working on this... thx..
Posted By: UBBSystems Version 7.5.7 Discussion - 12/13/2012 3:51 AM
We had a bug in /languages/english/changebasic.php which prevented the users from updating their profile.

We have updated the file, if you were one of the first to install 7.57, please download the .zip again and just replace that one file.

thanks...
Posted By: Gizmo Re: Version 7.5.7 Discussion - 12/13/2012 4:12 AM
Looks great, I'm glad to see things moving forward!

The only problem that I see is that the CP is a huge step backwards, it was clean and elegant before, now it looks ugly and drab...
Posted By: Gizmo Re: Version 7.5.7 Discussion - 12/13/2012 5:20 AM
Member area access has always been required to access updates; this was true with every previous owner...
Posted By: driv Re: Version 7.5.7 Discussion - 12/13/2012 10:40 AM
Can't find custom.css as referred to in upgrade notes.
(Should it be common.css?)

Posted By: Pilgrim Re: Version 7.5.7 Discussion - 12/13/2012 11:42 AM
Okay, uploaded all the files/folders in the update package and ran the "install.php" file as has been typical of past upgrades. The result was BORKED FORUM.... it appears it has overwritten nearly everything including any and all settings. All of my previous Styles don't work, etc., etc., etc..... It's as if I installed a new forum and not an upgrade/update. At least the posts (database) wasn't wiped too.

So, the question is.... What do I do now? Can I upload my forum backup files and revert back to 7.5.6p2? Or, is there an easier fix.
Posted By: driv Re: Version 7.5.7 Discussion - 12/13/2012 12:00 PM
Hi Pilgrim,
I doubt there's much you can do about that except revert to a backup.

I suspect it should be a little more clear that existing users need to use upgrade.php and not INSTALL.html.

(Or at least add this option to INSTALL.html)
Posted By: UBBSystems Re: Version 7.5.7 Discussion - 12/13/2012 12:00 PM
Upload all files and directories from the unzipped UBB directory to the UBB installation directory, except for the:
  • includes
  • styles and
  • cache_builders/custom
directories.

Also copy over install/styles/admin.css and install/styles/common.css

Then...

Bring up the "install/upgrade.php" script with your web browser.
Posted By: Stan Re: Version 7.5.7 Discussion - 12/13/2012 12:03 PM
it would be so much easier if there was one zip file for install and one for upgrade...
Posted By: Bjab Re: Version 7.5.7 Discussion - 12/13/2012 12:10 PM
In install\Upgrade_changes.txt are all changed files listed so you can create your own upgrade package smile
Posted By: driv Re: Version 7.5.7 Discussion - 12/13/2012 12:49 PM
Originally Posted by Gizmo
The only problem that I see is that the CP is a huge step backwards, it was clean and elegant before, now it looks ugly and drab...
I like it smile
Posted By: driv Re: Version 7.5.7 Discussion - 12/13/2012 12:52 PM
Stop Forum Spam...

I signed up and got an API key.

Very carefully pasted/ inserted the key.

Nothing seems to be happening. When I 'Test connectivity', I get a blank alert box.

Quote:
Stop Forum Spam Query
API status:


Is this normal?
Posted By: Stan Re: Version 7.5.7 Discussion - 12/13/2012 1:16 PM
We are not able to keep logged in on this forum, is that going to be a problem on our forums?

It has been like this way for so long we have to wonder if it is unfixable.
Posted By: Pak Chan Re: Version 7.5.7 Discussion - 12/13/2012 1:53 PM
I can't find either of the files ("styles/custom.css" and "styles/admin.css") mentioned in the upgrade notes in the "ubbthreads-7-5-7\install\styles\" directory. I only have "1.txt", "2.txt", "3.txt", "4.txt", "5.txt" in mine.

As a result, I've aborted the upgrade and reverted back to the previous version. Did anyone else find this to be the case? Are these files supposed to be generated as a result of the upgrade?
Posted By: Bjab Re: Version 7.5.7 Discussion - 12/13/2012 2:17 PM
Originally Posted by Stan
OK, has the upgrade worked for anyone?


Worked perfect for me. I manualy uploaded (only) the changed files to my server and then runned the upgrade. Everything is working fine now. Stop-forum-spam is also working as it should.
Posted By: Stan Re: Version 7.5.7 Discussion - 12/13/2012 2:18 PM
good to hear, THANKS
Posted By: Pak Chan Re: Version 7.5.7 Discussion - 12/13/2012 2:24 PM
Bjab, did you have the "styles/custom.css" and "styles/admin.css" files in your install directory during your upgrade?
Posted By: driv Re: Version 7.5.7 Discussion - 12/13/2012 2:25 PM
Originally Posted by Stan
OK, has the upgrade worked for anyone?
Yep - no problems (apart from stop forum spam seemingly doing nothing)
Posted By: driv Re: Version 7.5.7 Discussion - 12/13/2012 2:26 PM
Originally Posted by Pak Chan
Bjab, did you have the "styles/custom.css" and "styles/admin.css" files in your install directory during your upgrade?
I had admin.css and common.css in mine.

I didn't upload the common.css file as the notes said it should be custom.css

However, during the upgrade procedure, the common.css file was called for - so I just uploaded it at that time.
Posted By: driv Re: Version 7.5.7 Discussion - 12/13/2012 2:28 PM
Ah - I think I see what you've done now.

The necessary files are in the styles folder - not the install/styles folder.
Posted By: Pak Chan Re: Version 7.5.7 Discussion - 12/13/2012 2:30 PM
Thanks! You're right. I assumed that because the instructions said from the install directory, they meant from the install directory, not from the install package.

I'll go ahead with my upgrade now then.
Posted By: isaac Re: Version 7.5.7 Discussion - 12/13/2012 2:34 PM
Originally Posted by Stan
OK, has the upgrade worked for anyone?


I'm doing a line-by-line manual install and find a small, but nice bit of code cleaning had been done in 7.5.7.

Most of the "//end if" comments have been removed, but there are still quite a few "// end while" and "// end for" comments remaining (intentional? quite possibly.)

I've noticed an inconsistency in the scripts as...
"defined( 'UBB_MAIN_PROGRAM' ) or exit;"
vs
"if(!defined("UBB_MAIN_PROGRAM")) exit;"


I've also noticed that while this is 7.5.7 and not the 7.6 which SD was working on through March 2012, his CSS updates were not included?

And most visibly, where SD's comment of the following code was...
Code
{*
  Version: 7.6
  Purpose: New user registration
  Future:
*}


now only reads as...
Code
{* Script Version 7.5.7 *} 


Also, I didnt notice SD's inclusion of Nivo Slider (for the portal), as mentioned in his 7.6 upgrade discussion... but then again, this is a 7.5.7 upgrade, not 7.6.

As far as I could tell, Smarty-2.6.19 is still being used in 7.5.7. Since upgrading my 7.5.6 install to Smarty-2.6.27 last year, my site seems to perform searches much more quicly.

After four hours, I am currently about 60% through my manual upgrade. I'll post more of my observations if more comes up.

Nice work and I am very happy to see a new version released - thanks!
Posted By: Pilgrim Re: Version 7.5.7 Discussion - 12/13/2012 2:36 PM
THANKS!! I uploaded the directories/files from 5.7.6p2, which I had in backup that you said should NOT have been upgraded from 5.7.7, and launched the "upgrade.php" utility. All is now working fine. [Linked Image]
Posted By: Gizmo Re: Version 7.5.7 Discussion - 12/13/2012 4:37 PM
Originally Posted by Stan
it would be so much easier if there was one zip file for install and one for upgrade...
Groupee used to do this, I believe it was condensed to one file to aid in having to manage multiple files... I always liked having two releases personally.

Originally Posted by Stan
We are not able to keep logged in on this forum, is that going to be a problem on our forums?

It has been like this way for so long we have to wonder if it is unfixable.
This issue has only affected me here, I have several installs and utilize threads on multiple servers and have never experienced the issue elsewhere...

Posted By: Gizmo Re: Version 7.5.7 Discussion - 12/13/2012 4:40 PM
Originally Posted by Stan
OK, has the upgrade worked for anyone?


I've successfully updated 7 installs thus far.

Originally Posted by Pak Chan
Bjab, did you have the "styles/custom.css" and "styles/admin.css" files in your install directory during your upgrade?
I think it's a typo for common.css

Posted By: isaac Re: Version 7.5.7 Discussion - 12/13/2012 6:46 PM
A manual 7.5.7 upgrade from a very customized UBBThreads 7.5.6 was quite easy.

I just unzipped the original 7.5.6 & 7.5.7 archives in to their own directories on a local computer. Then compared each directory/file in Beyond Compare to view the difference. Then, in another window, I modified my customized UBBThreads files with the differences. Next, I tested out my work on a local sandboxed server. Lastly, I read through any txt files in the install directory to see if I was missing anything or if there were database changes that needed to be done -- finding no "altertable" file for 7.5.6, there was no database mucking around to be done smile

This upgrade was quite simple and straight forward as usual.
Posted By: Gizmo Re: Version 7.5.7 Discussion - 12/13/2012 7:06 PM
I just did another 2 upgrades on some highly customized forums, using BeyondCompare to hash the changes; worked without a hitch...

I'm pretty sure it's just file changes between 7.5.6 and 7.5.7 as I didn't find an altertable (one forum I upgrade has a load balancer on the server, so everything must be done manually).
Posted By: driv Re: Version 7.5.7 Discussion - 12/13/2012 8:09 PM
Originally Posted by Gizmo
(one forum I upgrade has a load balancer on the server, so everything must be done manually).
Can you explain that please?
Posted By: Gizmo Re: Version 7.5.7 Discussion - 12/13/2012 8:20 PM
Balances the load caused by traffic on the server over multiple servers; it's pretty annoying, and I have no idea how they have it setup...
Posted By: driv Re: Version 7.5.7 Discussion - 12/13/2012 8:55 PM
Sorry - I understood about load balancing, I don't understand the upgrading manually bit. (Or have I misread the sentence?)
Posted By: Gizmo Re: Version 7.5.7 Discussion - 12/13/2012 9:03 PM
Originally Posted by driv
Sorry - I understood about load balancing, I don't understand the upgrading manually bit. (Or have I misread the sentence?)
Oh, all instances for "full_url" and "base_url" have to be updated to work with the load balancer in question.
Posted By: driv Re: Version 7.5.7 Discussion - 12/13/2012 10:29 PM
Gotcha thanks.
I'm about to apply load balancing to one of my sites and that's worth noting.
Posted By: Gizmo Re: Version 7.5.7 Discussion - 12/13/2012 10:30 PM
Originally Posted by driv
Gotcha thanks.
I'm about to apply load balancing to one of my sites and that's worth noting.
I'm not sure how other options work; personally I think I'd rather have MySQL on a separate machine than to balance everything between two servers...
Posted By: driv Re: Version 7.5.7 Discussion - 12/13/2012 11:08 PM
I am used to having MySQL on a different box, but now that you mention it... I haven't checked with this new host.

Actually, I thought it was only the http side of things that was load balanced. (Rather a naive consideration!)

I'll check tomorrow. Thanks Giz.
Posted By: SD Re: Version 7.5.7 Discussion - 12/14/2012 12:21 AM
Stop Forum Spam more info

2c
Posted By: SD Re: Version 7.5.7 Discussion - 12/14/2012 12:38 AM
Originally Posted by AllenAyres
Not sure where to put this, sooo...

When I submit my profile page (updating password), I get a blank screen and the password doesn't get updated.

IE9 and Firefox 17


notable for being the 1st bug identified/fixed laugh
Posted By: Stan Re: Version 7.5.7 Discussion - 12/14/2012 12:39 AM
feels like we are home, Thank you SD
Posted By: AllenAyres Re: Version 7.5.7 Discussion - 12/14/2012 1:46 AM
Originally Posted by SD
Originally Posted by AllenAyres
Not sure where to put this, sooo...

When I submit my profile page (updating password), I get a blank screen and the password doesn't get updated.

IE9 and Firefox 17


notable for being the 1st bug identified/fixed laugh


I try wink A bit rusty or I would have been faster smile
Posted By: Stan Re: Version 7.5.7 Discussion - 12/14/2012 4:01 AM
ALl my widths are wonky... anyone else have and solve this problem?

Thanks

Attached picture Screen Shot 2012-12-13 at 10.58.10 PM.png
Posted By: Stan Re: Version 7.5.7 Discussion - 12/14/2012 4:10 AM
Well Tuscany works, but it is hard on the eyes...
Posted By: doug Re: Version 7.5.7 Discussion - 12/14/2012 4:11 AM
Just upgraded and when I reached the end where I click on the link to return to my forums I receive this message - FATAL ERROR: Unable to find the english or english language directories. Please notify the administrator.

Any ideas as to why? I allowed the upgrade file to update the language files.
Posted By: doug Re: Version 7.5.7 Discussion - 12/14/2012 4:21 AM
Fixed. I deleted the languages directory and re-uploaded it and that seemed to fix it.
Posted By: SD Re: Version 7.5.7 Discussion - 12/14/2012 4:24 AM
Originally Posted by Stan
ALl my widths are wonky... anyone else have and solve this problem?

Thanks


you did a nono and copied 'wrappers.php' from the installer over the one you already had...

that's not what the instructions say..

you will need to look at AUS-CITY's thread and do the t_inner:width 100%; dealio that i told him.... wink
Posted By: Stan Re: Version 7.5.7 Discussion - 12/14/2012 4:43 AM
thanks, I appreciate that so much.

Posted By: SD Re: Version 7.5.7 Discussion - 12/14/2012 4:59 AM
you be welcome smile
Posted By: AndreasL Re: Version 7.5.7 Discussion - 12/14/2012 9:36 AM
Originally Posted by doug
Just upgraded and when I reached the end where I click on the link to return to my forums I receive this message - FATAL ERROR: Unable to find the english or english language directories. Please notify the administrator.
The same problem exists here on ubbcentral. I just crate a second account to post this.

If I try to login with my first account (which is set to german language) I also get:
Quote:
FATAL ERROR: Unable to find the german or english language directories. Please notify the administrator.


My ticket from yesterday is unsolved, still cannot login with my first account (Zarzal)

I cannot do an upgrade with the risk that everyone stuck on this error after upgrade.
Posted By: Gizmo Re: Version 7.5.7 Discussion - 12/14/2012 3:13 PM
It'd seem the character set needs updating as well; look at yarps name elsewhere...
Posted By: JetStar Re: Version 7.5.7 Discussion - 12/14/2012 4:35 PM
I have my board closed right now awaiting some clear instructions. Please provide details for those of us who do not do this but once every couple of years.

Step by step would be great.
Posted By: FordDoctor Re: Version 7.5.7 Discussion - 12/14/2012 5:30 PM
Originally Posted by JetStar
I have my board closed right now awaiting some clear instructions. Please provide details for those of us who do not do this but once every couple of years.

Step by step would be great.


A test installation of your forum using a test database in a test directory will also be valuable to you. I have found it best for me to set up a test forum and do a dry run first to identify issues before doing so on my live forums. Prevents whoopsies, inconveniences and emergencies. It also provides you with time to make tweaks and adjustments.
Posted By: Pilgrim Re: Version 7.5.7 Discussion - 12/14/2012 5:57 PM
Originally Posted by JetStar
I have my board closed right now awaiting some clear instructions. Please provide details for those of us who do not do this but once every couple of years.

Step by step would be great.

I didn't find anything in the way of destructions for this upgrade either and made some unfortunate mistakes. But the owner, Brooks, saved the day with simple but clear destructions which you can see here:

http://www.ubbcentral.com/forums/ubbthreads.php/posts/251191
Posted By: Ruben Re: Version 7.5.7 Discussion - 12/14/2012 6:26 PM
The old docs still apply for a upgrade at this point in time.
http://www.ubbcentral.com/doc_upgrade7.php
For special instructions for each upgrade always read the UPGRADE_INSTRUCTIONS.txt file located in the zip under the install folder
For this version it is noted to manually add to the process upload two css files only.
Posted By: SD Re: Version 7.5.7 Discussion - 12/14/2012 7:29 PM
i updated Brooks' original post you linked with bolding and more readable list

Clicky

this should be easier to digest for speed readers smile
Posted By: Jake Re: Version 7.5.7 Discussion - 12/14/2012 11:05 PM
I just upgraded to 7.5.7. The installation was quick and easy - as usual. I especially appreciate the StopForumSpam. Thanks!

BTW - We just passed our 16 year mark with this software.
Posted By: AndreasL Re: Version 7.5.7 Discussion - 12/15/2012 11:58 AM
Originally Posted by AndreasL
FATAL ERROR: Unable to find the german or english language directories. Please notify the administrator.
Problem still in place and not solved. Cant login here with my old account. Whats going on?
Posted By: AndreasL Re: Version 7.5.7 Discussion - 12/17/2012 2:03 PM
Hello? Anybody?

Ticket not answerd
Problem unsolved
CANT LOGIN here with my old account (Zarzal).

Under this condition I can't try an update to my board. I run a multi language board and can't risk that user can't login after update.

Whats going on?
Posted By: UBBSystems Re: Version 7.5.7 Discussion - 12/17/2012 2:18 PM
There is no ticket in the system from your email....
Posted By: AndreasL Re: Version 7.5.7 Discussion - 12/17/2012 3:32 PM
I dont dream it ...

copy & paste:

Hello Zarzal,

Your ticket has been received. One of our staff members will review it and reply shortly.

You can check the status of this ticket or reply online at https://www.ubbcentral.com/tickets/ticket.php?ticket=10896:PBB9MC

Sincerely,

UBB Support
https://www.ubbcentral.com


Ticket is closed but still unable to logon with zarzal@(...).de
This is my account that dont work anymore: http://www.ubbcentral.com/forums/ubbthreads.php/users/15/Zarzal
Posted By: DLWebmaestro Re: Version 7.5.7 Discussion - 12/17/2012 3:55 PM
There is no spoon
Posted By: UBBSystems Re: Version 7.5.7 Discussion - 12/17/2012 4:06 PM

again, there is no ticket, send in another one, I also searched for your license under your email and don't see it....
Posted By: UBBSystems Re: Version 7.5.7 Discussion - 12/17/2012 4:09 PM
fixed your profile with regards to the German language...
Posted By: Zarzal Re: Version 7.5.7 Discussion - 12/17/2012 6:57 PM
Ok, I'm back and can login. Thanks, but what exactly do you fixed and how? As I see there is only 1 language left here on UBB. As I write I have a multilanguage board. What happen if I renew my subscription and apply the update? Will I run with all accounts in this problem?

I have a license, but not renewed. I paid seveveral times with getting no updates so I sit back and wait what happen here.

I submit a bug with your ticket system that belongs to YOUR board, so my license dont take care. Its about you to fix your system.
Posted By: Stan Re: Version 7.5.7 Discussion - 12/17/2012 7:01 PM
This is sounding more and more like a forum that I know.

Let's remember this, please, things have just been rebooted here, more of a delay that I would like to have had.

Keeping this civil will only help this grow and expand into something profitable for all of us.

Posted By: SD Re: Version 7.5.7 Discussion - 12/17/2012 7:03 PM
go ahead and upgrade... the multiple languages work... just the new strings will be in Engrish... wink
© 2019 UBB.threads PHP Forum Software Community