UBBCentral

Administrator edit post limit?

Posted By: Max Fisch

Administrator edit post limit? - 08/11/13 02:03 AM

Under the group management section of the control panel, the Edit Post time limit for Administrators is 0 for all forums. I keep changing it and the changes aren't being made (go back to 0 when revisited). Is this a known bug?
Posted By: Ruben

Re: Administrator edit post limit? - 08/11/13 08:25 PM

could be a file permission issue.
Or operator error.
Set File & Directory Permissions

Unix & Mac Servers:

You must set the following permissions on the UBB™ files and directories. You can use your FTP software to set these permissions. For exact information on setting permissions in your FTP client, see the documentation included with that program.

includes/ directory: set permissions to 0777

files within the includes/ directory: set permissions to 0666

sessions/ directory: set permissions to 0777

templates/compile directory: set permissions to 0777

templates/ directory: set permissions to 0777

cache/ directory: set permissions to 0777

cache_builders/ directory: set permissions to 0777

cache_builders/custom/ directory: set permissions to 0777

files within the cache_builders/custom/ directory: set permissions to 0666

styles/ directory: set permissions to 0777

files within the styles/ directory: set permissions to 0666

tmp/ directory: set permissions to 0777

gallery/ directory: set permissions to 0777

directories within the gallery/default directory: set permissions to 0777

IN MY CASE THE ADMIN FOLDERS ARE SET TO 755 AND THE SCRIPT FILES ARE SET TO 644.

When you change the setting there are a few different ways to access it.
In your case group management is probably best.
Select the forum link to the right of admins.
ensure that you are editing the admin group at the top
Select edit post time
Enter time in MINUTES.
But to be honest I think for admins this is hard coded for forever. Depending on the version you are using.
Then select Update this groups permissions.
Try one forum if it is not working then go back to double checking file folder permissions.
Posted By: Max Fisch

Re: Administrator edit post limit? - 08/13/13 04:49 PM

I edited the permissions, and it's still not working.

I can change the admin limits by editing individual forum permissions - but can't do it in bulk starting from group management.

This is a new installation of 7.5.7 , installed professionally recently. I guess I should put in a support ticket?

Posted By: Ruben

Re: Administrator edit post limit? - 08/13/13 07:02 PM

That is what I would do.
It could be that script file for (group_forumperms.php) is corrupted and just need to re upload a new one file.
Posted By: Max Fisch

Re: Administrator edit post limit? - 08/17/13 08:52 PM

FYI this turned out to be a bug on 7.5.7
Posted By: Ruben

Re: Administrator edit post limit? - 08/17/13 08:54 PM

Originally Posted by Max Fisch
FYI this turned out to be a bug on 7.5.7

can you expand on that?
Posted By: Max Fisch

Re: Administrator edit post limit? - 08/19/13 02:34 AM

This probabably explains it best:
Changing the 0s to 1s on this screen doesn't work, and the support staff confirmed that it's a bug

http://maxfisch.com/images/permissions.JPG

As a workaround, you need to modify the setting from within a board's permissions, and do a mass copy if needed
Posted By: Ruben

Re: Administrator edit post limit? - 08/19/13 03:59 PM

Well if you look at the image you posted.
Just above that is edit post time limit.
That is what I referenced.

But in the past versions a admin was hard coded to always have the ability to edit. Even though the permissions said differently.
Even though the directive for future versions was to adhere strictly to the permission settings and shy away from all of those hard coded permissions.
But anyway I have the same version and I don't have the issue.
?????
Posted By: Max Fisch

Re: Administrator edit post limit? - 08/19/13 04:58 PM

Sorry I switched midstream ...

The Edit time post limit was fixed by modifing it from the permissions of each individual forum.

So I switched to demonstrating my issue by showing the "Edit any post" setting. Right now, it's set at 0, and the only way to change it is to edit to the individual forum permissions (or to do a mass forum permissions copy) ... I can't make a change from the shown screen.




Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/25/14 11:59 PM

This same problem is happening in 7.5.8 but I find it interesting that Reuben wasn't having any issues with it?????
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/26/14 12:01 AM

Actually, I am having that problem with other type of permissions.

I can't even do edits on my own posts as the Administrator under 7.5.8 in that training forum that I am trying to use to train moderators.
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/26/14 02:15 AM

I also did this, but still not able to do the group permissions without them reverting to zero.

Originally Posted by Ruben
could be a file permission issue.
Or operator error.
Set File & Directory Permissions

Unix & Mac Servers:

You must set the following permissions on the UBB™ files and directories. You can use your FTP software to set these permissions. For exact information on setting permissions in your FTP client, see the documentation included with that program.

includes/ directory: set permissions to 0777

files within the includes/ directory: set permissions to 0666

sessions/ directory: set permissions to 0777

templates/compile directory: set permissions to 0777

templates/ directory: set permissions to 0777

cache/ directory: set permissions to 0777

cache_builders/ directory: set permissions to 0777

cache_builders/custom/ directory: set permissions to 0777

files within the cache_builders/custom/ directory: set permissions to 0666

styles/ directory: set permissions to 0777

files within the styles/ directory: set permissions to 0666

tmp/ directory: set permissions to 0777

gallery/ directory: set permissions to 0777

directories within the gallery/default directory: set permissions to 0777

IN MY CASE THE ADMIN FOLDERS ARE SET TO 755 AND THE SCRIPT FILES ARE SET TO 644.

When you change the setting there are a few different ways to access it.
In your case group management is probably best.
Select the forum link to the right of admins.
ensure that you are editing the admin group at the top
Select edit post time
Enter time in MINUTES.
But to be honest I think for admins this is hard coded for forever. Depending on the version you are using.
Then select Update this groups permissions.
Try one forum if it is not working then go back to double checking file folder permissions.
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/26/14 11:48 PM

I assume that changing the permissions via FTP also works for Linux?
Quote:

System Linux box384.bluehost.com 3.4.81-20140220.1.bh6.x86_64 #1 SMP Thu Feb 20 19:48:38 EST 2014 x86_64
Posted By: Ruben

Re: Administrator edit post limit? - 03/27/14 06:36 PM

Yes,
I use Filezilla for FTP.
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/29/14 11:17 PM

I think I figured out what the problem is.

When I changed the PHP back to 5.2 all the permissions took, which means that they will not work under PHP 5.4 which also means it is a 7.5.8 bug that was obviously missed.

In other words, the permissions all work under PHP 5.2 but not under 5.4 with the problem being that the host will soon be removing PHP 5.2 as an option.
Posted By: isaac

Re: Administrator edit post limit? - 03/29/14 11:37 PM

Originally Posted by Daryl Fawcett
System Linux box384.bluehost.com 3.4.81-20140220.1.bh6.x86_64 #1 SMP Thu Feb 20 19:48:38 EST 2014 x86_64


I manage several UBBT 7.5.8 sites through BlueHost. I'm not getting the same problems as you guys are.

PHP version: 5.4.24
MySQL version: 5.5.36-log

If you're having problems with your UBBT forum on BlueHost, turn OFF "PHP 5.4 (FastCGI)" and use "PHP 5.4 (Single php.ini)" instead.

When using "PHP 5.4 (Single php.ini)" as default, all subdirectories will use ~/public_html/php.ini
DO NOT USE FastCGI. Long PHP requests through UBBT will have trouble accessing SQL queries.

In addition, in your .htaccess file at the root of your site directory, add this line to the top:

Code
AddHandler application/x-httpd-php54s .php

Comment-out or remove all other "AddHandler" lines.


---

EDIT:

From the BlueHost cPanel, in the "Software/Services" group, choose "PHP Config"
You will see six or more items in the "Bluehost PHP Configuration" group. For UBBT, the three that you should be concerned with, are:

PHP 5.4
All files with the extension .php will be handled by the PHP 5.4 engine.
Latest version of PHP.

PHP 5.4 (Single php.ini) <-- USE THIS ONE
Same as PHP 5.4, but all subdirectories will use ~/public_html/php.ini

PHP 5.4 (FastCGI)
All files with the extension .php will be handled by PHP 5.4 FastCGI processes.
FastCGI for PHP makes all your PHP applications run through mod_fastcgi instead of mod_suphp. This eliminates the overhead of loading the PHP interpreter on every hit. Since it is always in memory ready for the next hit, the responses will be generated faster.
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/30/14 10:46 AM

Originally Posted by id242
Originally Posted by Daryl Fawcett
System Linux box384.bluehost.com 3.4.81-20140220.1.bh6.x86_64 #1 SMP Thu Feb 20 19:48:38 EST 2014 x86_64


I manage several UBBT 7.5.8 sites through BlueHost. I'm not getting the same problems as you guys are.

PHP version: 5.4.24
MySQL version: 5.5.36-log

If you're having problems with your UBBT forum on BlueHost, turn OFF "PHP 5.4 (FastCGI)" and use "PHP 5.4 (Single php.ini)" instead.

When using "PHP 5.4 (Single php.ini)" as default, all subdirectories will use ~/public_html/php.ini
DO NOT USE FastCGI. Long PHP requests through UBBT will have trouble accessing SQL queries.

In addition, in your .htaccess file at the root of your site directory, add this line to the top:

Code
AddHandler application/x-httpd-php54s .php

Comment-out or remove all other "AddHandler" lines.


---

EDIT:

From the BlueHost cPanel, in the "Software/Services" group, choose "PHP Config"
You will see six or more items in the "Bluehost PHP Configuration" group. For UBBT, the three that you should be concerned with, are:

PHP 5.4
All files with the extension .php will be handled by the PHP 5.4 engine.
Latest version of PHP.

PHP 5.4 (Single php.ini) <-- USE THIS ONE
Same as PHP 5.4, but all subdirectories will use ~/public_html/php.ini

PHP 5.4 (FastCGI)
All files with the extension .php will be handled by PHP 5.4 FastCGI processes.
FastCGI for PHP makes all your PHP applications run through mod_fastcgi instead of mod_suphp. This eliminates the overhead of loading the PHP interpreter on every hit. Since it is always in memory ready for the next hit, the responses will be generated faster.

I wasn't having any problems either until I did some permission changes in the Moderator group and in the forum for training new moderators.

I was also using this one:
PHP 5.4 (Single php.ini) <-- USE THIS ONE
Same as PHP 5.4, but all subdirectories will use ~/public_html/php.ini
Posted By: isaac

Re: Administrator edit post limit? - 03/30/14 11:19 AM

I've done a DIFF between 7.5.7-r1 and 7.5.8-r2. There really has not been much changed within the admin files, nor has there been any changes in the DB structure.

You wrote that PHP 5.4 is giving you issues, but PHP 5.2 is not.

Two suggestions;

A) Do a backup of your live install and run a DIFF between it and a set of unmodified 7.5.8-r2 files.

B) Since you cannot create the exact same environment variables as BlueHost on your own sandboxed server; Have you created a fresh/clean install on your BlueHost account, next to your current install?

Such as, if your main install is in "/forums", do a fresh/clean install to "/forums.clean" -- and do the same with your database. A fresh/clean install, right beside your current install.

Perform the same member management changes you are attempting to accomplish with your live system.

Monitor your logs. If you're also having problems with your fresh/clean install with the same server settings as with your live install, it may be time to look further. ie; are other UBBT 7.5.8 owners having the same member modification problems? Are your php.ini (or even .htaccess) settings creating this undesired effect?

If this is such a widespread problem with UBBT 7.5.8-rX rel.11-29-2013 (also 7.5.7-rX ??? rel.12/12/2012) why has there not been much discussion regarding this within the past years since its release?

Are you using IE? onoes I've seen crazy stuff such as this, happen within IE... honestly.
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/30/14 01:32 PM

My PHP Version is 5.4.26 (You said that your's is 5.4.24)

My MySQL Version is 5.5.36-log
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/30/14 02:12 PM

I tried the following, which didn't work:

AddHandler application/x-httpd-php54s .php
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/30/14 02:17 PM

I am now going to wait for a reply from Ruben regarding my discovery that the permissions work OK using PHP 5.2.17 but they don't work using PHP 5.4.26 for the reason that I see this a a bug in that it isn't compatible with the PHP 5.4.26 latest version.

I am thankful that I still have the PHP 5.2.17 option, however, I have been told that it will eventually be removed as an option by the host. I hope a bug fix will be done before then.
Posted By: Ruben

Re: Administrator edit post limit? - 03/30/14 09:36 PM

Well don't wait on me.
the changelog states:
Quote:
Compatibility with php 5.4 and php 5.5. Additionally, this has been tested on mysql 5.6.
.
As stated by myself and ID242.
It could be just your ubb configuration.(files/settings,mods,etc)
I stated to reupload the same version he stated to created a virgin testboard.
Both should have shown evidence.
Since you rolled back your php version and it works now.
Could be anything because there are to many variables on how a host sets up your account settings.
Such as apache version,mysql version,fastcgi,modsecurity,php.ini.
I could go on forever.
And last, yes it could be a bug for your particular setup with your host.

So I revert back to what I said before.
Open a support ticket and let the big guns sort it out.

Mark stated he has the same issue but is using a different version.
As well as most all the other posts with similar issues .



Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/30/14 11:49 PM

I will call my host provider tomorrow and discuss it with them to see if they have a solution to the problem between the two PHP versions.
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/31/14 03:49 PM

FYI, this is my present server info in the Admin Control Panel:
Quote:
Server Info
Server Type Linux
Server Load 16.38
Web Server Apache
PHP Version 5.2.17
MySQL Version 5.5.37-log
Database Size 989.64 MB

As I stated, PHP 5.2.17 works OK, but the 5.4 one gives me all those permission problems.

Will soon be calling my Blue Host provider.
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/31/14 03:54 PM

FYI, this is my present server info in the Admin Control Panel using PHP 5.4:
Quote:
Server Info
Server Type Linux
Server Load 13.67
Web Server Apache
PHP Version 5.4.26
MySQL Version 5.5.37-log
Database Size 989.65 MB
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/31/14 06:13 PM

I called my host provider and he told me what to do.

Here is what I changed in my php.ini file:
Quote:
max_input_vars = 4000

It was originally at 2000 and then changed to 3000, but I had to change it again to 4000 before all the permissions would work.

Posting this here in case anybody else runs into this problem.
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/31/14 06:27 PM

Just finished testing my permissions, which all now seem to be working under PHP 5.4 smile
Posted By: Gizmo

Re: Administrator edit post limit? - 03/31/14 06:49 PM

Originally Posted by Daryl Fawcett
I called my host provider and he told me what to do.

Here is what I changed in my php.ini file:
Quote:
max_input_vars = 4000

It was originally at 2000 and then changed to 3000, but I had to change it again to 4000 before all the permissions would work.

Posting this here in case anybody else runs into this problem.
Well, it's as I suspected on my post here, I just couldn't ever find the post I was referencing; which, now that I see the "fix" from your host I can reference the 2012 bug report here and here.
Posted By: Ruben

Re: Administrator edit post limit? - 03/31/14 06:49 PM

All of the sites I look at have max_input_vars= 1000.
It probably had to do with suhosin , Suhosin version was targeted at PHP 5.3.9.
Which really should not be used anymore in PHP 5.3.9+ when the value was introduced.
At least that is how I read it, until they update Suhosin .
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 03/31/14 09:20 PM

Even 3000 didn't do it, therefore, I increased it to 4000.

I wonder if 3500 would have also resolved it?

Too bad there wasn't a way to index these so it would be easier to locate them and save us all from going through all this.
Posted By: Ruben

Re: Administrator edit post limit? - 03/31/14 09:36 PM

It would have appeared in the server logs.
If you have access to them.
Posted By: Daryl Fawcett

Re: Administrator edit post limit? - 04/01/14 05:44 PM

I will check and see if I can access them.
© 2017 UBB.threads PHP Forum Software Community