UBBCentral

PHP 7.0

Posted By: Jake

PHP 7.0 - 02/20/18 06:20 PM

UBB currently requires PHP 5.4 - 5.6.

The UBB forum I run is on a server that also supports a Joomla website. Joomla is planning to move to v4.0 in the near future. The new version requires (as a minimum) PHP 7.0.

Would UBB run with PHP 7.0? Has anyone tested it?

Thanks!

PS: I upgraded to 7.6.1.1 a few days after it was released. UBB rocks! Thanks to those working on it.
Posted By: isaac

Re: PHP 7.0 - 02/20/18 06:44 PM

php 7 support is being worked on. the current public version of ubbt.threads is compatible up to php 5.6.

I've been working on it with my limited time. so it will happen. it's just not there yet

cheers laugh
Posted By: JAISP

Re: PHP 7.0 - 02/20/18 10:05 PM

So when the new PHP7 compatible version comes out for UBB.threads will everyone have to upgrade to PHP7 or will it still run on the current platforms that the people are running now?
Posted By: Gizmo

Re: PHP 7.0 - 02/20/18 10:17 PM

Newer builds of UBB.threads that will be capable with being run on PHP7 will continue to run on older versions. Our minimum PHP version at this time will continue being PHP5.4.
Posted By: Jake

Re: PHP 7.0 - 02/20/18 10:28 PM

Thanks for the answers!
Posted By: driv

Re: PHP 7.0 - 02/21/18 01:25 PM

Hi Jake,
I'm not sure this is of any use to you as I'm using a shared hosting solution.

However, I currently run my Joomla site on php7.1 and have UBBthreads (on the same site) running on php5.5

In my forums directory I use a .htaccess rule that points at php5.5
© 2018 UBB.threads PHP Forum Software Community