UBBCentral
Posted By: Markus_003 [FIXED in b5] Default time offset - 08/14/2006 2:04 AM
I have a problem with a TIME OFFSET. My default time offset is +14 hours and at first it looks like it is working correctly. Although it will show last post according to the offset time, calendar is still showing a date in red according to original server time.

For instance, I am loging into my forum from Australia, but my server is in USA. Instead showing me Monday in color RED (14.08.06) it is still showing me Sunday in color RED.

For that reason LAST POST cell will display my post from yesterday as if it was written today. So instead of displaying yesterday's date it displays word TODAY at 9:06 AM. And posts entered today will display today's date (which is in Australia 14.08.96).

I hope this makes sence.

Posted By: Mark S Re: Default time offset - 08/14/2006 2:10 AM
Ahh ha,
That might be what my problem was..

The 23rd Hr

As my server is +1
Posted By: Markus_003 Re: Default time offset - 08/14/2006 2:18 AM
Mark, I have just seen description of your problem, and it looks to me that we are talking about the same problem.

For instance, take UBB.threads Version 7 Test forum. It is also showing my SUNDAY in red.
Posted By: Okusi Re: Default time offset - 08/15/2006 12:44 AM
i am located in indonesia, with server in vancouver, using a +14 offset. yes, i experience the same problems.
Posted By: Rick Re: Default time offset - 08/15/2006 2:26 AM
The calendar portion is a cache issue. The calendar is cached off of the local time so it doesn't have to rebuild events every page load. I'm going to need to see if I can somehow use some javascript to highlight the appropriate day depending on the user preference.
Posted By: Rick Re: Default time offset - 08/22/2006 8:00 PM
This should be fixed for b4. Using javascript to highlight the current date in the calendar, and there was a slight bug in the time conversion where it wasn't taking into account the server time offset when showing the last post dates.
Posted By: Markus_003 Re: Default time offset - 08/27/2006 12:28 AM
Current date is fixed, and the time showing in the last post dates is shown according to the server time offset, but word TODAY or YESTERDAY next to the date is still calculated according to the original server time, and not according to the time offset. Therefore all post written yesterday afternoon are still shown as TODAY.
Posted By: Jamin Re: Default time offset - 08/27/2006 4:20 AM
Same deal here, but vice-versa. My time offset is -1, which should make right now 11:20pm, but the posts made today are saying "yesterday" cuz the server time is 12:20am.

Just throwing in my $0.02 on this issue, since my wife brought it up.

---Jamin
Posted By: Markus_003 Re: Default time offset - 08/27/2006 9:21 AM
My time offset is + 14, therefore I have to wait 14 hours for correct display.
Posted By: Rick Re: Default time offset - 08/27/2006 3:45 PM
Ugh, this little feature is a pain in the butt wink Back to work on it.
Posted By: Rick Re: Default time offset - 09/06/2006 4:38 PM
Ok, I think I finally have this one nailed down.
Posted By: Gizmo Re: Default time offset - 09/06/2006 11:41 PM
Does this mean no more chasing me with a hammer? :'(
Posted By: Ian Re: Default time offset - 09/10/2006 8:38 AM
Originally Posted by Rick
Ok, I think I finally have this one nailed down.


Well done smile

Hmmm - just read the word 'think' wink tongue
Posted By: Rick Re: Default time offset - 09/10/2006 3:04 PM
That's why I haven't moved this one yet. Will need it tested by some people wink
Posted By: Ian Re: Default time offset - 09/10/2006 3:40 PM
heck - I am in so many time zones both in Europe and the USA at the moment that I do not even know the current time. laugh
Posted By: Markus_003 Re: Default time offset - 09/13/2006 7:01 AM
Originally Posted by Rick
Ok, I think I finally have this one nailed down.


I am sorry Rick but time display next to post heading is still not working correctly. Today or Yesterda will be shown depending on original server time and not by adjusted server time, as it should. So in my case I still have to wait 14 hours for correct display.
Posted By: Rick Re: Default time offset - 09/13/2006 2:36 PM
I don't get it. I've manually adjusted my time preferences, the server time, the time offset and everything displayed correctly. I may just have to end up taking this out completely because I can't seem to get this working for everyone. I'll give it one more shot.

Is it wrong for you in all areas? Or just on certain places?
Posted By: Markus_003 Re: Default time offset - 09/13/2006 3:17 PM
All areas? Same problem on this forum also.
Posted By: Rick Re: Default time offset - 09/13/2006 6:38 PM
Ok, so I totally reworked the math on this and have uploaded the changes here.
Posted By: Markus_003 Re: Default time offset - 09/13/2006 11:48 PM
I quickly checked few sections of this forum and it looks like this time is working. I will keep my eye on it and will come back frequently during the day (well during the nigth confused ).

Thank you for not giving up on this at first not so important issue. For some reason I like that feature (today, yesterday) but if is not displayed accurately then it is confusing.
Posted By: Markus_003 Re: Default time offset - 09/14/2006 2:45 PM
Yes this time it looks like it is working.
Posted By: Rick Re: Default time offset - 09/14/2006 2:52 PM
yay! Nothing better than finally fixing a bug that's been kicking my butt for awhile wink
Posted By: Gizmo Re: Default time offset - 09/14/2006 10:27 PM
I kick your butt and you don't fix me :nods: wink
Posted By: Rick Re: Default time offset - 09/14/2006 10:36 PM
Originally Posted by Gizmo
I kick your butt and you don't fix me :nods: wink


You're one of those bugs that I've given up on laugh
Posted By: Ian Spence Re: Default time offset - 09/14/2006 11:00 PM
Originally Posted by Rick
Originally Posted by Gizmo
I kick your butt and you don't fix me :nods: wink


You're one of those bugs that I've given up on laugh


I never did figure out that time code, but don't wanna wait for RC1, so could you just PM me the code?
© 2019 UBB.threads PHP Forum Software Community