Previous Thread
Next Thread
Print Thread
Hop To
[FIXED for 7.1.1] 7.0.2: Active Text corrupts URLs
#169172 11/26/2006 6:51 PM
Joined: Apr 2006
Posts: 143
Z65Paul Offline OP
member
OP Offline
member
Joined: Apr 2006
Posts: 143
If an element within a URL happens to be identified in Active Text, the software inserts the resulting active text response into the URL. In the case reported by one of my users, a subdirectory within the URL triggered the Active Text insertion.

Active Text should not apply to text within URLs.


Stress the system until it breaks. Hey.. it works for Spacecraft.. why not here?

UBB since 1999: MonteCarloSS.com
Re: 7.0.2: Active Text corrupts URLs
Z65Paul #169176 11/26/2006 7:06 PM
Joined: Aug 2006
Posts: 583
old hand
Offline
old hand
Joined: Aug 2006
Posts: 583
What he said..

Re: 7.0.2: Active Text corrupts URLs
Basil #169618 12/03/2006 1:11 PM
Joined: Jun 2006
Posts: 9,243
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Can you give me an example of how this is breaking? I've tried to duplicate this to fix it but so far it doesn't seem to be doing that for me.

Re: 7.0.2: Active Text corrupts URLs
Rick #169627 12/03/2006 4:28 PM
Joined: Jun 2006
Posts: 15,868
Likes: 1
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,868
Likes: 1
What I'm thinking is he's saying if you have an activetext for PHP (as www.php.net) then it'll try to change your url of www.my-php.com/mike/ to www.my-www.php.net.com/mike/


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: 7.0.2: Active Text corrupts URLs
Gizmo #169700 12/05/2006 3:16 AM
Joined: Apr 2006
Posts: 143
Z65Paul Offline OP
member
OP Offline
member
Joined: Apr 2006
Posts: 143
Yep.. that's what's happening. In the case that was reported to me, the active test trigger text was a subdirectory in the URL. Rick, if you need a link to the page where it occured on our site, let me know.


Stress the system until it breaks. Hey.. it works for Spacecraft.. why not here?

UBB since 1999: MonteCarloSS.com
Re: 7.0.2: Active Text corrupts URLs
Z65Paul #169869 12/07/2006 12:42 PM
Joined: Jun 2006
Posts: 9,243
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
If you can point me to where it's happening on your site that would be great. I can't duplicate it on my 7.1 beta board so it may be a valid bug that I fixed without knowing it.

Re: 7.0.2: Active Text corrupts URLs
Rick #169947 12/08/2006 10:15 AM
Joined: Apr 2006
Posts: 143
Z65Paul Offline OP
member
OP Offline
member
Joined: Apr 2006
Posts: 143
Turns out it is happening only when the url is inbetween IMG tags. Here's the example post:

http://www.montecarloss.com/community/ubbthreads.php?ubb=showflat&Number=387953

In this case, the term "SMCC" is active text.


Stress the system until it breaks. Hey.. it works for Spacecraft.. why not here?

UBB since 1999: MonteCarloSS.com
Re: 7.0.2: Active Text corrupts URLs
Z65Paul #178194 02/11/2007 12:10 AM
Joined: Apr 2006
Posts: 143
Z65Paul Offline OP
member
OP Offline
member
Joined: Apr 2006
Posts: 143
TTT Still a bug in V7.1b5


Stress the system until it breaks. Hey.. it works for Spacecraft.. why not here?

UBB since 1999: MonteCarloSS.com
Re: 7.0.2: Active Text corrupts URLs
Z65Paul #178219 02/11/2007 12:51 PM
Joined: Jun 2006
Posts: 196
enthusiast
Offline
enthusiast
Joined: Jun 2006
Posts: 196
I'm able to confirm it on my board. I think the cause is the regex not accounting for " />, only ">

Re: 7.0.2: Active Text corrupts URLs
Ian Spence #180954 03/19/2007 3:12 PM
Joined: Jun 2006
Posts: 9,243
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
This should be fixed for 7.1.1. I've added to the regex as Ian suggested and that appears to have fixed it.


Link Copied to Clipboard
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
AWS Lightsail platform
by jjjjj - 02/20/2020 7:27 AM
Users cant register after upgrade to Version 7
by Jim0421 - 02/13/2020 11:32 PM
Looking for best site firewall and CDN service
by Ruben - 02/11/2020 3:01 PM
custom island shows when logged in?
by Ruben - 02/11/2020 1:54 PM
Who's Online Now
0 members (), 60 guests, and 56 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Amusing Terain Scenics
Amusing Terain Scenics
by isaac, August 19
Sky places
Sky places
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20200221)