Actually, I've talked with our manager about upgrading...they're always reluctant to spend money!
I found out what the problem was. Somehow the permissions on the ACL for my perlbin directory became reset so that the IUSR_machinename account access was removed. But now I'm having a different problem. Here is the error message I'm recieving when I try to update my general settings via the control panel:
Unable to open thread summary file at D:Inetpubcgi-binubb/ubb_library.pl line 1406.
I've checked my mappings for .cgi & .pl files to make sure IIS knows how to handle them, and I've re-checked permissions for all concerned directories. Any other suggestions?