Well, you've already checked two of the three things that mainly cause internal server errors, the permissions and path to perl. The other one is to make sure all the files were uploaded in ASCII except for the .jpg & .gif files. If you left your FTP software on auto-detect mode during the upload then I will pretty much guarantee you that your Modules directory contents were uploaded as binaries (these are the several files with the .pm extension). Check to make sure.

If this turns out not to be the problem, then please complete a support ticket as Infopop will need to look at your board installation.