This could be caused by a security script on the server reading a "string" for spam blocking/hack attempts; does your webhost have error logging enabled for your site? If so I highly recommend that you look through the error log to see what the exact error is being published in the logs.