The FORUM_ID in the mapping table is only used for UBB.classic. UBB.threads will always go solely off the post and ignore the forum.

Hmm, how big is the post that's being inserted when you get the "Data too long" error? It could be that it's exceeding the character limitation for a TEXT field?

As for changing all to InnoDB. All of the .threads tables, currently need to be MyISAM. There are some quirks with running under InnoDB.