And all is set to 3 even in MySQL but all terms less than 5 characters is ignored.
Here is an example of searching for the term "bug" for 36 weeks, here on this board using 7.1b2
There are no results for your query. Please try a broader range of search criteria.
Please use your back button to return to the previous page.
It seems that 4 characters is searchable on THIS board, but on mine anything less than 5 returns the "no results" error and mine is set to 3 characters and I'm running 7.02 so I consider that broken.
In theory (not advised, but possible) if I set MySQL to search for 2 character length it will search for it (would cause problems and instablility but would still sort of work) yet now with it set to 3 I can not search for less than 5.
.