The problem was resolved. The issue was this:
The error log on the server propagated earlier to the point where all the discs were full. The forum tried writing to the config file, and when it saw that there was no space to write, it left the config file in the includes directory empty.
Replacing the config file with a replica solved the issue.