ok...I got past that... as it turned out it was a problem with the mySQL db being in strict mode.

So now when uploading the images there isn't an error, but there is a problem... They don't actually upload at all. I've checked all my permissions and they're fine. Both the tmp folder and the gallery have proper permissions.

I saw a post where there was a similar situation and it was permissions with the tmp folder, but that isn't the case here unless it needs to be an account different then the IUSR_account.

Everything looks to me like it should work. Is there a setting with Imagemagic that I need to make or something? I'm really unsure what direction to take at this point or even how to troubleshoot it.

Thanks for your help.