I haven't noticed a problem but I am not on much.
We were getting a similar errors on our board last year and suspected it was our host. We were getting SQL errors: "Script: - Line: Unable to connect to the database! - User xxxxxxx_ubb already has more than 'max_user_connections' active connections"!
Maybe ping the site and see what hops you take?