Might be strict; I haven't heard anyone running on 5.4, but if you enable it we could do some troubleshooting... Basically you need to run it until you hit an error; log the error (apache webserver logs, ubb logs, mysql logs, etc) then post them and I can help figure out the problem...