The reason you get a generic message is due to the actual error could display information not for public use.
Such as database connection info.Which could be a security risk.
If the admin of the site did the setup correctly they can log into the ubb control panel and view the actual error.

But usually the error means that the ubb could not connect to the database. For reasons such as the dbase server is offline. Or something changed in the dbase settings.

So if you have say a email contact with the site that would be best to contact them. In case they are not aware of the problem.

And the only people that have admin access would be whoever is the master admin that installed it. Unless that person has added others to be a admin.

Last edited by Ruben; 02/24/2013 6:58 PM.

Blue Man Group
There is no such thing as stupid questions. Just stupid answers