It all worked before their update, you should figure out what they changed...
I could recommend the
Test Script to see if it notices anything blocked (I have a newer version if this one fails to run on your system).
As for the APIs its a simple "curl" or "file_get_contents request" so they need to be enabled; also, if they disabled "allow_url_fopen" it'd also cause problems (as allow_url_fopen and file_get_contents are specifically used by the Stop Forum Spam API).
Also, a
524 Error seems to be a connection issue with CloudFlare according to
Google.