I downloaded a small portion of the 512 meg Error log and the problem was "Too many connections". I called my Host's tech support back and they bumped the ticket up to Level II. Within an hour I got a reply saying that the "Abuse Team" had arbitrarily disabled the Board (they didn't say how) because they said the Board was using too many resources. I did notice in the logs a huge amount of entries for "Yahoo Slurp!", which I suspect caused the "Too many connections".
I haven't a clue how to prevent this from happening again. So right now, I'm in a conundrum. []
http://www.the-highway.com/Smileys/hairout2.gif[/]
Thanks for taking the time to help out.