|
|
Joined: May 2006
Posts: 243 Likes: 1
Enthusiast
|
|
Enthusiast
Joined: May 2006
Posts: 243 Likes: 1 |
I am trying to install Threads for the first time. (We have a lively Classic 6.7.3 board.)
I have come to a roadblock on the Database settings.
I enter the following: Database server: localhost Database name: WHITNEY Database user: WHITNEY1 and the password.
Clicking the Check database Settings button returns:
Here we are checking your database connectivity and permissions. If any of these checks fail you will need to correct the errors in order to proceed. Connecting to server FAILED Connecting to database FAILED One or more of the above checks failed. Click the button below to return to the previous screen to verify your settings. I called the tech support line, and the guy tried it on that end, and it failed as well. He says the "localhost" is the correct name for the Database Server.
The only thing I have done differently in the primary install is to create the installation directory under /httpdocs as the name "forum" rather than "forums".
Hope someone here can help me out. Thanks in advance.
|
|
|
|
|
Joined: Jun 2006
Posts: 196
enthusiast
|
|
enthusiast
Joined: Jun 2006
Posts: 196 |
maybe try 127.0.0.1 instead of localhost?
|
|
|
|
|
Joined: May 2006
Posts: 243 Likes: 1
Enthusiast
|
|
Enthusiast
Joined: May 2006
Posts: 243 Likes: 1 |
Thanks for the suggestion. Tried 127.0.0.1, and got the same result.
By the way, I am installing on a unix server, running MySQL 4.1.11, and PHP 4.3.11
|
|
|
|
|
Joined: Jun 2006
Posts: 9,242 Likes: 1
Former Developer
|
|
Former Developer
Joined: Jun 2006
Posts: 9,242 Likes: 1 |
You'll want to verify the username and password are correct as well. If these are incorrect it can keep you from connecting to the database server completely.
|
|
|
|
|
Joined: May 2006
Posts: 243 Likes: 1
Enthusiast
|
|
Enthusiast
Joined: May 2006
Posts: 243 Likes: 1 |
Well, I can successfully log into their Server Administrator page using my username WHITNEY1 and the password. It gives me access to some PLESK-powered pages.
So I think I have the username/password set up ok.
Is there an alternate route I can go to determine the specific error begin returned?
|
|
|
|
|
Joined: Jun 2006
Posts: 9,242 Likes: 1
Former Developer
|
|
Former Developer
Joined: Jun 2006
Posts: 9,242 Likes: 1 |
The Username and password for your server admin page is more than likely different than the Database Username / Password. You could make a quick PHP script with just the following in it:
<?php
mysql_connect("localhost","username","password");
?>
Just name it something like test.php, replace "username" and "password" with the actual username/password and then put it into your install directory. Bring it up in your browser and it should give you more info.
|
|
|
|
|
Joined: May 2006
Posts: 243 Likes: 1
Enthusiast
|
|
Enthusiast
Joined: May 2006
Posts: 243 Likes: 1 |
Thanks. Tried it, got the following:
Warning: Access denied for user: 'WHITNEY1@localhost' (Using password: YES) in /usr/local/psa/home/vhosts/whitneyportalstore.com/httpdocs/forum/install/test_install.php on line 3
Warning: MySQL Connection Failed: Access denied for user: 'WHITNEY1@localhost' (Using password: YES) in /usr/local/psa/home/vhosts/whitneyportalstore.com/httpdocs/forum/install/test_install.php on line 3
Edit ...More info coming...
Last edited by Steve C; 01/08/2007 3:29 PM.
|
|
|
|
|
Joined: Jun 2006
Posts: 9,242 Likes: 1
Former Developer
|
|
Former Developer
Joined: Jun 2006
Posts: 9,242 Likes: 1 |
Ok, so it's definitely the username/password that is being used. You'll want to contact your host and find out the proper username/password to access your database.
|
|
|
|
|
Joined: May 2006
Posts: 243 Likes: 1
Enthusiast
|
|
Enthusiast
Joined: May 2006
Posts: 243 Likes: 1 |
Ok, solved the problem with your help. I used the PLESK pages to create a second user and used the above test php file to login to the database. What I found is that this system accepts a Database name and Database user in ALL LOWER case ONLY. This is in spite of the fact that I asked tech support to initially create everything using upper-case.
Once I switched to all lower-case, I got past the check database settings page.
Not sure if that is only a restriction on this server, but a note in your install instructions could be useful.
Thanks for the help!
|
|
|
|
|
Joined: Nov 2006
Posts: 3,097 Likes: 1
Carpal Tunnel
|
|
Carpal Tunnel
Joined: Nov 2006
Posts: 3,097 Likes: 1 |
Updated documentation is always good, but as an FYI Windows hosting is typically not case sensitive and Linux often is.
.
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
Most CPanels work independantly of the MySQL password; in fact, they generally utilize your user password on the maching (such as for ftp or ssh access); mysql is a seperate service with its own user system (as it has a very strict permission system).
And as NT said best, Windows does not care about cAsE SensATIvitY, which can be horrid with usernames and passwords (the option to be CaSe SENsITIve is a good security option as well as you can change a simple string into a useful/secure password due to how you EnTEr it).
|
|
|
|
|
Joined: Nov 2006
Posts: 3,097 Likes: 1
Carpal Tunnel
|
|
Carpal Tunnel
Joined: Nov 2006
Posts: 3,097 Likes: 1 |
Well passwords are case sensitive on Windows, just not the file system (though it can be but I've never seen anyone set it up or use it)
Cpanel is a pita but unless you've got the cash to buy a VPS or a real server not much choice.
phpAdmin gives me fits as well via CP
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
Well, I was referancing them as cpanels, not specifically the cpanel control panel... I was referancing: CPanel Webmin Plesk etc... Myself, I use Webmin as my cpanel, because I'm just that hardcore  lol... besides, I like customization 
|
|
|
|
|
Joined: Nov 2006
Posts: 3,097 Likes: 1
Carpal Tunnel
|
|
Carpal Tunnel
Joined: Nov 2006
Posts: 3,097 Likes: 1 |
No choice for me  Have to take what they give me as I don't have the cash to do my own server. But as I posted in another thread, was cool they gave me some free stuff by knowing my site already. 
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
I'm on a VPS, so I can customize just about anything; in fact, I just upgraded Webmin/Usermin/Virtualmin/PHP/MySQL on my CentOS4.4 VPS hehe
|
|
|
|
|
Joined: Nov 2006
Posts: 3,097 Likes: 1
Carpal Tunnel
|
|
Carpal Tunnel
Joined: Nov 2006
Posts: 3,097 Likes: 1 |
I thought you said you was broke  LOL
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
The VPS is free, my compensation for working 24/7 at my old place of employment...
|
|
|
|
|
Joined: Nov 2006
Posts: 3,097 Likes: 1
Carpal Tunnel
|
|
Carpal Tunnel
Joined: Nov 2006
Posts: 3,097 Likes: 1 |
That's cool. 
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
That's cool.  yes, fueling my addictions is cool 
|
|
|
|
0 members (),
171
guests, and
128
robots. |
|
Key:
Admin,
Global Mod,
Mod
|
|
|
|