Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
0 registered members (), 42 guests, and 259 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
isaac
isaac
California
Posts: 1,171
Joined: April 2004
Show All Member Profiles 
Top Posters(30 Days)
isaac 20
Gizmo 13
Ruben 11
Morgan 3
BB 2
Abbott 2
Latest Photos
Testing to drag photos
Comfortable Cats
Test
BSA photos
Chinese Buddhist temple.
Previous Thread
Next Thread
Print Thread
HTTPS issue with forum #261005
01/23/18 10:46 PM
01/23/18 10:46 PM
Joined: Jun 2006
Posts: 320
Sydney, Australia
Outdoorking Offline OP

enthusiast
Outdoorking  Offline OP

enthusiast
Joined: Jun 2006
Posts: 320
Sydney, Australia
Hi all,

Just updated the forum to version 7.6.1.1 and it has all gone great and has a few good features in it and I will be posting latter regarding some options that I would like if possible in the next version update.

I have now an issue (not related to the update done) and hoping that you might be able to help with so I can correct it, so I can get the green padlock back. I just downloaded a programe to check for errors and it has come back with the following (which seems to right through the forum):

Insecure Image: <img src="http://www.outdoorking.com/forum/uploads/usergals/2013/01/full-4181-9587-utekeep.jpg" alt="[Linked Image]" class="post-image" style="height:auto!important;max-width:100%!important;"/>

nsecure Image: <img src="http://www.outdoorking.com/forum/images/members/5772.png" alt="" class="alvt" style="max-height:100%;max-width:100%;object-fit:contain;">

It all seems to be images that have http and not https I think and was hoping that their might be an easy fix to the problem rather that go through every image as I have thousands of them on the forum.

Any assistance with this issue would be appreciated.


Regards,

Bruce
www.outdoorking.com
Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: HTTPS issue with forum [Re: Outdoorking] #261006
01/23/18 10:52 PM
01/23/18 10:52 PM
Joined: Apr 2004
Posts: 1,171
California
isaac Offline
UBB.threads Developer
isaac  Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,171
California
The answer you're looking for is in the "Docs" section of the top menu.

Update your database to your website's new URLs.

Direct link:
https://www.ubbcentral.com/forums/u...transition-your-forum-from-http-to-https


isaac @ id242.com // forum @ CelicaHobby.com
a current developer of UBB.threads php forum software // 7.6.2 Changelog
Re: HTTPS issue with forum [Re: Outdoorking] #261007
01/23/18 11:03 PM
01/23/18 11:03 PM
Joined: Jun 2006
Posts: 320
Sydney, Australia
Outdoorking Offline OP

enthusiast
Outdoorking  Offline OP

enthusiast
Joined: Jun 2006
Posts: 320
Sydney, Australia
Thank you for your assistance it is greatly appreciated.


Regards,

Bruce
www.outdoorking.com
Re: HTTPS issue with forum [Re: Outdoorking] #261008
01/23/18 11:18 PM
01/23/18 11:18 PM
Joined: Apr 2004
Posts: 1,171
California
isaac Offline
UBB.threads Developer
isaac  Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,171
California
After you update, your "secure test tool" should not present any more flags regarding your site. Though your tool may flag inlined images linked from third-party sites, or if you allow your users to use avatars linked from other websites.

There really is no other way around it, other than choosing one of the three following options.

Thes apply to linked images for Avatars, Signatures, Posts, Private Messages... and probably Profile Comments, if you have them enabled:
1) Remove all the linked images and disable their ability to use images other than what you've provided or what they've uploaded to you.
2) Disable the ability to hotlink images, and purely rely on user uploaded image attachments. This would mean that you'd be hosting their images.
3a) Just accept it.
3b) Just accept that everything before a certain date (today?) is the way it is, and make the changes so that everything going forward is 100% secure.

If you disable hotlinked images, IIRC, the forum will just display a link to that image, instead of trying to display it. This will pass your tool's test.


isaac @ id242.com // forum @ CelicaHobby.com
a current developer of UBB.threads php forum software // 7.6.2 Changelog

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Custom Insert won't save
by Baldeagle. 06/18/18 07:44 PM
New Image capabilities ver 7.6.1
by Abbott. 06/14/18 02:28 PM
Thread deleted?
by Lisanne. 06/05/18 11:13 AM
random 500 server errors on post
by Bad Frog. 05/31/18 09:34 AM
Upgraded from 7.6.0 to 7.6.1.1
by BB. 05/30/18 12:33 PM
Forum Statistics
Forums36
Topics35,121
Posts191,324
Members12,085
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.2
(Preview build 20180524)