Yeah, changing forum settings clears the cache.
It looks like the error is coming from the module we're using to perform the cache clear, which is built in to Perl. I don't know what would cause it to return a blank error. If an error occurs, it's supposed to actually return something useful, not just keel over like that.
Has this error ever made itself known on the frontend, or has it only appeared for you in the control panel?
When the error occurs, did you happen to notice whether or not the page took an exceptionally long time to return the error or not?