I narrowed it down. It turns out the server prevents the word
Lynx (only with a space after it). I know the server has some hacker keyword prevention or something enabled, but that's just too funny how crazy I was getting. And I was about to post the "error" here!
