Problem solved.

Two things prevented the uploads without any error message:

1: PHP requires that the user under which the web site runs as write access to the "default" temp folder, which is in my case c:\windows\temp

2: open_basedir must not be set

Perhaps there is a configuration setting which gives me more control about where temporary upload files are written to?