You said you fixed the first error? That error means you either don't have ImageMagick installed or are pointing to the wrong place in your config.

I'm not sure why you're getting that second error, but adding this line near the top of your image.inc.php file will work as a short-term fix until you can correct the underlying problem:
PHP Code
ini_set('memory_limit', '48'); 
Keep in mind it's only for a temporary fix. It adjusts the memory limit for that file; however, it would probably be a good idea to find the cause of the problem so you can nip it in the bud. You can adjust the '48' up or down to your liking. If you have access to your php.ini file, you can change this setting in there for all php files. Look for the line "memory_limit ="