Like I said I never tried remote access with ubb.
But your error message is a generic one from the language files If you have error logging turned on in the ubb you can view the actual error in cp>>logs
No worries. I don't expect you to know everything. (Isn't that Rick's job?

)
It's actually a circular problem. UBB has to have mysql access for ubb to log the event - not to mention for me to log into the bb or cp - before it will log the error about why it can't get to the database...