Remove that @ before file_get_contents and tell me if it throws an error.

As for your report about the status page, are you at the right page for the data you want? There are two of them, one, which has the api status test is pretty bare:
CP -> Master Settings -> Primary Settings -> Stop Forum Spam -> Test Connectivity

The other is when you're looking at a member and click "More Info" which has, more information.

The strings on the Test connectivity page are just:
$ubbt_lang['SF_SPAM'] = "Stop Forum Spam";
$ubbt_lang['SFS_STAT_DESC'] = "API Status: ";
$ubbt_lang['SFS_STAT_GOOD'] = "Can Connect";
$ubbt_lang['SFS_STAT_BAD'] = "Can Not Connect";
$ubbt_lang['SFS_TEST_IT'] = "Test Connectivity";

If the language strings do NOT load on these pages, you may not have the languages/english/admin/stop_forum_spam.php language file in place.

I wrote yet another test script for file_get_contents (there really isn't anything we can do at this point, it's a simple request from your server to their server, if something is found it just sorts the file):
PHP Code

<?php

$payload
= "91.200.13.3";

if(
function_exists("file_get_contents")) {
$fetch = file_get_contents("https://api.stopforumspam.org/api?ip=". $payload);
if(
$fetch != false) {
if(
$fetch != "Error") {
$xml = new SimpleXMLElement($fetch);

if(
$xml->appears == "yes") {
echo(
"We could connect to the Stop Forum Spam Database and have checked the dataset specified, the user \"". $payload ."\" is a spammer.");
} else {
echo(
"We could connect to the Stop Forum Spam Database and have checked the dataset specified, the user \"". $payload ."\" is <b>not</b> a spammer.");
}
} else {
echo(
"There was an error with the response from the Stop Forum Spam Database.");
}
} else {
echo(
"We could not establish a connection to the Stop Forum Spam Database, please ensure that your webhost does not restrict outside connections via the \"file_get_contents\" PHP Function.");
}
} else {
echo(
"The PHP function \"file_get_contents\" does not exist on this server.");
}
?>



You could also try my check new version code:
PHP Code

<?php

$build
= "20170101";
if(
function_exists("file_get_contents")) {
$source = file_get_contents("https://www.ubbwiki.com/latest/check/system-requirement-test");

if(
version_compare($source, $build, ">")) {
echo(
"<div style=\"text-align: center;\">\n\t<h2 class=\"heading notice\">Outdated Test Script Version</h2><br>\n</div>\n\nAn upgrade to the UBB.threads System Requirement Test is available, please see <a href=\"https://www.ubbwiki.com/\" target=\"_blank\">UBB.Wiki</a>: <a href=\"https://www.ubbwiki.com/latest/system-requirement-test\" target=\"_blank\">Latest System Requirement Test</a>. <b>Your Build</b>: ". $build ." <b>Latest Build</b>: ". $source ."<br><br>\n\n");
}
}
?>

Attached Files aaa.pngbbb.png

I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!