Hi Jake,
I'm not sure this is of any use to you as I'm using a shared hosting solution.

However, I currently run my Joomla site on php7.1 and have UBBthreads (on the same site) running on php5.5

In my forums directory I use a .htaccess rule that points at php5.5


Using version :: 7.6.0