The original error is that it can't find and/or write to the SQL Error logs - check the path and make sure that the directory and files are writable.

The second error is a corrupt database table.
The command Astaran posted should have fixed it. If not, then you might need a more advanced database repair. Most likely this is something your host would have to do for you, unless it's your own server.

Have the names of your tables been changed?
[]
Can't open file: 'w3t_MYISAMPosts.MYD'. (errno: 145)[/]

You might try

REPAIR TABLE w3t_MYISAMPosts


Joshua Pettit
Web Developer
www.ThreadsDev.net | www.JoshuaPettit.com