Previous Thread
Next Thread
Print Thread
Hop To
Forums over 30 not displaying properly in CP #113803 08/21/2004 1:28 PM
Joined: Jun 2004
Posts: 27
Singletrack Offline OP
newbie
OP Offline
newbie
Joined: Jun 2004
Posts: 27
I have recently added a 31st forum, and it's not showing when forums are sorted by number. If I sort by something else, it does show up, but then some other forum doesn't. In short, there's always only 30 forums showing. Version's 6.7.1.

Is there a link to page 2 of the forums listing missing, or is this a bug?


~ Scott
Express Hosting
Re: Forums over 30 not displaying properly in CP #113804 08/21/2004 6:52 PM
Joined: Apr 2004
Posts: 141
oracleweb Offline
member
Offline
member
Joined: Apr 2004
Posts: 141
try changing "offset=0;" to "offset=30;" in the url and see if that works.

Re: Forums over 30 not displaying properly in CP #113805 08/22/2004 10:08 AM
Joined: Jun 2004
Posts: 27
Singletrack Offline OP
newbie
OP Offline
newbie
Joined: Jun 2004
Posts: 27
That shows the forum missing in the listing with offset=0...


~ Scott
Re: Forums over 30 not displaying properly in CP #113806 08/22/2004 3:41 PM
Joined: Apr 2004
Posts: 141
oracleweb Offline
member
Offline
member
Joined: Apr 2004
Posts: 141
that means the pages work. I don't have 30 forums so I can't tell if there's a link to the next page though

Re: Forums over 30 not displaying properly in CP #113807 08/22/2004 7:18 PM
Joined: Jun 2006
Posts: 15,848
Gizmo Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,848
Ian, UGN has more and it allows me to see the next page link, but if i recall at 31 it wouldn't show but at 32 it would...


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Forums over 30 not displaying properly in CP #113808 08/22/2004 8:20 PM
Joined: Jun 2006
Posts: 346
Ron M Offline
enthusiast
Offline
enthusiast
Joined: Jun 2006
Posts: 346
I'm not haing any problems with my listing on 6.7.2. There should be a link in the bottom left to goto page 2.

Re: Forums over 30 not displaying properly in CP #113809 08/23/2004 6:28 AM
Joined: Jun 2004
Posts: 27
Singletrack Offline OP
newbie
OP Offline
newbie
Joined: Jun 2004
Posts: 27
There isn't with 31 forums, but I created another one (32nd) and now it does show. Classify this as a bug; there's a variable listed wrong somewhere.


~ Scott
Re: Forums over 30 not displaying properly in CP #113810 08/23/2004 10:47 AM
Joined: Jun 2006
Posts: 346
Ron M Offline
enthusiast
Offline
enthusiast
Joined: Jun 2006
Posts: 346
If you deleted any forms lower than 30, then 31 will show on page 1.

Re: Forums over 30 not displaying properly in CP #113811 08/23/2004 11:19 AM
Joined: Jun 2004
Posts: 27
Singletrack Offline OP
newbie
OP Offline
newbie
Joined: Jun 2004
Posts: 27
No. Read post #1. Only 30 show on the page at any time.


~ Scott
Re: Forums over 30 not displaying properly in CP #113812 08/23/2004 1:26 PM
Joined: Jul 2006
Posts: 2,144
David Dreezer Offline
Pooh-Bah
Offline
Pooh-Bah
Joined: Jul 2006
Posts: 2,144
Kate reported this internally a few months ago, and I could have sworn that I fixed it... I'll take a peek at the code...


This thread for sale. Click here! [Linked Image from navaho.infopop.cc]
Re: Forums over 30 not displaying properly in CP #113813 08/23/2004 1:32 PM
Joined: Jul 2006
Posts: 2,144
David Dreezer Offline
Pooh-Bah
Offline
Pooh-Bah
Joined: Jul 2006
Posts: 2,144
Yay for off by one errors.

Try this. cp2_forums.cgi, line 118 reads:

Code
if($end_point >= $total_forums) { $end_point = $total_forums - 1; }
Change >= to just >, then try viewing your forum list again.


This thread for sale. Click here! [Linked Image from navaho.infopop.cc]
Re: Forums over 30 not displaying properly in CP #113814 08/23/2004 2:59 PM
Joined: Jun 2004
Posts: 27
Singletrack Offline OP
newbie
OP Offline
newbie
Joined: Jun 2004
Posts: 27
Nope, still only showing 30...


~ Scott
Re: Forums over 30 not displaying properly in CP #113815 08/23/2004 3:09 PM
Joined: Jul 2006
Posts: 2,144
David Dreezer Offline
Pooh-Bah
Offline
Pooh-Bah
Joined: Jul 2006
Posts: 2,144
OKay... Please open a support ticket.

In the ticket body, include the URL to this topic and a note that I asked that the ticket be assigned to me.

Be sure to include valid FTP and admin login information so I can patch your board.


This thread for sale. Click here! [Linked Image from navaho.infopop.cc]
Re: Forums over 30 not displaying properly in CP #113816 08/23/2004 3:38 PM
Joined: Jun 2004
Posts: 27
Singletrack Offline OP
newbie
OP Offline
newbie
Joined: Jun 2004
Posts: 27
We're doing some work on the server right now and for the next few days, so that's not possible, things keep going up & down. It's not really a problem anyway as I'll be adding another forum in a couple of days anyway, and it functions ok as soon as I have more than 31. You don't need access to my forums to be able to track this bug down, do you?


~ Scott
Re: Forums over 30 not displaying properly in CP #113817 08/23/2004 4:31 PM
Joined: Jul 2006
Posts: 2,144
David Dreezer Offline
Pooh-Bah
Offline
Pooh-Bah
Joined: Jul 2006
Posts: 2,144
As you're the one experiencing the problem, it would be nice to work on your board, yes. It's not a super-urgent thing though, as you noted, so you can open the ticket at a later time.

We do plan a 6.7.3 release for some time around when the new product is going into beta, but that's still a while off. The bug would be fixed in that release.


This thread for sale. Click here! [Linked Image from navaho.infopop.cc]
Re: Forums over 30 not displaying properly in CP #113818 08/23/2004 5:03 PM
Joined: Jun 2004
Posts: 27
Singletrack Offline OP
newbie
OP Offline
newbie
Joined: Jun 2004
Posts: 27
Ok, I'll see about opening a ticket once things calm down on our end.


~ Scott
Re: Forums over 30 not displaying properly in CP #113819 08/23/2004 9:35 PM
Joined: Jun 2006
Posts: 15,848
Gizmo Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,848
At leat it won't be UBB.Classic 6.7.2a <img src="https://www.ubbcentral.com/boards/images/graemlins/wink.gif" alt="" />


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Forums over 30 not displaying properly in CP #113820 08/24/2004 8:39 AM
Joined: Dec 2003
Posts: 1,803
AllenAyres Offline
Pooh-Bah
Offline
Pooh-Bah
Joined: Dec 2003
Posts: 1,803
Odd, I'm running 6.7.1, have 42 forums, and they all show..... 30 1st page, 12 2nd page.....


- Allen
- ThreadsDev | PraiseCafe
Re: Forums over 30 not displaying properly in CP #113821 08/24/2004 11:35 AM
Joined: Jul 2006
Posts: 2,144
David Dreezer Offline
Pooh-Bah
Offline
Pooh-Bah
Joined: Jul 2006
Posts: 2,144
The bug only triggers if you have exactly 30 - the last one won't display.


This thread for sale. Click here! [Linked Image from navaho.infopop.cc]
Re: Forums over 30 not displaying properly in CP #113822 08/24/2004 5:26 PM
Joined: Dec 2003
Posts: 1,803
AllenAyres Offline
Pooh-Bah
Offline
Pooh-Bah
Joined: Dec 2003
Posts: 1,803
Ah... OK....

I just updated to 6.7.2 and all looks fine... <img src="https://www.ubbcentral.com/boards/images/graemlins/smile.gif" alt="" />


- Allen
- ThreadsDev | PraiseCafe
Re: Forums over 30 not displaying properly in CP #113823 08/25/2004 2:07 PM
Joined: Jun 2004
Posts: 27
Singletrack Offline OP
newbie
OP Offline
newbie
Joined: Jun 2004
Posts: 27
Actually, it triggers if you have exactly 31, not 30. 30 always show ok. One over that doesn't.


~ Scott
Re: Forums over 30 not displaying properly in CP #113824 08/25/2004 2:25 PM
Joined: Jul 2006
Posts: 2,144
David Dreezer Offline
Pooh-Bah
Offline
Pooh-Bah
Joined: Jul 2006
Posts: 2,144
Exactly 31? Okay, got it... that explains why I couldn't replicate it locally. <img src="https://www.ubbcentral.com/boards/images/graemlins/smile.gif" alt="" />


This thread for sale. Click here! [Linked Image from navaho.infopop.cc]
Re: Forums over 30 not displaying properly in CP #113825 08/25/2004 6:22 PM
Joined: Jun 2006
Posts: 15,848
Gizmo Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,848
I certainly hope you can replicate it now :x...


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!

Additional Resources
UBB Developers
UBB Wiki
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Strange Merge Issue
by Baldeagle - 08/16/2019 3:37 PM
Formatting Links
by Ty Griffin - 08/13/2019 4:39 PM
Changing from iso-8859-1 to UTF-8?
by Daryl Fawcett - 08/13/2019 9:58 AM
Threaded Mode
by ToddUGA - 08/10/2019 9:18 PM
Who's Online Now
0 registered members (), 38 guests, and 264 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Monkeyra
Monkeyra
London
Posts: 33
Joined: June 2006
Show All Member Profiles 
Forum Statistics
Forums34
Topics35,320
Posts192,710
Members11,865
Most Online2,569
Jul 27th, 2019
Random Gallery Image
Latest Photos
The Sky
Land Rocks
Cozy Places
Trees
Powered by UBB.threads™ PHP Forum Software 7.7.3