Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
2 registered members (mmkk, Gizmo), 61 guests, and 385 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
isaac
isaac
California
Posts: 1,004
Joined: April 2004
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 18
M4TT 12
FREAK 11
Ruben 8
isaac 4
mmkk 4
Latest Photos
Chinese Buddhist temple.
My buddha beads.
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Previous Thread
Next Thread
Print Thread
Forums over 30 not displaying properly in CP #113803
08/21/04 12:28 PM
08/21/04 12:28 PM
Joined: Jun 2004
Posts: 27
Colorado
S
Singletrack Offline OP
newbie
Singletrack  Offline OP
newbie
S
Joined: Jun 2004
Posts: 27
Colorado
I have recently added a 31st forum, and it's not showing when forums are sorted by number. If I sort by something else, it does show up, but then some other forum doesn't. In short, there's always only 30 forums showing. Version's 6.7.1.

Is there a link to page 2 of the forums listing missing, or is this a bug?


~ Scott
Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: Forums over 30 not displaying properly in CP #113804
08/21/04 05:52 PM
08/21/04 05:52 PM
Joined: Apr 2004
Posts: 141
O
oracleweb Offline
member
oracleweb  Offline
member
O
Joined: Apr 2004
Posts: 141
try changing "offset=0;" to "offset=30;" in the url and see if that works.

Re: Forums over 30 not displaying properly in CP #113805
08/22/04 09:08 AM
08/22/04 09:08 AM
Joined: Jun 2004
Posts: 27
Colorado
S
Singletrack Offline OP
newbie
Singletrack  Offline OP
newbie
S
Joined: Jun 2004
Posts: 27
Colorado
That shows the forum missing in the listing with offset=0...


~ Scott
Re: Forums over 30 not displaying properly in CP #113806
08/22/04 02:41 PM
08/22/04 02:41 PM
Joined: Apr 2004
Posts: 141
O
oracleweb Offline
member
oracleweb  Offline
member
O
Joined: Apr 2004
Posts: 141
that means the pages work. I don't have 30 forums so I can't tell if there's a link to the next page though

Re: Forums over 30 not displaying properly in CP #113807
08/22/04 06:18 PM
08/22/04 06:18 PM
Joined: Jun 2006
Posts: 16,788
Portland, OR; USA
Gizmo Online tapedshut
UBB.threads Developer
Gizmo  Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 16,788
Portland, OR; USA
Ian, UGN has more and it allows me to see the next page link, but if i recall at 31 it wouldn't show but at 32 it would...


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Forums over 30 not displaying properly in CP #113808
08/22/04 07:20 PM
08/22/04 07:20 PM
Joined: Jun 2006
Posts: 361
Des Moines, IA
Ron M Offline
enthusiast
Ron M  Offline
enthusiast
Joined: Jun 2006
Posts: 361
Des Moines, IA
I'm not haing any problems with my listing on 6.7.2. There should be a link in the bottom left to goto page 2.

Re: Forums over 30 not displaying properly in CP #113809
08/23/04 05:28 AM
08/23/04 05:28 AM
Joined: Jun 2004
Posts: 27
Colorado
S
Singletrack Offline OP
newbie
Singletrack  Offline OP
newbie
S
Joined: Jun 2004
Posts: 27
Colorado
There isn't with 31 forums, but I created another one (32nd) and now it does show. Classify this as a bug; there's a variable listed wrong somewhere.


~ Scott
Re: Forums over 30 not displaying properly in CP #113810
08/23/04 09:47 AM
08/23/04 09:47 AM
Joined: Jun 2006
Posts: 361
Des Moines, IA
Ron M Offline
enthusiast
Ron M  Offline
enthusiast
Joined: Jun 2006
Posts: 361
Des Moines, IA
If you deleted any forms lower than 30, then 31 will show on page 1.

Re: Forums over 30 not displaying properly in CP #113811
08/23/04 10:19 AM
08/23/04 10:19 AM
Joined: Jun 2004
Posts: 27
Colorado
S
Singletrack Offline OP
newbie
Singletrack  Offline OP
newbie
S
Joined: Jun 2004
Posts: 27
Colorado
No. Read post #1. Only 30 show on the page at any time.


~ Scott
Re: Forums over 30 not displaying properly in CP #113812
08/23/04 12:26 PM
08/23/04 12:26 PM
Joined: Jul 2006
Posts: 2,199
David Dreezer Offline

Pooh-Bah
David Dreezer  Offline

Pooh-Bah
Joined: Jul 2006
Posts: 2,199
Kate reported this internally a few months ago, and I could have sworn that I fixed it... I'll take a peek at the code...


This thread for sale. Click here! [Linked Image]
Re: Forums over 30 not displaying properly in CP #113813
08/23/04 12:32 PM
08/23/04 12:32 PM
Joined: Jul 2006
Posts: 2,199
David Dreezer Offline

Pooh-Bah
David Dreezer  Offline

Pooh-Bah
Joined: Jul 2006
Posts: 2,199
Yay for off by one errors.

Try this. cp2_forums.cgi, line 118 reads:

Code
if($end_point >= $total_forums) { $end_point = $total_forums - 1; }
Change >= to just >, then try viewing your forum list again.


This thread for sale. Click here! [Linked Image]
Re: Forums over 30 not displaying properly in CP #113814
08/23/04 01:59 PM
08/23/04 01:59 PM
Joined: Jun 2004
Posts: 27
Colorado
S
Singletrack Offline OP
newbie
Singletrack  Offline OP
newbie
S
Joined: Jun 2004
Posts: 27
Colorado
Nope, still only showing 30...


~ Scott
Re: Forums over 30 not displaying properly in CP #113815
08/23/04 02:09 PM
08/23/04 02:09 PM
Joined: Jul 2006
Posts: 2,199
David Dreezer Offline

Pooh-Bah
David Dreezer  Offline

Pooh-Bah
Joined: Jul 2006
Posts: 2,199
OKay... Please open a support ticket.

In the ticket body, include the URL to this topic and a note that I asked that the ticket be assigned to me.

Be sure to include valid FTP and admin login information so I can patch your board.


This thread for sale. Click here! [Linked Image]
Re: Forums over 30 not displaying properly in CP #113816
08/23/04 02:38 PM
08/23/04 02:38 PM
Joined: Jun 2004
Posts: 27
Colorado
S
Singletrack Offline OP
newbie
Singletrack  Offline OP
newbie
S
Joined: Jun 2004
Posts: 27
Colorado
We're doing some work on the server right now and for the next few days, so that's not possible, things keep going up & down. It's not really a problem anyway as I'll be adding another forum in a couple of days anyway, and it functions ok as soon as I have more than 31. You don't need access to my forums to be able to track this bug down, do you?


~ Scott
Re: Forums over 30 not displaying properly in CP #113817
08/23/04 03:31 PM
08/23/04 03:31 PM
Joined: Jul 2006
Posts: 2,199
David Dreezer Offline

Pooh-Bah
David Dreezer  Offline

Pooh-Bah
Joined: Jul 2006
Posts: 2,199
As you're the one experiencing the problem, it would be nice to work on your board, yes. It's not a super-urgent thing though, as you noted, so you can open the ticket at a later time.

We do plan a 6.7.3 release for some time around when the new product is going into beta, but that's still a while off. The bug would be fixed in that release.


This thread for sale. Click here! [Linked Image]
Re: Forums over 30 not displaying properly in CP #113818
08/23/04 04:03 PM
08/23/04 04:03 PM
Joined: Jun 2004
Posts: 27
Colorado
S
Singletrack Offline OP
newbie
Singletrack  Offline OP
newbie
S
Joined: Jun 2004
Posts: 27
Colorado
Ok, I'll see about opening a ticket once things calm down on our end.


~ Scott
Re: Forums over 30 not displaying properly in CP #113819
08/23/04 08:35 PM
08/23/04 08:35 PM
Joined: Jun 2006
Posts: 16,788
Portland, OR; USA
Gizmo Online tapedshut
UBB.threads Developer
Gizmo  Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 16,788
Portland, OR; USA
At leat it won't be UBB.Classic 6.7.2a <img src="https://www.ubbcentral.com/boards/images/graemlins/wink.gif" alt="" />


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Forums over 30 not displaying properly in CP #113820
08/24/04 07:39 AM
08/24/04 07:39 AM
Joined: Dec 2003
Posts: 2,046
Texas
AllenAyres Offline
Pooh-Bah
AllenAyres  Offline
Pooh-Bah
Joined: Dec 2003
Posts: 2,046
Texas
Odd, I'm running 6.7.1, have 42 forums, and they all show..... 30 1st page, 12 2nd page.....


- Allen
- ThreadsDev | PraiseCafe
Re: Forums over 30 not displaying properly in CP #113821
08/24/04 10:35 AM
08/24/04 10:35 AM
Joined: Jul 2006
Posts: 2,199
David Dreezer Offline

Pooh-Bah
David Dreezer  Offline

Pooh-Bah
Joined: Jul 2006
Posts: 2,199
The bug only triggers if you have exactly 30 - the last one won't display.


This thread for sale. Click here! [Linked Image]
Re: Forums over 30 not displaying properly in CP #113822
08/24/04 04:26 PM
08/24/04 04:26 PM
Joined: Dec 2003
Posts: 2,046
Texas
AllenAyres Offline
Pooh-Bah
AllenAyres  Offline
Pooh-Bah
Joined: Dec 2003
Posts: 2,046
Texas
Ah... OK....

I just updated to 6.7.2 and all looks fine... <img src="https://www.ubbcentral.com/boards/images/graemlins/smile.gif" alt="" />


- Allen
- ThreadsDev | PraiseCafe
Re: Forums over 30 not displaying properly in CP #113823
08/25/04 01:07 PM
08/25/04 01:07 PM
Joined: Jun 2004
Posts: 27
Colorado
S
Singletrack Offline OP
newbie
Singletrack  Offline OP
newbie
S
Joined: Jun 2004
Posts: 27
Colorado
Actually, it triggers if you have exactly 31, not 30. 30 always show ok. One over that doesn't.


~ Scott
Re: Forums over 30 not displaying properly in CP #113824
08/25/04 01:25 PM
08/25/04 01:25 PM
Joined: Jul 2006
Posts: 2,199
David Dreezer Offline

Pooh-Bah
David Dreezer  Offline

Pooh-Bah
Joined: Jul 2006
Posts: 2,199
Exactly 31? Okay, got it... that explains why I couldn't replicate it locally. <img src="https://www.ubbcentral.com/boards/images/graemlins/smile.gif" alt="" />


This thread for sale. Click here! [Linked Image]
Re: Forums over 30 not displaying properly in CP #113825
08/25/04 05:22 PM
08/25/04 05:22 PM
Joined: Jun 2006
Posts: 16,788
Portland, OR; USA
Gizmo Online tapedshut
UBB.threads Developer
Gizmo  Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 16,788
Portland, OR; USA
I certainly hope you can replicate it now :x...


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Users Unable to Upload Avatar [Not a Bug]
by M4TT. 12/13/17 08:51 AM
Shout Box Sound Effect
by M4TT. 11/29/17 08:28 PM
Ad island
by TGCsanderson. 11/25/17 06:41 PM
Taking to long to connect to DB
by AstroCat. 11/24/17 12:34 PM
Forum Statistics
Forums36
Topics35,015
Posts190,544
Members12,045
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171106)