Previous Thread
Next Thread
Print Thread
Hop To
Joined: Aug 2006
Posts: 18
Olly Offline OP
stranger
OP Offline
stranger
Joined: Aug 2006
Posts: 18
Parse error: syntax error, unexpected ',' in /usr/local/psa/home/vhosts/teentoday.co.uk/httpdocs/boards/styles/2.php on line 11

And when I try and select I just have a blank space in the list... do i have permissions set incorrectly?

Last edited by Rick; 10/05/2006 10:06 PM.
Joined: Jun 2006
Posts: 457
Likes: 1
Addict
Offline
Addict
Joined: Jun 2006
Posts: 457
Likes: 1
Which style and how did you import it ?


Happy Customer !!!
Joined: Aug 2006
Posts: 18
Olly Offline OP
stranger
OP Offline
stranger
Joined: Aug 2006
Posts: 18
I just used the importer to import a txt file. It's all of them so it's definitely something with my install... but this is a BRAND new install.

The exatct code is this when first trying to do it:


Parse error: syntax error, unexpected $end in /usr/local/psa/home/vhosts/teentoday.co.uk/httpdocs/boards/admin/importstyle2.php(95) : eval()'d code on line 1

Parse error: syntax error, unexpected $end in /usr/local/psa/home/vhosts/teentoday.co.uk/httpdocs/boards/admin/importstyle2.php(102)

Joined: Jun 2006
Posts: 9,242
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,242
Ok, first can you attach the contents of your styles/2.php file?

Is it one of the styles from this forum you've tried to import?

Joined: Aug 2006
Posts: 18
Olly Offline OP
stranger
OP Offline
stranger
Joined: Aug 2006
Posts: 18
can't attach php files so doing it as text..

i've tried many styles on this forum and all of them have created that error... is it to do with my hosting or permissions?

Attached Images
174-2.txt (224 Bytes, 572 downloads)
Joined: Jun 2006
Posts: 9,242
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,242
It appears that it's not loading anything from the the style being imported. Definitely not permissions as it wouldn't be able to write the file at all. It might be quickest if I can just FTP into your server and take a look at a few things. If that would work you can either send me details in a private topic here or open up a support ticket.

Joined: Jun 2006
Posts: 9,242
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,242
Ok, it appears that your php configuration didn't allow for the uploaded file to be read the way the code was setup. This is a bug that needs to be patched for anyone else that runs into this problem, so I'm moving this to the bugs forums. I've fixed your site.

If anyone else runs into this problem, edit admin/importstyle2.php. Line 60 looks like this:

Code
$file = file_get_contents($style_temp);

That, needs to be changed to this:

Code
move_uploaded_file($style_temp,"{$config['FULL_PATH']}/styles/import.txt");
$file = file_get_contents("{$config['FULL_PATH']}/styles/import.txt");
unlink("{$config['FULL_PATH']}/styles/import.txt");


Link Copied to Clipboard
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Issue Upgrading from 7.7.3 to 7.7.4
by Jake - 10/23/2020 3:02 PM
MySQL 5.6 upgrade to 5.7
by Morgan - 10/19/2020 6:19 AM
Custom islands error
by Morgan - 10/18/2020 7:25 AM
Saved Member Searches Enhancement
by Ruben - 10/10/2020 1:17 PM
RSS Feeds
by Mors - 10/06/2020 6:44 PM
Who's Online Now
2 members (Morgan, Ruben), 58 guests, and 66 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
gallery test
gallery test
by Mors, September 23
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Powered by UBB.threads™ PHP Forum Software 7.7.5
(Snapshot build 20201022)