Previous Thread
Next Thread
Print Thread
Hop To
#170149 12/12/2006 9:09 AM
Joined: Oct 2006
Posts: 51
Likes: 1
M
Journeyman
Journeyman
M Offline
Joined: Oct 2006
Posts: 51
Likes: 1
When I try to access my forum, I get the following message:

Quote
Script: /home/cust1/dbusername/html/forums/libs/ubbthreads.inc.php
Line#: 1979
SQL Error: Access denied for user 'dbusername'@'%' to database 'dbname'
SQL Error #: 1044
Query: replace into ubbt_CACHED_PERMISSIONS (USER_ID,CACHED_PERMISSION_DATA,CACHED_TIMESTAMP) values ( 3 , 'a:11:{i:1;a:3:{s:4:\"read\";s:1:\"1\";s:5:\"topic\";s:1:\"1\";s:5:\"reply\";s:1:\"1\";}i:10;a:3:{s:4:\"read\";s:1:\"1\";s:5:\"topic\";s:1:\"1\";s:5:\"reply\";s:1:\"1\";}i:11;a:3:{s:4:\"read\";s:1:\"1\";s:5:\"topic\";s:1:\"1\";s:5:\"reply\";s:1:\"1\";}i:2;a:3:{s:4:\"read\";s:1:\"1\";s:5:\"topic\";s:1:\"1\";s:5:\"reply\";s:1:\"1\";}i:3;a:3:{s:4:\"read\";s:1:\"1\";s:5:\"topic\";s:1:\"1\";s:5:\"reply\";s:1:\"1\";}i:4;a:3:{s:4:\"read\";s:1:\"1\";s:5:\"topic\";s:1:\"1\";s:5:\"reply\";s:1:\"1\";}i:5;a:3:{s:4:\"read\";s:1:\"1\";s:5:\"topic\";s:1:\"1\";s:5:\"reply\";s:1:\"1\";}i:6;a:3:{s:4:\"read\";s:1:\"1\";s:5:\"topic\";s:1:\"1\";s:5:\"reply\";s:1:\"1\";}i:7;a:3:{s:4:\"read\";s:1:\"1\";s:5:\"topic\";s:1:\"1\";s:5:\"reply\";s:1:\"1\";}i:8;a:3:{s:4:\"read\";s:1:\"1\";s:5:\"topic\";s:1:\"1\";s:5:\"reply\";s:1:\"1\";}i:9;a:3:{s:4:\"read\";s:1:\"1\";s:5:\"topic\";s:1:\"1\";s:5:\"reply\";s:1:\"1\";}}' , 1165932156 )
What do I need to do to get my message board working again?

Last edited by mjuby; 12/12/2006 9:45 AM.
mjuby #170151 12/12/2006 9:16 AM
Joined: Aug 2006
Posts: 583
old hand
old hand
Joined: Aug 2006
Posts: 583
I can't help you with the problem, but I would suggest that you not post your actual database and databse username. Suggest you edit to replace with something generic like "dbusername" and "dbname". We will still get the idea of your error but without you displaying to the world what your db user name is. Just food for thought. (Maybe im just paranoid after having been hacked)

Last edited by Basil; 12/12/2006 9:17 AM.
Basil #170156 12/12/2006 10:49 AM
Joined: Jun 2006
Posts: 9,242
Likes: 1
R
Former Developer
Former Developer
R Offline
Joined: Jun 2006
Posts: 9,242
Likes: 1
This looks like a MySQL permission problem. Basically, it's stating that it doesn't have permission to connect to the MySQL server. You'd want to contact your host and check to make sure you have the right info for connecting to the database.

Rick #170159 12/12/2006 11:23 AM
Joined: Oct 2006
Posts: 51
Likes: 1
M
Journeyman
Journeyman
M Offline
Joined: Oct 2006
Posts: 51
Likes: 1
Rick,

Thanks, I'll do that. Everything was working fine last night, then I found this mess this morning. I did not make any changes; heck, I didn't even make any posts last night. Do you have any idea what might have caused me to lose permissions?

By the way, I went to the mySQL administration page, where I was able to log in and browse the database. However, when I tried to edit a record, I received another #1044 error message. Sounds like you nailed it when you identified it as a mySQL permission problem.


Link Copied to Clipboard
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Add a post to additional forums
by Larry Miller - 01/27/2023 2:58 PM
What happens to modified templates during the upgrade
by Michael_E6D9 - 01/13/2023 2:11 AM
Attachments broken after server migration
by jgeoff - 12/22/2022 3:33 PM
Post Moderation Issue
by FREAK - 11/24/2022 1:07 PM
Users cannot register
by - 07/04/2022 8:42 PM
Who's Online Now
2 members (Larry Miller, Ruben), 195 guests, and 139 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Preview build 20221228)