|
|
Joined: Jun 2006
Posts: 693
Addict
|
|
Addict
Joined: Jun 2006
Posts: 693 |
Ever since upgrading to UBB 7.2 we've been crashing 2-3 times a day. I did just upgrade PHP to the most recent 5.2.3 - we were a little behind on that. We will see if that helps.
We've been running MySQL 4. I've installed MySQL 5 but to be honest I'm very nervous about doing this switch - I can imagine all sorts of disaster scenarios. It takes many hours to back up my forum database so this isn't a casual switch.
Any suggestions on how to go about doing this?
|
|
|
|
|
Joined: Nov 2006
Posts: 3,097 Likes: 1
Carpal Tunnel
|
|
Carpal Tunnel
Joined: Nov 2006
Posts: 3,097 Likes: 1 |
How large is the physical size of your Database?
What happens when you crash? What do the logs say?
|
|
|
|
|
Joined: Jun 2006
Posts: 693
Addict
|
|
Addict
Joined: Jun 2006
Posts: 693 |
My ibdata1 is 395mb, is that what you're curious about? Right now with both 4 and 5 on the system, it's hard to know which admin tools to run to look at things and I don't want to run anything that might mess things up. Things are tenuous enough as it is  When I installed 5, in fact, it gave me an error about not accessing the root account without a password - when I did have a password on 4 and had specified a password for 5 during the install process. So I'm not quite sure what is going on yet. Should I just run the "migrate" utility that came with MySQL 5, to bring the tables in from 4 to 5? Or should I do a database export in UBB, then somehow connect UBB to the 5 database and do a re-import? Can you even do that? OK I did risk running the SQL admin, the data len is 351mb and the index len is 119mb. The hosting guys say said: "What seems to be occurring with your system prior the hanging/reboot, the FTP, HTTP, and SMTP processes exit unexpectedly. These events usually occur about 50 times in sucession before the system finally crashes. Associated with these process errors are errors having to do with the ubbthread.php script which is the primary piece of code that runs your message forum." When I look at my error logs, I see lots of timeout errors even though my system shows it's only using 30% of its processor power and 50% of its memory. The system isn't "busy" and it's not doing anything else really. It's a dedicated machine. The event log is full of errors like this: "The World Wide Web Publishing Service service terminated unexpectedly. It has done this 11 time(s). The following corrective action will be taken in 0 milliseconds: No action. " SMTP, FTP and IIS Admin are doing the same crashing.
Last edited by BellaOnline; 08/17/2007 2:48 PM.
|
|
|
|
|
Joined: Apr 2007
Posts: 3,940 Likes: 1
Former Developer
|
|
Former Developer
Joined: Apr 2007
Posts: 3,940 Likes: 1 |
i did export from 4, then import to 5. worked really well.. i've never tried the migrate DB, but would expect that the mysql peeps got it right..
|
|
|
|
|
Joined: Jun 2006
Posts: 693
Addict
|
|
Addict
Joined: Jun 2006
Posts: 693 |
That seemed safest to me, too. So I will do the export ... then go into the admin settings and change all the entries to point to the MySQL 5 database - and then just run the import then? Now I have to figure out why MySQL 5 gave errors when I installed it, so that I can get MySQL 5 ready to handle the import ...
|
|
|
|
|
Joined: Nov 2006
Posts: 3,097 Likes: 1
Carpal Tunnel
|
|
Carpal Tunnel
Joined: Nov 2006
Posts: 3,097 Likes: 1 |
Hello Bella (girl dragon)
You're site is pretty big, are you sure that is the database size? Our site does not appear to be a big as your site and our DB is bigger than that.
Since this is Server 2003 and you have root (Remote Desktop or SSH access) I have a script that will backup your site, db, etc automatically for you. The DB backup shouldn't take very long to run at all.
I would NOT do any upgrades without a solid backup though.
|
|
|
|
|
Joined: Jun 2006
Posts: 693
Addict
|
|
Addict
Joined: Jun 2006
Posts: 693 |
The BellaOnline forums are only 2000 - I'm asking them to upgrade this to 2003. I believe my other forums on the wineintro.com are on 2003 which might be confusing people  I run two different UBB forums, for 2 different sites I own. The numbers I gave are from the SQL administrator tool for the active UBB database. I'm not sure what else to check, to verify it ...
|
|
|
|
|
Joined: Nov 2006
Posts: 3,097 Likes: 1
Carpal Tunnel
|
|
Carpal Tunnel
Joined: Nov 2006
Posts: 3,097 Likes: 1 |
No that sounds okay then.
Well the backup scripts I have won't run on 2000, has to be 2003
If you shell / remote desktop into your server though you should be able to save your DB pretty quick via command line from a MySQL prompt.
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
I upgraded vs migrated on mine, though it's easier when you have a yum repository at your side  ... A simple "yum upgrade mysql" and I was upgraded in about 10 seconds :x
|
|
|
|
|
Joined: Jun 2006
Posts: 693
Addict
|
|
Addict
Joined: Jun 2006
Posts: 693 |
Well, it was 12:34am when I began the export operation in UBB, and the last file came out at 3:17am. So it's not 10 seconds for me It was a many hour process, but I do now have all the data in MySQL 5 and have rebooted. Things look good so far, although we're still getting a lot of timeout errors. So MySQL5 didn't help those. The server says it's idle, so it's not that the server is busy. I wonder why it's timing out ... but at least I now have that server with the latest PHP and the latest MYSQL so we are narrowing down the things to work on. My next step is to get the server guys to upgrade the server from 2000 to 2003. That might take a few days though, so I'm going to start playing with PHP and MySQL ini files in the meantime.
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
well, exporting data then importing it isn't necessarily the norm when upgrading mysql; at least from my perspective... then again i've yet to work with mysql in windows... I'd have still tried upgrading the thing while backing up the flat files that hold the db information... but that's just me...
|
|
|
|
|
Joined: Jun 2006
Posts: 693
Addict
|
|
Addict
Joined: Jun 2006
Posts: 693 |
I guess I've found with databases that the database gets all "jumbled" internally after a while, and when you do a full export and re-import, that everything lays out smooth and in order on the disk and suddenly things run much more quickly. So for me it's a worthwhile thing to do every once in a while. We're still getting the crashes of IIS/FTP/SMTP every 1/2 hr or so, so MySQL5 didn't fix the problem, but at least we're narrowing down the culprits  To see what I'm facing, the server rebooted at 9:15am today. Since then, these are the times of the "crash quad" of IIS/FTP/SMTP/IISA: 10:11 10:43 11:16 11:40 11:41 12:38 12:38 1:10 2:15 3:39 3:41 3:42 3:43 so eventually it's going to crash again, once these rack up enough.
|
|
|
|
|
Joined: Nov 2006
Posts: 3,097 Likes: 1
Carpal Tunnel
|
|
Carpal Tunnel
Joined: Nov 2006
Posts: 3,097 Likes: 1 |
Hi Bella I've been doing Windows Admin work now for over a dozen years and I would HIGHLY recommend a NEW install of Server 2003 and not do an upgrade if at all possible. When you upgrade you bring in all the trouble and trash of the old Registry and mis-behaving applications.
I know a clean new install is costly both money and time wise but you will be much better off in the long run (IMHO)
I have not done an "upgrade" to a Server now in over 5 or 6 years as myself and others just got tired of the issues it brought with it. A clean install is the way to go.
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
I will concourr with NT on the fresh install comments, and highly agree with his reasoning
|
|
|
|
0 members (),
563
guests, and
80
robots. |
|
Key:
Admin,
Global Mod,
Mod
|
|
|
|