Previous Thread
Next Thread
Print Thread
Hop To
#200108 10/29/2007 12:23 AM
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
All in all I seem to be having problems working with the control panel and manipulating my stylesheets. Somehow while using the "Copy Style Settings from" feature it wiped out my original ubbthreads_stock sheet. I had to paste a backup I had into the ubbthreads_dark sheet in order to get it to work. I also had to replace several tags that were omitted/deleted as well. When trying to import stylesheets I get this error

Parse error: syntax error, unexpected $end in /home/mminnis/public_html/forums/ubbthreads/admin/importstyle2.php(98) : eval()'d code on line 1

Parse error: syntax error, unexpected $end in /home/mminnis/public_html/forums/ubbthreads/admin/importstyle2.php(127) : eval()'d code on line 1

and then finally end up on page displaying this
Parse error: syntax error, unexpected ',' in /home/mminnis/public_html/forums/ubbthreads/styles/10.php on line 11

How does this feature work? Do I have to import it from a local machine? Can I just FTP my stylesheets in? If so how do I get them to display in the editor. All in all I am lost when it comes to this versions process for working with the css sheets.

Any help will be appreciated.



Emerald Forest Gaming Community
ChAoS #200109 10/29/2007 12:59 AM
Joined: Jun 2006
Posts: 16,299
Likes: 116
UBB.threads Developer
UBB.threads Developer
Joined: Jun 2006
Posts: 16,299
Likes: 116
the data is stored in the database, so just uploading them is a no no; I'm not at my pc right now but if someone could, please export the default stylesheets and upload them, if not I'll do it in the morning when I'm back home.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
thankyou thankyou, But how do I go about saving and or creating my new ones? I probably need these instruction written in crayola for me wink Is it that I am actually trying to import a .css file and its wanting a db?


Emerald Forest Gaming Community
Joined: Jun 2006
Posts: 16,299
Likes: 116
UBB.threads Developer
UBB.threads Developer
Joined: Jun 2006
Posts: 16,299
Likes: 116
well, you can't just import a css file; the ubb uses a dbdump for the styles for import; you should instead create your styles in the built in editor.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Jun 2006
Posts: 16,299
Likes: 116
UBB.threads Developer
UBB.threads Developer
Joined: Jun 2006
Posts: 16,299
Likes: 116
Just took a gander, I don't have any installs as of the default dark style; but I had this (not sure if it's even current).


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Jun 2006
Posts: 16,299
Likes: 116
UBB.threads Developer
UBB.threads Developer
Joined: Jun 2006
Posts: 16,299
Likes: 116
Looks like you can import it from install/styles/1.txt and install/styles/2.txt; just went in and poked wink


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
Well thats the problem. I dont seem to understand the built in editor. I tried using it and thats what wiped out my default style.I think I possibly selected edit from the prior screen when I should have chosen create new. The above link in your post is forbidden to me by the way.


Ok now I see I choose create new and then in the first section thats where I name it.

It takes too long to create it in the editor. Once I have the basic style created (within the editor) can I edit the style sheet via FTP? Thats what I have been doing so far and it seems to have worked. I edit the sheet manually on my desktop and then paste it into an existing style sheet on my server.


Emerald Forest Gaming Community
Joined: Nov 2006
Posts: 3,095
Likes: 1
Carpal Tunnel
Carpal Tunnel
Joined: Nov 2006
Posts: 3,095
Likes: 1
Should work just fine. Copy down to your workstation, use any editor you want, then copy back to the server and overwrite.

Just keep a backup of any originals you modify so that you can get back to the original if it doesn't look or work the way you wanted it to.

Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
Yeah I see how that is affecting the way 7.2.2 saves things in the database now. If I copy and paste then my new settings appear in the preview window but dont show up in the actual code editor (at the left). I have always made my changes before in editpad or used Dreamweaver to edit my .css sheets (remotely)up until now. I may have to retrain myself to do it differently. I can see how Threads method would be simpler for someone who wanted the complete "out of the box" type forums then this editor would be perfect, Can ye teach old dogs new tricks though?

Last edited by ChAoS; 10/29/2007 4:32 PM.

Emerald Forest Gaming Community
Joined: Apr 2007
Posts: 3,940
Likes: 1
SD Offline
Former Developer
Former Developer
Joined: Apr 2007
Posts: 3,940
Likes: 1
Originally Posted by ntdoc
Should work just fine. Copy down to your workstation, use any editor you want, then copy back to the server and overwrite.


that works ONE time. but if you then edit that particular style, it will grab the DB stuff and all your nice text edits are gonzo. that's why you'll see what looks like multiple copies of xxxx.css in your styles folder..

the key is to use import or copy from existing to get a new db entry for the style then use the style editor in the control panel. when you 'save', the db entry is updated and a new xxxx.css file is created to be included by your forum.

ftp'ing doesn't cut it.

SD #200154 10/29/2007 5:18 PM
Joined: Nov 2006
Posts: 3,095
Likes: 1
Carpal Tunnel
Carpal Tunnel
Joined: Nov 2006
Posts: 3,095
Likes: 1
LOL - SD beat me to an update. Was thinking about it and thought, hmmm I better go back and rephrase what I said.

Some pages can be edited that way just fine, but due to how PHP and your database are working together many pages are built on the fly so an edit outside the program will not work properly.

SD #200160 10/29/2007 6:04 PM
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
Quote
that works ONE time. but if you then edit that particular style, it will grab the DB stuff and all your nice text edits are gonzo. that's why you'll see what looks like multiple copies of xxxx.css in your styles folder..

Lol , yeah thats what happened the first time and thats how I lost my originals. I still need a copy of the default DB's if anyone has them please smile


Emerald Forest Gaming Community
Joined: Apr 2007
Posts: 3,940
Likes: 1
SD Offline
Former Developer
Former Developer
Joined: Apr 2007
Posts: 3,940
Likes: 1
look in your install/styles directory.

there should be a 1.txt and 2.txt

import those 2 and you have them back smile

SD #200175 10/29/2007 7:02 PM
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
Another problem. I am editing my boards main style sheet and I cannot get any of the values below the .new-alt-topicreplies class to save to the Database when I select update/addstyle they just remain blank. In fact after looking several of them i seem to be missing alot.

Last edited by ChAoS; 10/29/2007 7:28 PM.

Emerald Forest Gaming Community
Joined: Nov 2006
Posts: 3,095
Likes: 1
Carpal Tunnel
Carpal Tunnel
Joined: Nov 2006
Posts: 3,095
Likes: 1
Which browser are you using? I would highly recommend using FireFox 2.x instead of IE for doing the editing. There have been numerous issues with caching and IE in the past.

Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
I have to use IE at work. Firefox is considered a security risk and is forbidden. Betcha can guess where I work. I am going to have to look at my tables tonight or put in a ticket. Im thinking the Databases are bugged


Emerald Forest Gaming Community
ChAoS #200201 10/29/2007 10:46 PM
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
All the boxes in the style sheet editor below the value of .new-alt-topicreplies are blank . I had to actually paste these into my stylesheet from an original that I had fortunately saved. Any idea how to correct this error?


Emerald Forest Gaming Community
ChAoS #200208 10/30/2007 12:19 AM
Joined: Jun 2006
Posts: 16,299
Likes: 116
UBB.threads Developer
UBB.threads Developer
Joined: Jun 2006
Posts: 16,299
Likes: 116
Well, these new classes where added in 7.2.2, so if you upgraded that'd be the reason they're blank.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
Ok I think I still might be missing something here. If I go to the stylesheet editor and then down to the section for new-alt-topicviews [?] and (the box is blank mind you) and paste what I want in shouldn't it be saving it to the .css sheet? Or is there something wrong with my DB? Yes I did import from 6.5.5


Emerald Forest Gaming Community
Joined: Jun 2006
Posts: 16,299
Likes: 116
UBB.threads Developer
UBB.threads Developer
Joined: Jun 2006
Posts: 16,299
Likes: 116
It would save to the db then write out the data in the db to the flatfile (assuming the flat file is chmodded 666 and its containing directory is chmodded 777)


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
Whenever I use the stylesheet editor it breaks anything below the .new-alt-topicreplies [?] section. It just totally wipes it out no matter what style I am working on. I imported Ricks Black and Gold Style and it worked perfectly until I tried to edit it. I used both Firefox and IE 7 to test this with the same results. I can make any changes to any of the properties above that particular line and they will save but anything below it dissappears from my db and my css sheets when I use Update/Add Style. Boxes are left blank


Emerald Forest Gaming Community
Joined: Jun 2006
Posts: 16,299
Likes: 116
UBB.threads Developer
UBB.threads Developer
Joined: Jun 2006
Posts: 16,299
Likes: 116
Dumb question; what're you adding to it?


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
just changing the colors thats all. there is something thats breaking it though .new-alt-topicreplies shows up in the editor but .new-alt-topicviews [?] and anything thereafter gets erased


Emerald Forest Gaming Community
Joined: Jun 2006
Posts: 16,299
Likes: 116
UBB.threads Developer
UBB.threads Developer
Joined: Jun 2006
Posts: 16,299
Likes: 116
I think you may need to open a support ticket and have Rick take a look at it; the script shouldn't truncate any data from the database, let alone erase it from the system altogether... You'll want to include access information to your server (both FTP and SQL) in the ticket.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Apr 2007
Posts: 3,940
Likes: 1
SD Offline
Former Developer
Former Developer
Joined: Apr 2007
Posts: 3,940
Likes: 1
sounds like you have a version prior to the new css classes being implemented.

are you sure you are 7.2.2 ? :shrug:

SD #200291 10/30/2007 9:37 PM
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
Originally Posted by Sirdude
sounds like you have a version prior to the new css classes being implemented.

are you sure you are 7.2.2 ? :shrug:
Yup Im postive I upgraded 6.5.5 to 7.2.2 . All the classes work but I had to paste them (the missing ones) into my stylesheet manually. And importing css styles (like Ricks Black and Gold) work fine out of the box unless I try to edit them with the control panel. Then it wipes out everything below the value I noted above.

Last edited by ChAoS; 10/30/2007 9:53 PM.

Emerald Forest Gaming Community
ChAoS #200293 10/30/2007 10:55 PM
Joined: Apr 2007
Posts: 3,940
Likes: 1
SD Offline
Former Developer
Former Developer
Joined: Apr 2007
Posts: 3,940
Likes: 1
the i'd look @ the /admin/doupdatestyle.php

does the version (line ~ 14) say 7.2.2 ? that's where is saves it to the DB from the $_POST vars from the /templates/default/admin/editstyle.tmpl .. make sure the tmpl is too.

otherwise i'd have to see it in action.. :shrug:

SD #200294 10/31/2007 1:40 AM
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
yeah they both check out. I actually imported to a new directory when I did the import.


Emerald Forest Gaming Community
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
FYI Rick took a look at this and its the result of my host limiting the amount of form variables that can be passed to the scripts. And here I though I was going mad.Still waiting to hear from my host on this though

Thankyou Rick!


Emerald Forest Gaming Community
Joined: Dec 2006
Posts: 42
C
newbie
newbie
C Offline
Joined: Dec 2006
Posts: 42
Ok here is the update after this was fixed, This was a PHP setting PHP 5.2.4(Suhosin)

suhosin.post.max_vars was set at 200 needed to be changed to 500
suhosin.request.max_vars set at 200 needed to be changed to 500

Changing both of these values fixed my problems


Emerald Forest Gaming Community
Joined: Feb 2007
Posts: 16
P
stranger
stranger
P Offline
Joined: Feb 2007
Posts: 16
Originally Posted by ChAoS
Quote
that works ONE time. but if you then edit that particular style, it will grab the DB stuff and all your nice text edits are gonzo. that's why you'll see what looks like multiple copies of xxxx.css in your styles folder..

Lol , yeah thats what happened the first time and thats how I lost my originals. I still need a copy of the default DB's if anyone has them please smile

I think I am having an issue similar to what I've seen described in this thread.

I've edited my original theme and uploaded to a test environment under a new theme name, and the bulk of the style is applied. However, some of the pages are still pulling the stylesheet referenced by the last theme. I know this because I can see through a FireFox plug in that the name of stylesheet being referenced contains the name of the deleted theme as apposed to other pages which now reference a stylesheet containing the name of the newer updated theme. I can see no rhyme or reason why the old stylesheet should be referenced at all (the older theme was deleted). Am I correct in thinking it could be due to a database cacheing issue?

Unfortunately the links to my test environment won't work outside the office so I can't show examples.
I just want to be sure I won't encounter these problems when attempting to push the new style live, or be able to quickly address them if they are encountered.

Thanks,

Joined: Jun 2006
Posts: 3,837
I
Ian Offline
Carpal Tunnel
Carpal Tunnel
I Offline
Joined: Jun 2006
Posts: 3,837
It sounds more like browser cache issue - have you done a CTRL + refresh to try and pull it in from the server?

Ian #203877 12/26/2007 6:33 PM
Joined: Feb 2007
Posts: 16
P
stranger
stranger
P Offline
Joined: Feb 2007
Posts: 16
several times, and even from machines that hadn't yet been to the test environment. I even had our IT guys take a look at the test environment and the could see no reason why it should be showing up.

any other possible solutions?

Joined: Feb 2007
Posts: 16
P
stranger
stranger
P Offline
Joined: Feb 2007
Posts: 16
Well, I've applied my new style to our live production envrionment and I'm getting the same funky style caching issues.

Can anyone take a peak and see if they can figure out what's going on?

http://forum.sounddomain.com/ubbthreads.php

The correct style (as demonstrated on the above page) is named 'blue-gray' and all pages displaying correctly are referencing a stylesheet named 'blue-gray_1198876152.css'

but if you click from our forum list page through to 'Mobile Electronic News' (http://forum.sounddomain.com/ubbthreads.php/ubb/postlist/Board/40/page/1) this page is referencing a stylesheet named 'sound_off_1177536150.css' from the old style 'sound_off' which has been disabled in the control panel.

Any ideas why the old style is still applying itself to random pages like this?

PS. the only difference in styles are some color tweaks, the older style has different shades of gray/blue and an orange date and link hover settings.

Last edited by pupil; 12/28/2007 7:15 PM.
SD #204055 12/29/2007 10:35 AM
Joined: May 2007
Posts: 50
journeyman
journeyman
Joined: May 2007
Posts: 50
Originally Posted by Sirdude
Originally Posted by ntdoc
Should work just fine. Copy down to your workstation, use any editor you want, then copy back to the server and overwrite.


that works ONE time. but if you then edit that particular style, it will grab the DB stuff and all your nice text edits are gonzo. that's why you'll see what looks like multiple copies of xxxx.css in your styles folder..

the key is to use import or copy from existing to get a new db entry for the style then use the style editor in the control panel. when you 'save', the db entry is updated and a new xxxx.css file is created to be included by your forum.

ftp'ing doesn't cut it.
OK I have a support ticket on this
so you can't import a css file ?
I was trying to import my old css from v5.5
as I just upgraded from 6.3 to 6.5.5 took the time to update my css then upgraded to 7.2.2 thats where the problem came in .
I went to style editor & seen import so I was trying to import the css from 5.5 .
so after reading this thread what I come away with is
you can not import a old css file what you need to do is make a new one using the editor or copy the style 1 or 2 text file & edit that outside ubbthreads then upload it & go back to the editor ? is this correct
if so darn it import is misleading

dslam #204057 12/29/2007 10:42 AM
Joined: Jun 2006
Posts: 3,837
I
Ian Offline
Carpal Tunnel
Carpal Tunnel
I Offline
Joined: Jun 2006
Posts: 3,837
css files cannot be imported from pre 7 forums, as too much has changed.

Ian #204061 12/29/2007 10:46 AM
Joined: Jun 2006
Posts: 16,299
Likes: 116
UBB.threads Developer
UBB.threads Developer
Joined: Jun 2006
Posts: 16,299
Likes: 116
Correct, the import function only works within 7.x


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Ian #204062 12/29/2007 10:47 AM
Joined: May 2007
Posts: 50
journeyman
journeyman
Joined: May 2007
Posts: 50
ok thanks here I'v been waiting on support
Rick close the ticket

just got support here wink

dslam #204064 12/29/2007 10:54 AM
Joined: Jun 2006
Posts: 3,837
I
Ian Offline
Carpal Tunnel
Carpal Tunnel
I Offline
Joined: Jun 2006
Posts: 3,837
no worries smile .....


Link Copied to Clipboard
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Bots
by Outdoorking - 04/13/2024 5:08 PM
Can you add html to language files?
by Baldeagle - 04/07/2024 2:41 PM
Do I need to rebuild my database?
by Baldeagle - 04/07/2024 2:58 AM
This is not a bug, but a suggestion
by Baldeagle - 04/05/2024 11:25 PM
Is UBB.threads still going?
by Aaron101 - 04/01/2022 8:18 AM
Who's Online Now
1 members (Nightcrawler), 607 guests, and 159 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Preview build 20230217)