Previous Thread
Next Thread
Print Thread
Hop To
Joined: Dec 2008
Posts: 14
stranger
OP Offline
stranger
Joined: Dec 2008
Posts: 14
The automatic feeds on the "my stuff/feeds" areas give an error about cookies and being logged in after subscribing in IE7.
The feeds you make yourself aren't dynamic and thus use no login security (fixes the cookie problem, but raises a security one). They also can't be deleted once created and an error occurs when you try to turn off "active".
And none of the RSS feeds add header text to the forum pages for browser auto-discovery.
Also, the look of the RSS feeds for the my stuff ones and the manually created ones are different. One is formatted like normal posts, and the other appears to be filtered into plain text (no images, emoticons, or font colors).

Joined: Dec 2008
Posts: 14
stranger
OP Offline
stranger
Joined: Dec 2008
Posts: 14
More information on this.
The different looking feeds I believe are from when I created the manual feeds (in 7.2.2) and now. The down side is that it appears the feeds were not updating themselves. Perhaps it takes a new post to update the cached feed.
It also appears that the reason that the feeds are "always active" is because if the checkbox is unchecked it passes no value and the form page isn't smart enough to see an unchecked checkbox.

Joined: Dec 2008
Posts: 14
stranger
OP Offline
stranger
Joined: Dec 2008
Posts: 14
I'm not sure there is any way to fix IE RSS reader. From looking at the logs it appears that the IE uses a different AGENT when requesting the feed file once you have subscribed. What is really interesting is that even if you browse to the feed url through the website after you have subscribed it even sends that request with the different AGENT.
My guess is that because the AGENT is changing that it breaks the auto-login cookie. Or it isn't using the main browser's cookies at all. I'll just tell IE users that it is a browser problem and they can't access the all forums feeds.

There are still the issues of the missing link code in the header, not being able to delete (I had to get ride of mine through an sql delete), and the deactivate checkbox bugs. Would also be nice if those custom built feeds were dynamic urls instead of direct links to the cache folder.


Link Copied to Clipboard
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Like unlike bug?
by Morgan - 09/24/2020 5:03 PM
looking to renew :)
by Mors - 09/23/2020 7:52 PM
test
by Mors - 09/23/2020 7:51 PM
What triggers page view numbers
by Morgan - 09/21/2020 10:31 AM
Forum Permissions Question
by FREAK - 09/20/2020 2:13 PM
Who's Online Now
4 members (Gizmo, Morgan, Ruben, 1 invisible), 52 guests, and 61 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
gallery test
gallery test
by Mors, September 23
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Powered by UBB.threads™ PHP Forum Software 7.7.5
(Snapshot build 20200921)