Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
2 registered members (JAISP, mmkk), 65 guests, and 410 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Posts: 82
Joined: September 2008
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 14
FREAK 11
M4TT 8
mmkk 5
isaac 4
Ruben 3
Latest Photos
Chinese Buddhist temple.
My buddha beads.
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Previous Thread
Next Thread
Print Thread
Another Who's On Line Issue #221244
01/18/09 02:07 PM
01/18/09 02:07 PM
Joined: Jun 2006
Posts: 295
New Joisey!
FordDoctor Offline OP
enthusiast
FordDoctor  Offline OP
enthusiast
Joined: Jun 2006
Posts: 295
New Joisey!
Just upgraded to 7.4.2 and everything so far seems okay except I have problems with the Who's On Line and Members On Line islands in my layout. Yes, I have BOTH islands as choices so my first question is, should I?

Problem number one is that if I use "Who's On Line" it works properly in all screens but it does not show at when in the main forum view.

Problem number two is if I use Members On Line it does not work and I get an error message. It does however show in all screens. Here is the error:
Code
Members On Line 
 
if (!defined('UBB_MAIN_PROGRAM')) define('UBB_MAIN_PROGRAM',1); echo "";

include("/data/10/0/145/59/797548/user/817524/htdocs/forums/cache/online_now.php"); 

echo " ";  


Ford diesel master technician by day...
Webmaster by night! cool
FordDoctorsDTS.com running UBB Threads 7.5.4.2p2
Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: Another Who's On Line Issue [Re: FordDoctor] #221245
01/18/09 02:22 PM
01/18/09 02:22 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
Trying to get my head around this.
Who's online is a stock island.(It should work fine)
Members online is not a stock island: So it must be a custom island you added.(I think you have photopost at your site?)This could be the culprit.
You might try turning off Members online to see if Who's online shows everywhere.

Still can't see your site since I am not approved.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Another Who's On Line Issue [Re: Ruben] #221246
01/18/09 02:28 PM
01/18/09 02:28 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
Oh and by the way since you are with lunar now. The error you posted.
Quote:
include("/data/10/0/145/59/797548/user/817524/htdocs/forums/cache/online_now.php");

Does not look like a valid path. At least not for my account at lunar. Not even close.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Another Who's On Line Issue [Re: Ruben] #221247
01/18/09 03:25 PM
01/18/09 03:25 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
You know what, the more I look at your error I bet it is a custom island built for your chat program(Flashchat)


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Another Who's On Line Issue [Re: Ruben] #221248
01/18/09 03:56 PM
01/18/09 03:56 PM
Joined: Jun 2006
Posts: 295
New Joisey!
FordDoctor Offline OP
enthusiast
FordDoctor  Offline OP
enthusiast
Joined: Jun 2006
Posts: 295
New Joisey!
This site is not on the Lunar server yet. I wanted to upgrade the forums before I moved them. Also, the other islands have always been there and did not have any affect on this particular UBB island. But, since you never know, I will try turning all other islands off and see what I get. Also, I did not create either island, Who's On Line -or- Members OnLine. The Who's On-Line Chatting is not a stock island for sure, but it always has and continues to work. Don't confuse that one with the other two. wink


Ford diesel master technician by day...
Webmaster by night! cool
FordDoctorsDTS.com running UBB Threads 7.5.4.2p2
Re: Another Who's On Line Issue [Re: FordDoctor] #221249
01/18/09 04:18 PM
01/18/09 04:18 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
Well I am still confused with the Members online island. If that is what it is really called. Because it is not a stock island.

Here is a list of stock islands in 7.4.2 any others are user added.
Quote:
Search
Who's Online
Newest Members
Public Calendar
Private Calendar
Shout Box
Top Posters
Top Posters (last 30 days)
Forum Stats
Todays' Birthdays
Featured Member


Any island not named above is a post,gallery or custom island. Edited by the user.

Last edited by Ruben Rocha; 01/18/09 04:37 PM.

Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Another Who's On Line Issue [Re: Ruben] #221253
01/18/09 05:22 PM
01/18/09 05:22 PM
Joined: Jun 2006
Posts: 295
New Joisey!
FordDoctor Offline OP
enthusiast
FordDoctor  Offline OP
enthusiast
Joined: Jun 2006
Posts: 295
New Joisey!
Well, I got rid of all the old custom islands I don't need including that Members On Line island. I turned off all islands BUT the Who's On Line and the same thing happens. I reinstalled the original header and footer templates as I have made some minor modifications to them and tried it - nope. The island still disappears when I bring up the main forum list. Cleared cache on my forum and my browser, re-uploaded the template files. I am at a loss. It must have something to do with the Main Forum template but haven't a clue. This has been acting up since the upgrade.

I am out of ideas. Anybody?


Ford diesel master technician by day...
Webmaster by night! cool
FordDoctorsDTS.com running UBB Threads 7.5.4.2p2
Re: Another Who's On Line Issue [Re: FordDoctor] #221254
01/18/09 05:38 PM
01/18/09 05:38 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
Assuming your permissions are correct. You can manually ftp to the cache directory delete everything but the index.html file.
Sometimes that works.
It will force all the islands to be rebuilt.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Another Who's On Line Issue [Re: Ruben] #221255
01/18/09 05:59 PM
01/18/09 05:59 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
Okay it looks like the online island appears now but only on the portal and each forum but not on the forum summary.
Maybe try opening cp>portal layout. Double check island layout, make sure you don't have an island in duplicate locations even change something and change it back then resave layout.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Another Who's On Line Issue [Re: Ruben] #221256
01/18/09 06:04 PM
01/18/09 06:04 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
BTW it looks like the active topics menu is not working.
Might need to check your error logs.

Last edited by Ruben Rocha; 01/18/09 06:04 PM.

Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Another Who's On Line Issue [Re: Ruben] #221277
01/19/09 10:31 AM
01/19/09 10:31 AM
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
R
Rick Offline
Former Developer
Rick  Offline
Former Developer
R
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
Hmm, do you have any modifications at all? There really isn't anything in the code that would prevent it from displaying on one page but not another.

If it comes down to it, you might need to open a support ticket so I can take a closer look. I can't really think of anything other than some type of modification that's preventing it's display.

Re: Another Who's On Line Issue [Re: Rick] #221279
01/19/09 10:46 AM
01/19/09 10:46 AM
Joined: Jun 2006
Posts: 295
New Joisey!
FordDoctor Offline OP
enthusiast
FordDoctor  Offline OP
enthusiast
Joined: Jun 2006
Posts: 295
New Joisey!
Well, if what you mean by modifications is limited to adding, editing or removing UBB files then no, this is a clean upgrade. I did add two links to the header for the top menu which I had done in the prior version with no issues, I also added background color attribute to a table tag in the footer. Neither of those edits caused this as I removed the edited files and reinstalled the originals that came with the 7.4.2 zip file.

The custom islands I have are all ones I was previously using as well and they are working as they always have. I did try removing them (hiding) leaving only the Who's On Line island but that had no effect. To summarize, there is nothing different going on when the main forum view is selected than any other page. This is really odd! But everything else seems to be working properly for now. I no longer fear performing updates... it was easy. smile

Since this is an upgrade performed in advance of moving this web site and forum to a new host and server, should I just perform a fresh install on the new server and import my database and see what happens? It might also be a good idea to re-download the UBB zip file just in case something got corrupted in the process. If you want to investigate this I will fill out a support ticket but I cant do that until I get home and look up my license number.


Ford diesel master technician by day...
Webmaster by night! cool
FordDoctorsDTS.com running UBB Threads 7.5.4.2p2
Re: Another Who's On Line Issue [Re: FordDoctor] #221281
01/19/09 10:56 AM
01/19/09 10:56 AM
Joined: Feb 2007
Posts: 1,318
Pennsylvania
JAISP Online tapedshut
veteran
JAISP  Online Tapedshut
veteran
Joined: Feb 2007
Posts: 1,318
Pennsylvania
I did look at your chat online stuff and that is an IFRAME so that wouldn't have any effect either way. you using the same method I had used for the chat online box.

Re: Another Who's On Line Issue [Re: JAISP] #221295
01/19/09 03:13 PM
01/19/09 03:13 PM
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
R
Rick Offline
Former Developer
Rick  Offline
Former Developer
R
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
If you want, you can go ahead and upgrade and if the problem persists after that, then I can take a look and see if we can't track it down.

Re: Another Who's On Line Issue [Re: Rick] #221296
01/19/09 03:15 PM
01/19/09 03:15 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
He already did upgrade Rick.
That's what started this.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Another Who's On Line Issue [Re: Ruben] #221302
01/19/09 05:31 PM
01/19/09 05:31 PM
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
R
Rick Offline
Former Developer
Rick  Offline
Former Developer
R
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
Whoops, I meant the server move. Once it's actually moved over and the database transfered, then we can take a look.

Re: Another Who's On Line Issue [Re: Rick] #221319
01/20/09 06:33 AM
01/20/09 06:33 AM
Joined: Jun 2006
Posts: 295
New Joisey!
FordDoctor Offline OP
enthusiast
FordDoctor  Offline OP
enthusiast
Joined: Jun 2006
Posts: 295
New Joisey!
I performed a fresh install on my new server and pulled my database over. The problem does not exist with no custom files or my HTML header and footer inserts <--- forgot about those but again, those are present when every page loads too. I think I will begin my move and see how it goes.

There is a problem with my install though: I performed a fresh install and none of my custom files are on the server but my database has information related to them. If I am moving I need to copy over certain directories and files, or is it best to transfer everything, set my paths and file permissions and update the DB? I assume that would transfer the problem with it though. eek Sooner or later I am bound to figure this out!


Ford diesel master technician by day...
Webmaster by night! cool
FordDoctorsDTS.com running UBB Threads 7.5.4.2p2
Re: Another Who's On Line Issue [Re: FordDoctor] #221321
01/20/09 12:31 PM
01/20/09 12:31 PM
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
R
Rick Offline
Former Developer
Rick  Offline
Former Developer
R
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
You'll want to make sure you transfer your cache_builders/custom directory and then once everything is in place on the new server you can login to the control panel and rebuild the cache to force all your islands to be rebuilt.

Re: Another Who's On Line Issue [Re: Rick] #221359
01/20/09 11:39 PM
01/20/09 11:39 PM
Joined: Jun 2006
Posts: 295
New Joisey!
FordDoctor Offline OP
enthusiast
FordDoctor  Offline OP
enthusiast
Joined: Jun 2006
Posts: 295
New Joisey!
Well, it is safe to say this is not a bug but I am guessing you all suspected that from the start. I have transfered my forums to my new server and the Who's On Line disappearing on the main forum list page problem is not happening.

This is not a fresh install by the way, I zipped up my current live forums directory and unzipped it to my new server, set the file permissions, imported my database and ran the install script.

All seems well. This doesn't explain what the heck is happening on the live server at the moment but I am glad it is corrected. Thank you to all who offered help!


Ford diesel master technician by day...
Webmaster by night! cool
FordDoctorsDTS.com running UBB Threads 7.5.4.2p2
Re: Another Who's On Line Issue [Re: FordDoctor] #221366
01/21/09 10:19 AM
01/21/09 10:19 AM
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
R
Rick Offline
Former Developer
Rick  Offline
Former Developer
R
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
Glad to hear it got sorted out.

Re: Another Who's On Line Issue [Re: Rick] #221385
01/21/09 02:56 PM
01/21/09 02:56 PM
Joined: Jun 2006
Posts: 295
New Joisey!
FordDoctor Offline OP
enthusiast
FordDoctor  Offline OP
enthusiast
Joined: Jun 2006
Posts: 295
New Joisey!
Yeah, me too, but it is my nature to want to know why. It's a mechanic thing I guess.


Ford diesel master technician by day...
Webmaster by night! cool
FordDoctorsDTS.com running UBB Threads 7.5.4.2p2
Re: Another Who's On Line Issue [Re: FordDoctor] #221388
01/21/09 03:16 PM
01/21/09 03:16 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
You know I had some flaky things happen when I upgraded from classic to threads. Can't remember what they were now. But I upgraded from php4 to php5 and the problem went away. Then just as a test I changed back to php4 and the problem did not come back.

So as a mechanic you should know the old story. LOL
The customer brings the car in and says "It won't start when it is hot" you run it to death and it starts every time.

The problem could have been anything. such as a corrupted file on the server (php.ini,Etc)


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Another Who's On Line Issue [Re: Ruben] #221586
01/25/09 01:15 PM
01/25/09 01:15 PM
Joined: Jun 2006
Posts: 295
New Joisey!
FordDoctor Offline OP
enthusiast
FordDoctor  Offline OP
enthusiast
Joined: Jun 2006
Posts: 295
New Joisey!
Just to confirm, the problem I reported did not return on the new server after I migrated... and is also still not a bug.


Ford diesel master technician by day...
Webmaster by night! cool
FordDoctorsDTS.com running UBB Threads 7.5.4.2p2

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Shout Box Sound Effect
by M4TT. 11/29/17 08:28 PM
Ad island
by TGCsanderson. 11/25/17 06:41 PM
Taking to long to connect to DB
by AstroCat. 11/24/17 12:34 PM
I want to update forum but can't find license
by dimaninc. 11/23/17 10:51 AM
Thumbs Up/Rate Individual Posts
by M4TT. 11/22/17 01:11 PM
Forum Statistics
Forums36
Topics35,013
Posts190,528
Members12,045
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171106)