Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
0 registered members (), 74 guests, and 389 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Mark S
Mark S
Liverpool : England : UK
Posts: 4,704
Joined: July 2006
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 18
M4TT 12
FREAK 11
Ruben 8
isaac 4
mmkk 4
Latest Photos
Chinese Buddhist temple.
My buddha beads.
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Previous Thread
Next Thread
Print Thread
user_uploads now writable #222442
02/15/09 05:22 PM
02/15/09 05:22 PM
Joined: Jan 2005
Posts: 36
P
p74vic Offline OP
newbie
p74vic  Offline OP
newbie
P
Joined: Jan 2005
Posts: 36
We moved to a new server this morning, simply backed up the file structure and unarchived on the new server, now we get this error when testing the user_uploads directory from the cpanel

Directory exists but is not writeable.
Test failed. Either the directory was not found or cannot be written to by the web server.

Permission on this directory are 777, any thoughts?

Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: user_uploads now writable [Re: p74vic] #222444
02/15/09 05:34 PM
02/15/09 05:34 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
I used 755 for my attachment directory and it works fine.

But possibly the path may not be 100% correct.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: user_uploads now writable [Re: Ruben] #222449
02/15/09 08:09 PM
02/15/09 08:09 PM
Joined: Dec 2005
Posts: 141
Jakarta, Indonesia
KuKuKaChu Offline
member
KuKuKaChu  Offline
member
Joined: Dec 2005
Posts: 141
Jakarta, Indonesia
you may also want to check directory ownership.


JakChat.com -- Forums for Indonesia's English-speaking community
Ubuntu-Indonesia.com -- Forums for Indonesia's Ubuntu Users
Re: user_uploads now writable [Re: KuKuKaChu] #222632
02/18/09 02:35 PM
02/18/09 02:35 PM
Joined: Jan 2005
Posts: 36
P
p74vic Offline OP
newbie
p74vic  Offline OP
newbie
P
Joined: Jan 2005
Posts: 36
I checked the permissions and changed them to 755, still nothing. The owner is "crownvic" which is what everything else is owned by. Any more thoughts? I tried creating a new directory and moving the data and still it says Directory exists but is not writeable.

Re: user_uploads now writable [Re: p74vic] #222634
02/18/09 02:48 PM
02/18/09 02:48 PM
Joined: Apr 2007
Posts: 4,313
SoCal, USA
SD Offline
Carpal Tunnel
SD  Offline
Carpal Tunnel
Joined: Apr 2007
Posts: 4,313
SoCal, USA
there is a 'test.' file in that directory.. you'll need to chmod it (the file itself) to 666 or simply delete the file, so it can be recreated..

i believe that might be your problem smile

Re: user_uploads now writable [Re: p74vic] #222636
02/18/09 03:01 PM
02/18/09 03:01 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
Okay First question :
file permissions I know if I use wsftp it does not reflect the current permissions only what the last command was unless you close and reopen it.
Do you have another avenue to double check the permissions.
Second:
Since you moved to a new host the path may not be correct meaning your control panel has one path but you are changing permissions on a different directory.
Make a file called say pathto.php;
Insert
Quote:
<?php echo getcwd(); ?>
in the file . Upload it to the directory in queston. then run it from your browser.
This will verify what the absolute path is to that directory.

What sirdude says is correct also.
When you run the test it creates that file to see if the directory is writable. Maybe that file is bad if it exists.

Last edited by Ruben; 02/18/09 03:03 PM.

Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: user_uploads now writable [Re: SD] #222637
02/18/09 03:01 PM
02/18/09 03:01 PM
Joined: Jan 2005
Posts: 36
P
p74vic Offline OP
newbie
p74vic  Offline OP
newbie
P
Joined: Jan 2005
Posts: 36
Thanks, that did the trick!

Jason

EDIT: The test.file solution solved the permissions problem. Now we have an issue where new attachments are not being uploaded to the server, looking into that now.

Last edited by p74vic; 02/18/09 03:06 PM.
Re: user_uploads now writable [Re: p74vic] #222638
02/18/09 03:09 PM
02/18/09 03:09 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
Depending on the error that could just be a permission setting in the ubb control panel.
Who can upload,file type allowed, File size allowed,ETC.
If the settings were always there.
I recall a few users just had to open the options and resave the settings.
If it is a file size issue your new host may have a lower file size limit. You can check that in the control panel>>phpinfo


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: user_uploads now writable [Re: Ruben] #222643
02/18/09 04:41 PM
02/18/09 04:41 PM
Joined: Jan 2005
Posts: 36
P
p74vic Offline OP
newbie
p74vic  Offline OP
newbie
P
Joined: Jan 2005
Posts: 36
The forums show that a file has been uploaded and processes a new post. No file is created in the user_uploads directory however, this appears to be an issue with galleries too.

Jason

Re: user_uploads now writable [Re: p74vic] #222645
02/18/09 04:59 PM
02/18/09 04:59 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
Well if the upload is successful in the gallery area what do you get in the post.
Empty box with the old red x? But the post is there?
Sorry corrected this statement
For the Attachments (Not gallery) you have to enter two paths. Absolute and relative.
When you post a gallery item the software will name the actual file with a number prefix. Same as file attachments.
Also the gallery default directories full,medium,thumbs should be set to 777.
If they were wrong to begin with that may be another problem
Sounds like it may be a path issue at this point.
Try looking in your site for the files via ftp everywhere.

If not it may be time to call in the big gun and open a support ticket.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: user_uploads now writable [Re: Ruben] #222646
02/18/09 05:14 PM
02/18/09 05:14 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
What is the url to your board?


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: user_uploads now writable [Re: Ruben] #222647
02/18/09 05:22 PM
02/18/09 05:22 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
I assume you are at crownvic.net.
Something weird happened when opening a forum I got a popup message not the whole screen that stated "sessions directory to large". Never seen that before.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: user_uploads now writable [Re: Ruben] #222653
02/18/09 06:09 PM
02/18/09 06:09 PM
Joined: Mar 2007
Posts: 532
Massachusetts
SteveS Offline

addict
SteveS  Offline

addict
Joined: Mar 2007
Posts: 532
Massachusetts
The sessions directory currently has 1024 items in it (and climbing).


Steve

UBB.classic from 2000-2003
UBB.threads from 2003-present!
Re: user_uploads now writable [Re: Ruben] #222656
02/18/09 06:23 PM
02/18/09 06:23 PM
Joined: Mar 2007
Posts: 532
Massachusetts
SteveS Offline

addict
SteveS  Offline

addict
Joined: Mar 2007
Posts: 532
Massachusetts
Originally Posted by Ruben
Well if the upload is successful in the gallery area what do you get in the post.
Empty box with the old red x? But the post is there?
Correct. Post with empty box and red x.
Originally Posted by Ruben

Sorry corrected this statement
For the Attachments (Not gallery) you have to enter two paths. Absolute and relative.
Understood, and yes, we did.

Originally Posted by Ruben

When you post a gallery item the software will name the actual file with a number prefix. Same as file attachments.
Also the gallery default directories full,medium,thumbs should be set to 777.
If they were wrong to begin with that may be another problem
Sounds like it may be a path issue at this point.
Try looking in your site for the files via ftp everywhere.
We did, and have not located them.
Originally Posted by Ruben

If not it may be time to call in the big gun and open a support ticket.


Steve

UBB.classic from 2000-2003
UBB.threads from 2003-present!

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Users Unable to Upload Avatar [Not a Bug]
by M4TT. 12/13/17 08:51 AM
Shout Box Sound Effect
by M4TT. 11/29/17 08:28 PM
Ad island
by TGCsanderson. 11/25/17 06:41 PM
Taking to long to connect to DB
by AstroCat. 11/24/17 12:34 PM
Forum Statistics
Forums36
Topics35,015
Posts190,544
Members12,045
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171106)